Hardware Getting a x-rom to work in windows 10

lostatsea

New Member
OP
Newbie
Joined
Jun 1, 2016
Messages
3
Trophies
0
Age
81
XP
43
Country
United States
I found my old gba sp and decided to see if it still works. It does, but I don't really care for the games I last programmed on it. I last used it probably 2006 with a xp computer. I didn't realize how hard it is to use these legacy devices in the 64bit era.

I've found the drivers/little writer, and the thread in this forum about using virtual box. But I can't get it to work. I got the drivers for the usb writer to be recognized by windows xp virtualbox, so it is ready to use in the xp device manager. But littlewriter doesn't recognize the gba/sp and flashcart. I've tried little writer 1.0.8.3 and 1.0.8.4.

Does anybody still use a x-rom? How do I get the flasher working again?
 
Last edited by lostatsea,

Xanthe

Costco Executive Member
Member
Joined
Dec 23, 2015
Messages
908
Trophies
0
XP
971
Country
United States
Virtual Box tends to be horrific when it comes to the Guest OS seeing the USB drive, even when you've manually selected for it to be used on your Virtual Machine. I know this because I use a VM for day-to-day tasks. I would try using a different Virtual Machine program such as VM Ware before continuing
 

ferret7463

Well-Known Member
Member
Joined
Sep 21, 2010
Messages
612
Trophies
0
Age
47
XP
560
Country
United States
good to see some one else still has a working X-rom. I keep an old XP machine running in the basement for such things.
 

Rossa625

New Member
Newbie
Joined
Nov 5, 2021
Messages
2
Trophies
0
Age
21
XP
2
Country
United States
It's been 5 years, and I'm trying to get this to work too! On my XP machine, it's taking forever for Littlewriter to detect my 512mb X-rom cartridge. Anyone have ideas if this thread is still alive?
 

hartleyshc

Well-Known Member
Member
Joined
Oct 2, 2008
Messages
462
Trophies
0
Age
39
Location
Gainesville, FL
XP
899
Country
United States
It's been 5 years, and I'm trying to get this to work too! On my XP machine, it's taking forever for Littlewriter to detect my 512mb X-rom cartridge. Anyone have ideas if this thread is still alive?
You can try the official xrom flasher. I remember even back when this was a current card, I would use that more than Littlewriter for some reason I can't remember now.

Heres what I have saved for the xrom . The flasher, the drivers, and the testing tools. You should be able to test the cable with some of those. Its been years, but there is an included readme.

https://sites.google.com/site/hartleyshc/XROMFront.zip
https://sites.google.com/site/hartleyshc/X-Romdrivers.zip
https://sites.google.com/site/hartleyshc/xrom_testing_tools.zip

I'm making absolutely zero promises, but if I get bored over the weekend I might set up an XP VM and see if I can get it all working. It would be kind of nice to just flash it as some single cart.

But I've had this issue before back when flashers used parallel ports. On some revision of Windows (might have been XP that dropped it) they changed the way communications happen over a parallel port, so it was pretty much only used by LPT. At that time, even in VM it wouldn't work, and you'd have to have run Windows on bare metal.
 

Rossa625

New Member
Newbie
Joined
Nov 5, 2021
Messages
2
Trophies
0
Age
21
XP
2
Country
United States
Thanks for the files!

It seems that the X-ROM Frontend program is missing MsComCtl.ocx, or it's invalid. Perhaps my machine just needs updates?
 
General chit-chat
Help Users
    KennieDaMeanie @ KennieDaMeanie: Stay frosty