GC games not being detected/showing

Discussion in 'Wii - Hacking' started by KuraiSin, May 10, 2013.

  1. KuraiSin
    OP

    KuraiSin Newbie

    Newcomer
    5
    0
    May 10, 2013
    Canada
    Ok so I started modding my Wii and all that so I can play back ups of GC and Wii games. So far I got the Wii stuff to work but can't for the life of me figure out what im doing wrong with the GC part. My Wii is 4.3U.

    I followed the instructions from this site
    http://gwht.wikidot.com/dios-mios
    With a few changes. The DIOS MIOS is v2.9 and cfg is v70 with mod r51. I didn't see the option to "Set DML Version to DM" in cfg.

    My USB that has been formatted to FAT32 at 32KB and I made a folder named "games" at the root of the USB and used the DMToolbox to compress and create a folder with the game iso on my USB.

    Yet with this, cfg doesn't show the GC games and I even got USB Loader GX and Wiiflow to see if I could use those to play the GC isos but they don't show up on them either. I already tried multiple games that the compatibility test said it should work but none of them show up.

    Like I said before, I got Wii games working but the GC is driving me nuts so any help or suggestions would be much appreciated.
     
  2. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,537
    21,496
    Sep 13, 2009
    Poland
    Gaming Grotto
    Have you tried using DiscEx instead of DMToolbox? I know it's both tools by crediar himself but all my GC backups are converted with DiscEx, I never tried DMToolbox myself. :P It would also be nice if you could post what kind of a hard drive you have or at least the sector (not cluster) size as DIOS-MIOS is picky about that. To be specific, drives with 4KiB sector size will refuse to work with DIOS-MIOS.
     
  3. grossaffe

    grossaffe GBAtemp Addict

    Member
    2,727
    2,098
    May 5, 2013
    United States
    I've been using Fix94's GamecubeISOcompress to get my games ready for Dios Mios. Always have to ask these kinds of questions, but are your folders containing the images in your games folder, and are your images labeled "game.iso"? I also believe that your FAT32 partition is supposed to be the first primary partition on your HDD.

    Probably not the cause of your issues, but not all HDDs are compatible with DIOS MIOS. I know mine didn't seem to work (games showed up in CFG, but didn't load) so I had to switch to DML and run off my SD. Fortunately I had a 32GB MicroSDHC lying around unused.
     
  4. KuraiSin
    OP

    KuraiSin Newbie

    Newcomer
    5
    0
    May 10, 2013
    Canada
    Ok after a lot of messing around with what you guys said, I got DIOS MIOS lite and put the games on my SD card. After doing that the the GC games are finally showing up but now MIOS DIOS is giving me the "fatal error: apploader size is zero" problem. I've already taken a look at the following
    https://code.google.com/p/diosmios/wiki/FAQ#I_get_"Fatal_error_apploader_size_is_zero!"
    http://gbatemp.net/threads/dios-mios-lite-fatal-error-apploader-size-is-zero.341680/
    http://gbatemp.net/threads/fatal-error-apploader-size-is-zero-problem.347373/

    But still no luck. So you guys got any suggestions to what I should try?

    Edit: Ok now after a crap ton of trail and error and reinstalling stuff. I finally got it to work, so thx to the guys that bothered helping me.