GBAtemp V8 / tempStyle 3.2 feedback thread - post bugs or feedback here

shaunj66

GBAtemp Administrator
OP
Administrator
Joined
Oct 24, 2002
Messages
11,384
Trophies
2
Age
37
Location
South England
Website
www.gbatemp.net
XP
15,418
Country
United Kingdom
Please post feedback for tempStyle 3 in here.

If possible please provide screenshots or URLs to bugs or concerns you have...

KNOWN BUGS (AKA PLEASE READ FIRST):​

  • Editor toolbar is configured badly and many necessary buttons are missing on various display widths (awaiting feedback)
  • Patreon customisation is broken
  • Max signature display height is incorrectly configured (fixed - Costello)
  • Smilies are to be replaced with hi-def versions
  • Reaction smilies are to be replaced with hi-def versions
  • Members who had a blog prior to V8 now have 2 - one with the number of entries double what it actually is and another that is empty
  • Meme box preview has no prev & next meme buttons
  • Alerts are not marked as read when opening the alerts dropdown
  • "Disable affiliate videos" option is broken
  • Advertisements overlapping content
  • Recent content box shows threads from groups that are not joined
  • Former staff name is unreadable on black theme
  • Not enough difference between bold and regular text
  • Some BbCodes are not properly styled
  • Preferences page cuts off on FireFox on certain zoom levels.
 
Last edited by shaunj66,

AlexMCS

Human
Member
Joined
Jul 3, 2018
Messages
307
Trophies
0
Age
35
Location
Fortaleza
XP
1,417
Country
Brazil
Clicking on "The Meme Box" used to take me to the last unread post on the thread. There is no link there anymore.

The "Disable affiliate videos" setting seems to be broken for me, since the option still exists in preferences I assume this is probably a bug.

Preferences:
View attachment 276823

Still shows:
View attachment 276822

This one blew my mind though, I made a Greasemonkey script to hide those videos a looong time ago.
 

Sono

cripple piss
Developer
Joined
Oct 16, 2015
Messages
2,463
Trophies
2
Location
rehabilitation center
XP
5,500
Country
Hungary
@lone_wolf323 They want to increase engagement and visibility, but I think it's made each section look messy and I expect new threads to get buried quickly, which will end up turning people off.

Filter prefixes existed in XenForo 1.5.x too, but they were disabled here. And most web developers would recommend subforums and prefixes. Not just prefixes.

While I do sort of like the change despite the bad visibility and confusion issues, I do admit that a "wrapper" fake subforum would help eliminate confusion, which would do nothing, but automatically filter for a given prefix.
 
  • Like
Reactions: Seriel

Tweaker_Modding

Siezure Dice™
Member
Joined
Sep 1, 2017
Messages
387
Trophies
0
Location
Somewhere
Website
google.com
XP
934
Country
United Kingdom
B6FA253E-DB77-409C-99DB-107FF27DFDE8.jpeg
4A4937CE-90A6-4784-B65D-A76D8E1A68B8.jpeg

the ads are broken on mobile and the video ad covers most of the screen with no way of closing it
 

RichardTheKing

LoZ: Oracle remaster, plz!
Member
Joined
Mar 18, 2020
Messages
686
Trophies
1
Age
23
XP
1,355
Country
Australia
Yeah, on phone it's basically unbearable.



On desktop it looks really squished instead of shifted.


Edit: oh no, post merging doesn't work...
Managed to shift my avatar over in Preferences. Still doesn't look perfect, but close enough.
Oh, and custom title's cut off, as I mentioned in Chat. Right now, only one word's gones ("plz!"), but still...why?
 
  • Like
Reactions: Sono

Sono

cripple piss
Developer
Joined
Oct 16, 2015
Messages
2,463
Trophies
2
Location
rehabilitation center
XP
5,500
Country
Hungary
Okay, this is worse than I thought...

Not only does the site lag heavily on my phone without NoScript, but it takes almost a minute to load, freezes my entire phone for multiple seconds every so often, and I had to enable battery saver + underclock, as the battery drains away percent by percent in front of my eyes in real time as long as a tab is open >_>
 

KennieDaMeanie

Village Idiot
Member
Joined
May 26, 2013
Messages
713
Trophies
0
Age
29
XP
1,623
Country
Burkina Faso
Unsure if this has been mentioned but in the shoutbox mobile I can only reply if the cursor is added at the start of the sentr. I'm also using a Nord N10 I believe so it could be a cache error.
 

Noctosphere

Adoptive father of Zelda
Member
Joined
Dec 30, 2013
Messages
5,300
Trophies
1
Age
28
Location
In my sister's basement with kitty Zelda
XP
6,297
Country
Canada
Okay, this is worse than I thought...

Not only does the site lag heavily on my phone without NoScript, but it takes almost a minute to load, freezes my entire phone for multiple seconds every so often, and I had to enable battery saver + underclock, as the battery drains away percent by percent in front of my eyes in real time as long as a tab is open >_>
Omg you're right!
I was 80% half an hour ago, im now 55%
 
UPDATE SEPT. 25 (Costello)

Costello

Headmaster
Administrator
Joined
Oct 24, 2002
Messages
14,007
Trophies
2
XP
17,140
We knew there were gonna be a thousand things to fix, there they are :P

- We read and will take care of every problem and every message in this thread, but we have to prioritize. Thanks for your patience, if your issues aren't addressed yet, please rest assured that they will be eventually, we just need some time to fix all that.

- I have fixed the signature height issue. The limit is 120px at the moment (it was set to 75 yesterday)

- The automatic clearing of notification is something that can be enabled from your preferences.

- The ads are definitely broken, but we can't do aynthing about that (well we could disable them altogether but then we would go broke and die), we have emailed the ad network twice with "URGENT" in the subject, no reply so far, but it's the weekend so...

- The "disable affiliate video" option no longer works but right now we don't have control over that for the reason above. This is a top priority fix, we're working on it.

- We will definitely look into the mobile slowdowns and battery drain. Mobile browsing is very important to us so we'll make sure it's a smooth experience. Thanks for your patience. @RichardTheKing @Sono @Noctosphere

- All customizations will be back in due time but this isn't top priority, we need to address the more urgent things first, sorry about that, everyone.

- There were a few server glitches between yesterday night and this morning. Hopefully this explained some issues you guys ran into.

- We are looking into email subscriptions for new threads filtered by prefix. This is a tough one. But there might be some addons for it. If not, we will custom-code our own addon.

- The Chat addon needs some configuration. We are aware of issues and will correct them.

- @blackb0x I have seen your concerns expressed in this thread and the v8 announcement threads, they are certainly legitimate. We are collecting feedback and will ponder over it to find solutions that are acceptable to everyone. Thanks for your patience. Meanwhile why not try the Groups feature? It's meant to take some pressure/load off the main forums, especially for projects. Imagine a thread like CEMU with over 75 thousand posts. It seems like it would be better to have a group for this, especially considering that users can self-moderate their groups.

- The Meme Box will be receiving improvements soon to work the way it was working before on the old site. Thanks for your patience, this isn't top priority. Meanwhile just use the Meme box thread I suppose.

- Clicking on the Meme box widget title now will take you to the Meme box thread again, like it was before (this has been fixed).
 

KleinesSinchen

GBAtemp's Backup Reminder + Fearless Testing Sina
Member
GBAtemp Patron
Joined
Mar 28, 2018
Messages
2,522
Trophies
2
XP
5,574
Country
Germany
Not an urgent problem:

Attached pictures in old blog entries seem to be semi-broken. They are still there, but don't show embedded (but when clicked on).

I've tried to repair this one by editing. In the preview everything was embedded fine, but after saving the picture still wasn't embedded:
https://gbatemp.net/blogs/tempy-in-pearler-beads-heat-fuse-beads.17326/

You will notice it looks okay now: I've uploaded the same picture again (which is now attached twice, but only embedded once). The duplicate can only be seen on the edit page
Then I tried to delete one copy which again made the embedding not work. Next try: Delete both attachments to reupload afterwards. But this isn't possible. I can't delete both:
Blog2.png
Blog3.png

Again, certainly not an urgent problem, but something is definitely not right here.
 

RichardTheKing

LoZ: Oracle remaster, plz!
Member
Joined
Mar 18, 2020
Messages
686
Trophies
1
Age
23
XP
1,355
Country
Australia
We will definitely look into the mobile slowdowns and battery drain. Mobile browsing is very important to us so we'll make sure it's a smooth experience. Thanks for your patience. @RichardTheKing @Sono @Noctosphere
I'm not on mobile, I'm on my laptop. I never really do use GBAtemp on my phone.
 

hartleyshc

Well-Known Member
Member
Joined
Oct 2, 2008
Messages
449
Trophies
0
Age
39
Location
Gainesville, FL
XP
839
Country
United States
- @blackb0x I have seen your concerns expressed in this thread and the v8 announcement threads, they are certainly legitimate. We are collecting feedback and will ponder over it to find solutions that are acceptable to everyone. Thanks for your patience. Meanwhile why not try the Groups feature? It's meant to take some pressure/load off the main forums, especially for projects. Imagine a thread like CEMU with over 75 thousand posts. It seems like it would be better to have a group for this, especially considering that users can self-moderate their groups.
I'll second @blackb0x 's concerns.

Keeping the tags + subforums seems to me to be better usability.

In its current form, with my own personal browsing habits, the site is pretty difficult to just casually browse.
The auto assigning of tags is a huge start, I know it has to be done this way, but some of the older threads will be much harder to find now. Translation threads in GBA is a good example. Only 3 gba projects show up when you click Translations? Many of those older threads will never be updated with new tags.

Another example is the Flashing Hardware GBA subforum, which was pretty much the dedicated EZ Flash subforum. My flashcart is an EZFlash. There is no way for me to single out posts that would have only shown up in that forum. Now if I select hardware, I'll get posts for various hardware and not just what I have. Of course this can be fixed with new tags. but I'm not sure if you want to go down that road of "tag management" every few months to add/remove tags from the pool.

My last example will be the Switch forum. It's really difficult to read through. Why is there 3 different tags for homebrew? (homebrew, homebrew app, homebrew game). There's no Q&A or Support tag. Although I see some Question tag and Discussion tag in other posts. It seems you cant pick these when making a thread? There also seems to be a number of threads that have no tags, will tags be made a requirement? Then on the other side of things, I can see issues with people adding tags that aren't even relevant.

Who knows, I might be in the minority with how I read the site. I usually read every thread and every post in a handful amount of sub forums. Even with the tag system, it seems I will be self filtering a lot as I scroll through the threads.

I'm also assuming with the currently upgrade, tapatalk support has now been dropped.



On the good side of things, the mobile version is VERY usable, and the performance of the site (page loading mostly) has increased noticeably.
 
Last edited by hartleyshc,

Titney

Well-Known Member
Newcomer
Joined
Feb 1, 2014
Messages
78
Trophies
0
XP
733
Country
I'll second @blackb0x 's concerns.

Keeping the tags + subforums seems to me to be better usability.

In its current form, with my own personal browsing habits, the site is pretty difficult to just casually browse.
The auto assigning of tags is a huge start, I know it has to be done this way, but some of the older threads will be much harder to find now. Translation threads in GBA is a good example. Only 3 gba projects show up when you click Translations? Many of those older threads will never be updated with new tags.

Another example is the Flashing Hardware GBA subforum, which was pretty much the dedicated EZ Flash subforum. My flashcart is an EZFlash. There is no way for me to single out posts that would have only shown up in that forum. Now if I select hardware, I'll get posts for various hardware and not just what I have. Of course this can be fixed with new tags. but I'm not sure if you want to go down that road of "tag management" every few months to add/remove tags from the pool.

My last example will be the Switch forum. It's really difficult to read through. Why is there 3 different tags for homebrew? (homebrew, homebrew app, homebrew game). There's no Q&A or Support tag. Although I see some Question tag and Discussion tag in other posts. It seems you cant pick these when making a thread? There also seems to be a number of threads that have no tags, will tags be made a requirement? Then on the other side of things, I can see issues with people adding tags that aren't even relevant.

Who knows, I might be in the minority with how I read the site. I usually read every thread and every post in a handful amount of sub forums. Even with the tag system, it seems I will be self filtering a lot as I scroll through the threads.

I'm also assuming with the currently upgrade, tapatalk support has now been dropped.



On the good side of things, the mobile version is VERY usable, and the performance of the site (page loading mostly) has increased noticeably.
Agreeing with this too. I would mostly frequent the GBA and "Other handhelds" forums, and that is a complete mess now since it was all merged with retro home consoles. I mostly play GBC and Wonderswan right now, and there are no tags for those, not even a generic "other handheld" or something tag, so that content is completely buried now.
 

smileyhead

I like cute stuff.
Member
Joined
Aug 31, 2015
Messages
4,602
Trophies
3
Age
21
Location
Budakeszi, Hungary
Website
sites.google.com
XP
8,615
Country
Hungary
Some smaller, personal nitpicks:

1. I don't like the icon on the ‘Post reply’ button. I associate this glyph with quoting posts, not just replying to a thread in general:

1632557966316.png


2. When I jump to a post directly via a link, the view is scrolled a little too much up. Previously, I was only able to see the padding between the previous and the linked post below the menu bar, but now I can see a significant amount of the post above as well:

1632558150095.png
 

Deleted member 550701

Well-Known Member
Newcomer
Joined
Feb 4, 2021
Messages
81
Trophies
0
Age
20
XP
148
Country
Czech Republic
I love the new update except one singular thing, and that is, that you merged all of the console threads (for the specific consoles) together, it's messy and unorganized and the prefixes help just a bit. Otherwise love this update looks sleeker than ever, good job :) !
 
  • Like
Reactions: hippy dave

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,422
Trophies
2
Age
43
Location
Engine room, learning
XP
14,523
Country
France
Note : All tested on desktop version, using Waterfox.

- Is there a way to force "BB code" mode by default without clicking on the icon every time ? aka "don't use rich text editor" setting ?

- on the previous forum version, there were some mixed mode, where you used standard editor, but could still hightlight and click Bold, underline, or link, etc. to encapsulate your text with tags around it.
Now, if you use BB mode, it entirely disable the rich text features ! you can't click on ANY button anymore. you can't even add a picture or spoiler tags etc.
I find this new version hard to use.
Would it be possible to add the previous editor back in v8 ?
Some users even prefer the old "rich text" editor, because the new one hides useful icons by default.

- It's missing "Wiki" link category in the header. (maybe other things I forgot ? twitch/tv maybe)

- If you scroll down to the bottom of the browser's page... it's not the bottom of the forum. there is a huuuge empty gap at the bottom.
The end of the forum is about half the way.

- In the meme box picture viewer, there's no way to scroll to next/previous image anymore.
What would be great is a way to change the picture by scrolling the mouse wheel :) (along with added arrows on the side, for users without a mouse)
Though, you can now zoom in by clicking on the picture (great!) instead of liking it by mistake.

- Review center is all messed up

- On the home page, the subforum list might benefit from having "PS5" category ;)

- maybe we would need something to encourage users to attach tags to their newly created threads.
there are already a few without tags


- I have former staff's rights, but don't see the staff forum anymore.

- help > about :
The "masot" instead of Mascot
The current year is static (2020) instead of dynamic date(Y)
 
Last edited by Cyan,

Sono

cripple piss
Developer
Joined
Oct 16, 2015
Messages
2,463
Trophies
2
Location
rehabilitation center
XP
5,500
Country
Hungary
Is there a way to force "BB code" mode by default without clicking on the icon every time ? aka "don't use rich text editor" setting ?

It's sadly hidden in the three-dot menu.

1632562346938.png



It also annoys me that it requires an extra click now, as I was faster at using BBCode than figuring out where formatting options hide.

Edit: especially how there is not yet a way to make lists for example, BBCode is the only way at the moment to do it.
Edit2: it seems like it stays as you leave it as
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,422
Trophies
2
Age
43
Location
Engine room, learning
XP
14,523
Country
France
Yes, I know there is this option, but it's not possible to set it by default anymore :(
the setting in the preferences doesn't exist anymore.

Thanks for the help :)
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: Broke back to the future