GBA on N3DS 11.4 with LumaCFW?

Discussion in '3DS - Homebrew Development and Emulators' started by xXDungeon_CrawlerXx, May 10, 2017.

  1. xXDungeon_CrawlerXx
    OP

    xXDungeon_CrawlerXx GBAtemp Maniac

    Member
    1,194
    517
    Jul 29, 2015
    Liverpool
    Hey Guys,

    I just installed "Pokemon Clover VC Version" on my 3DS and wanted to play it.
    The Game doesn't start, have to shutdown the 3ds.
    I'm using a N3DS with Firmware 11.4 and Luma CFW (SysNAND).

    Other GBA Cias doesn't work, too.

    How do I get them to work?
     
  2. Robz8

    Robz8 Coolest of TWL

    Member
    6,802
    2,871
    Oct 1, 2010
    United States
    Install a clean AGB_FIRM CIA.
     
  3. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,794
    2,160
    Jan 11, 2016
    Japan
    日本
    -snip-

    I get an auto-shutdown with GBA/DS/DSiWare games
    Luma3DS's automatic patching reports when a patch fails, to make it easier to maintain the patches in the future and to prevent unintended consequences. This means that if you installed a pre-patched FIRM which contains the same patches applied by Luma, this will trigger an error (with manifests with an auto-shutdown). You can fix this by reinstalling the clean versions from Nintendo.

    1. Get the clean system titles package from -snip-
    2. From the package, copy O3DS AGB.cia and O3DS TWL.cia (if you have an Old 3DS), or N3DS AGB.cia and N3DS TWL.cia (if you have a New 3DS) to the SD card.
    3. Plug the SD in your 3DS and open your favorite cia installer (the guide has been tested successfully with FBI). If you don't have one it's outside the scope of this guide, check how to get your first cia installed on Plailect's guide (refer to the "Injecting FBI" section).
    4. Install the .cia files you copied in step 2.
    5. Luma3DS should now be functioning normally, you can delete the .cia files you used.
     
    Last edited by proflayton123, May 11, 2017
  4. BL4Z3D247

    BL4Z3D247 GBAtemp Stoner

    Member
    1,667
    409
    Oct 22, 2008
    United States
    I'm so high, I don't even know!
    You probably have to go into Luma's configuration and disable the option "show GBA boot screen in patched AGB_FIRM".

    Or do what the other two said.
     
    Last edited by BL4Z3D247, May 11, 2017
  5. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,794
    2,160
    Jan 11, 2016
    Japan
    日本
    What I said should help


    Sent from my iPhone using Tapatalk
     
    BL4Z3D247 likes this.
  6. BL4Z3D247

    BL4Z3D247 GBAtemp Stoner

    Member
    1,667
    409
    Oct 22, 2008
    United States
    I'm so high, I don't even know!
    Edited my post, we must've all posted around the same time as I didn't see any posts when I clicked reply. :) But yes, what you and Robz8 posted should sort them out.
     
    Last edited by BL4Z3D247, May 11, 2017
  7. NutymcNuty

    NutymcNuty GBATemp's Autismo

    Member
    320
    549
    Mar 24, 2015
    Canada
    Ottawa, Ontario
    aren't those clean system titles property of Nintendo/copyrighted?
     
  8. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,794
    2,160
    Jan 11, 2016
    Japan
    日本
    ive snipped just in case, well they're on lumas github.
     
    NutymcNuty likes this.
  9. xXDungeon_CrawlerXx
    OP

    xXDungeon_CrawlerXx GBAtemp Maniac

    Member
    1,194
    517
    Jul 29, 2015
    Liverpool
    Installed clean N3DS AGB and N3DS TWL, using latest LUMA.
    (x) Autoboot SysNAND
    ( ) Use SysNAND...
    ( ) Use custom paths
    ( ) Enable region/language emu.
    (x) show NAND or user string
    ( ) Show GBA boot
    ( ) Patch SVC/...

    Still blackscreen


    //EDIT
    Installed the lates hourly of Luma instead of the normal build and it works now.
     
    Last edited by xXDungeon_CrawlerXx, May 11, 2017
    proflayton123 likes this.