GBA Mario games

Discussion in 'M3 Adapter' started by Mega_Nift, Jun 28, 2008.

  1. Mega_Nift
    OP

    Mega_Nift Advanced Member

    Newcomer
    57
    0
    Mar 29, 2008
    United States
    niftundra
    no matter where i get the roms from, all the GBA mario games say the same thing when i try to play the game. "your saved data is corrupt" wtf its on all mario games for GBA! Super Mario Advace 1, 2, 3, and 4, Super mario pinball land, all of em! my other GBA games work just fine, but not my mario games. Whats up with this!?
     
  2. thedicemaster

    thedicemaster GBAtemp Addict

    Member
    2,428
    15
    Apr 26, 2008
    Netherlands
    you need to savepatch them.
     
  3. Fun_Zephyr

    Fun_Zephyr GBAtemp Fan

    Member
    320
    3
    Mar 19, 2008
    Victoria
    Hmm, I have the M3 Real with GBA Expansion pak and never had an issue loading Mario games. I believe I have seen the save data corrupted message - but I admitt I am not sure if it was for a mario game or not. Anyway, i just pushed my bottons and it continued on and played - again, I do nto remember for the life of me what game this was for.

    Anyway, I just delete my SMA1, SMA2, SMA3 save files and then loaded a new game and they have all loaded just fine with no errors and I have never save patched them - unless that has been previously completed prior to my download of them...
     
  4. thedicemaster

    thedicemaster GBAtemp Addict

    Member
    2,428
    15
    Apr 26, 2008
    Netherlands
    some GBA loaders detect, and autopatch troublesome roms.
     
  5. YoshiRiRu

    YoshiRiRu Member

    Newcomer
    23
    0
    Jun 22, 2007
    United States
    Make sure that you're running them in "Patch load" or "Low-speed" mode; that took care of my problems.
     
  6. Mega_Nift
    OP

    Mega_Nift Advanced Member

    Newcomer
    57
    0
    Mar 29, 2008
    United States
    niftundra
    thnx 4 the help but i figured out the problem within 15 minutes of my post, just needed to be low speed save type