1. Minitus

    OP Minitus Newbie
    Newcomer

    Joined:
    May 10, 2021
    Messages:
    1
    Country:
    United States
    hello guys, hopefully you can help me to save my GBA classic.

    the issue is: when I power it, the console turns on normally when it doesen't have a cartridge on it, but when i put a game on the slot it doesn't turn on ah the power on led just make a little green/red flash.

    if anyone knows whats happening to my dear console i would appreciate it!!!

    if you guys need vids of whats happening I can put it on the thread!
     
  2. FAST6191

    FAST6191 Techromancer
    Reporter

    Joined:
    Nov 21, 2005
    Messages:
    33,304
    Country:
    United Kingdom
    Usual guess is sounds like either the cartridge (try in another GBA slot device if you have one) or the GBA slot itself has an issue (most likely for the slot then a shorted pin). If you can correct it then do so. You might have to replace the slot, don't know if they sell them in mod shops offhand but various replacements have been available in the past.

    It could be something deeper but powering on without a cartridge does effectively serve as a test for a lot of the GBA hardware so I do return to something in the slot causing a short, or the cartridge itself causing much the same*.

    *if you are using an original GBA with rechargeable batteries and various flash carts that could also cause that -- if the flash cart needs more power than the 1.2V (as opposed to 1.5V of a nice alkaline battery) typical of a rechargeable then yeah. Same if you also have some kind of screen mod installed.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - electrical, classic, issue