Gateway save file compatibility when updating sysNAND from 4.5 to 9.2

Discussion in '3DS - Flashcards & Custom Firmwares' started by Epicbeardman, Jan 1, 2016.

  1. Epicbeardman
    OP

    Epicbeardman Member

    Newcomer
    12
    3
    Nov 26, 2010
    United States
    I'm a Gateway user and I've got an O3DS on 4.5, so I'm currently using MSET to boot into emuNAND. I was thinking of using rxTools to boot into devmode on sysNAND and then use sysupdater to update to 9.2, so that I can take advantage of themehax to coldboot into Gateway mode. But if I did this, would my save files still work? I'm asking this because I heard that the save crypto was changed somewhere between 4.5 and 9.2, but I'm not sure what the ramifications of this are for a Gateway user like myself who is looking to update sysNAND to 9.2.

    Also, what is the recommended version of rxTools to use for this process? Is the latest nightly ok or should I use a different version?

    Lastly, I'd just like to wish everyone at the temp a happy new year! I hope that 2016 treats you all well :)
     
  2. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    If you ever have problems with save encryption, see this topic. I actually had the problem you mentionned and solved it thanks to @The Real Jdbye :)

    And I use either the 10-02 or 10-24 version of rxTools. Everything works. They probably added things on later versions but broke others too so I never thought about updating.
     
  3. Elaugaufein

    Elaugaufein GBAtemp Regular

    Member
    211
    41
    Jan 26, 2010
    You can always use SaveDataFiler to dump the saves and then restore them if they don't work after you update.
     
  4. Epicbeardman
    OP

    Epicbeardman Member

    Newcomer
    12
    3
    Nov 26, 2010
    United States
    Well I took the plunge updating to 9.2 and all of my saves still work, and now I'm able to autoboot into Gateway mode. It took a while to get everything set up but it was well worth it in the end.
     
    Zidapi likes this.
  5. _v3

    _v3 GBAtemp Advanced Fan

    Member
    532
    264
    Oct 12, 2013
    Croatia
    If you go 4.5 > 9.2 your saves will work, the other way won't, reason being they changed the keys in 7.x
     
    Zidapi likes this.
  6. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    Not completely true. I had a MH4U save on an GW'd console on 4.5 sysNAND, then I updated my sysNAND to 9.2 and the save stopped functionning.
    All other games I tried were fine though so I'd say you're mostly right. I really don't know what was going on with that game in particular.
    And I confirm the fact that the other way doesn't work since I played Pokemon X on 7.X+ before downgrading to 4.5, and it stopped working...