Gateway puzzle on downgraded J N3DS LL

Discussion in '3DS - Flashcards & Custom Firmwares' started by RobotHelper, Apr 7, 2016.

  1. RobotHelper
    OP

    RobotHelper Newbie

    Newcomer
    7
    0
    Mar 31, 2016
    Guys, I’ve got a puzzle for you…

    First, I’ve been lurking here for a long time (many years!) and so I owe a huge thanks to this community for getting through many a tricky situation. Thanks everyone.

    This one, though, has got me completely stumped. Let me give you a brief (as possible) history:
    • Bought Japanese N3DS LL 10.3.0-20J in Tokyo

    • Followed Salamencizer’s excellent NOOB friendly guide to downgrading to 9.2: https://gbatemp.net/threads/noob-friendly-guide-to-downgrading-your-3ds-from-fw-10-7.418125/

    • I used oot3dhax with a physical cart and save dongle

    • I had exactly the same experience as reported in that guide by LoveHina:
      “I successfully downgraded from a JPN N3DS 10.4 to 9.1 with 9.2 CIAs. I know it's very strange.
      When I follow you guide, I can't get pass STEP 4 for checking JPN N3DS 9.2 CIA packs. It fails on 0004001000020900.cia. However, I downloaded and checked several times and MD5s. So I decided to downgrade.
      Anyway, I succeeded. Thanks Salamencizer for your tutorial!”
    • I then followed the latest Gateway manual and got as far as launching OoT and loading the Gateway save. On hitting A, the game freezes and nothing happens. Tried many attempts at this.
    • Over on the Max Console forums, user Zelda gave me some very dedicated and equally noob-friendly help and we did the following:

    So here’s my plan:
    1. Find a way to check the title versions for Japanese N3DS and see if they’re correct on my console
    2. Replace any that are the wrong version with the titles from the JP O3DS pack (using FBI)
    3. Try Gateway again and see if that fixed it

    Quiz questions for you:
    • Does anyone know a way (manual or automated) to check title version for a JP N3DS?
    • Has anyone downgraded a JP N3DS and successful used Gateway?
    • Does anyone have any other bright ideas?
    Cheers guys. Any replies very gratefully received.
     
  2. frosty5689

    frosty5689 GBAtemp Regular

    Member
    145
    53
    Jan 30, 2016
    There is a homebrew that checks your system if its full downgrade or partial. (in which case you need to run SysUpdater to complete downgrade). I'm not sure which version of SafeSysUpdater you used, but back when I downgraded my N3DS JP, the md5 hashes were for 9.1 firmware files, because the firmware package from that ISO site incorrectly labeled 9.1 as 9.2

    I would just forgo Gateway for now and setup ReiNAnd OR AuReiNAND CFW
     
  3. RobotHelper
    OP

    RobotHelper Newbie

    Newcomer
    7
    0
    Mar 31, 2016
    Thanks for replying. Is the homebrew you referred to the Download Check I referred to in the OP? It's this one: https://github.com/svanheulen/downgrade_check

    The problem with that is that it says it's checking against 9.2.0-20U (i.e. the US 9.2 titles). Have you had experience using it with JP and found the results to be accurate?

    I think you're right about skipping the Gateway altogether. Right now, I'm thinking next step is to run the downgrade again and see if it manages any better. Over on the Max Console thread, I was pointed to a SafeSysUpdater fork with a fix specifically for JP "9.2" hashes (I gather there was no 9.2 in Japan - only 9.1: just the wrong name stuck...), so I may give that a try: https://github.com/Plailect/PlaiSysUpdater

    Thanks again. Any other comments or suggestions welcome.

    R
     
  4. Binebina87

    Binebina87 GBAtemp Regular

    Member
    243
    68
    May 27, 2013
    Gambia, The
    Just my uneducated guess :-) :

    Wouldnt it be possible for you to run browserhax? If so you could run the gateway.3dsx and go into the GW menu and create an Emunand. And also set up Menuhax to Autoboot into GW Emunand.
     
  5. RobotHelper
    OP

    RobotHelper Newbie

    Newcomer
    7
    0
    Mar 31, 2016
    Thanks for the reply.

    An update: I just ran PlaiSysUpdater with the n3ds 9.1J titles and it seems to have successfully tidied up my downgrade. Downgrade check now reports just 2 different title versions and 1 extra title.

    GW menu will now launch (from OOT save), but "Boot Gateway Mode" crashes out to sys menu with cart slot not recognised and requires a reboot.

    My next plan is to fix those 2 titles with the wrong version by bringing them in from the o3ds fw, following this guide: https://gbatemp.net/threads/potential-reason-for-random-errors-on-n3ds-after-downgrading.410075/

    Will post results here for reference by others. Comments and suggestions still very welcome! Thanks.
     
  6. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,161
    9,523
    Sep 23, 2013
    oh i see you can get into the GW menu, try running diagnostics and see if that all passes, you can also hold "B" (iirc, it may be soething else) to boot into "sysnand Gateway mode" this can help you identify if its a issue with your emunand setup

    oh and you may be able to just setup emunand using a different cfw then update emunand to 10.7, afterwards you can use the 10.7 emunand with GW and any mismatched system titles should no longer be an issue
     
    Last edited by gamesquest1, Apr 9, 2016
  7. RobotHelper
    OP

    RobotHelper Newbie

    Newcomer
    7
    0
    Mar 31, 2016
    OK, everything's sorted. Thanks to everyone who replied.

    For later reference, should anyone stumble on this thread, here's how I finished up:

    Problem: I was following the GW manual and it fell down at the point that the Red Cart was supposed to update.
    Solution: I ignored that step and just carried on with the EmuNAND setup and the rest of the manual.

    So I didn't bother fixing the funny titles in my downgrade, and now I'm running 10.7 Emu and all is well.

    Thanks, gbatemp!
     
  8. Bu2d85

    Bu2d85 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    Bu2d85 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    961
    268
    Nov 6, 2014
    United States
    Setup MenuHax. Then you will no longer need the OOT cart to load GW. It takes less than 5 minutes to do.
     
  9. RobotHelper
    OP

    RobotHelper Newbie

    Newcomer
    7
    0
    Mar 31, 2016
    Thanks for that. Got MenuHax set up. Only slight problem is I have my big SD card in the 3DS and my small one in the Red Cart. Any way to swap these around (or to put games not the internal card)?
     
  10. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,509
    5,471
    Mar 17, 2010
    Norway
    Alola
    1. Back up all the files from the small card
    2. Create a new emuNAND on the small card using GW launcher or emuNAND9
    3. Dump the emuNAND from the big card and restore it to the small card with emuNAND9
    4. Copy all files over from the big card to the small card
    5. Format big card using SDFormatter and "Format Size Adjustment" set to on
    6. Restore the files you backed up in the first step to the big card
    7. All Done
     
  11. Bu2d85

    Bu2d85 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    Bu2d85 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    961
    268
    Nov 6, 2014
    United States
    I recommend just buying another SD card for your GW card if that is possible. With GW you can also install games directly to your system. You may not use this feature now but it is usefull for online games as the ones installed on your system do not have to be patched with a private header.
     
  12. RobotHelper
    OP

    RobotHelper Newbie

    Newcomer
    7
    0
    Mar 31, 2016
    Thanks guys.

    The Real Jdbye: gonna follow your steps right now - nice one
    Bu2d85: Would like to install games on the system directly - any how-to threads to get me started?
     
  13. Bu2d85

    Bu2d85 GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    Bu2d85 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    961
    268
    Nov 6, 2014
    United States
    Use FBI or BBM to install a .cia file (or similar, soon!2 is nice and noob friendly). Search the forum here.

    You can find the first two as a .3ds to use on your gateway card then you can use one of them to install soon!2 as it is a .cia file.

    All installable games are .cia. Google "that 3ds iso site" and you will find the downloads. You will have to create an account and there are a lot of pop-up adds but you get what you pay for.
     
    RobotHelper likes this.