Hacking gateway GW3D 11.10 (B9S AND CFW)

djnate27

Well-Known Member
Member
Joined
Mar 15, 2009
Messages
164
Trophies
0
XP
1,195
Country
United States
eShop won't work in the emunand, if you have private headers online play works fine

Eshop works fine booting the sysnand
Okay. Well, I've only been using emunand & Gatewaynand. My games & apps don't show up right in sysnand...so I don't use it. I don't care as much about the eShop...just wanted to go online in emunand.
 

CoolMe

.. Nani??
Member
Joined
Apr 16, 2019
Messages
810
Trophies
0
Age
26
XP
729
Country
United States
Okay. Well, I've only been using emunand & Gatewaynand. My games & apps don't show up right in sysnand...so I don't use it. I don't care as much about the eShop...just wanted to go online in emunand.
I can confirm that online works on Emunand.
 

ClancyDaEnlightened

GBAtemp Official Psychonaut
OP
Member
Joined
Jan 29, 2008
Messages
1,725
Trophies
1
Location
somewhere within 4 dimensional space-time
XP
2,465
Country
United States
Mine is 11.14, Haven't updated it to lastest but it still will work anyway

--------------------- MERGED ---------------------------

Does the new update already exist to install by sysUpdater on it?

If you update the emunand, just run sysupdater on the emunand using luma, you should already know how to install cia's and boot/install homebrew, otherwise booting gateway will just black screen
 
Last edited by ClancyDaEnlightened,

djnate27

Well-Known Member
Member
Joined
Mar 15, 2009
Messages
164
Trophies
0
XP
1,195
Country
United States
Mine is 11.14, Haven't updated it to lastest but it still will work anyway

--------------------- MERGED ---------------------------



If you update the emunand, just run sysupdater on the emunand using luma, you should already know how to install cia's and boot/install homebrew, otherwise booting gateway will just black screen
My emunand is now bugging me to update to 11.15.0-47U every time I start up. What's the best way to go about this so I don't lose my Gateway? Do I let it update when it prompts or cancel and manually go into Settings? I just don't want to mess anything up.
 

djnate27

Well-Known Member
Member
Joined
Mar 15, 2009
Messages
164
Trophies
0
XP
1,195
Country
United States
Every time I launch emunand, I'm prompted to update the system to 11.15.0-47U. Can I just update from there and be good (keeping my Gateway Mode) or should I use a different method?
 

djnate27

Well-Known Member
Member
Joined
Mar 15, 2009
Messages
164
Trophies
0
XP
1,195
Country
United States
Why not install CFW and get rid of Emunand as it's not needed anymore. You can copy Emunand to sysnand if you want, follow section IV here to do that https://3ds.hacks.guide/move-emunand.html
And update to the latest firmware,so you'll be nag-free.
But you can just back up saves/ cias and whatnot if you don't want to deal with it.
I'm not sure about the nag if it can be eliminated without switching to cfw, another user was having trouble with it too and there wasn't a solution for it at that moment.
I appreciate what you are saying...but I prefer to keep my ability to run Gateway. (For instance: I have game cheats that only run on Gateway,)

ClancyDaEnlightened (name changed) started this thread to show how to keep Gateway while enjoying newer system firmware. I was able to update to 11.14, but forgot exactly how I did it and was hoping he could weigh in.

11.15 maybe (presumably) be the last update and I know it shouldn't break functionality. If Nintendo was still pushing out regular updates then I wouldn't worry about it.
 

DeadSkullzJr

Developer
Developer
Joined
Sep 28, 2017
Messages
1,273
Trophies
0
XP
2,055
Country
United States
Every time I launch emunand, I'm prompted to update the system to 11.15.0-47U. Can I just update from there and be good (keeping my Gateway Mode) or should I use a different method?
Just update via system settings.
Why not install CFW and get rid of Emunand as it's not needed anymore. You can copy Emunand to sysnand if you want, follow section IV here to do that https://3ds.hacks.guide/move-emunand.html
And update to the latest firmware,so you'll be nag-free.
But you can just back up saves/ cias and whatnot if you don't want to deal with it.
I'm not sure about the nag if it can be eliminated without switching to cfw, another user was having trouble with it too and there wasn't a solution for it at that moment.
1. EmuNAND is a much safer approach to homebrew than messing with your system NAND. If something happened to your EmuNAND, the worst that happens is you have to either set it up all over again using the virgin SysNAND you have, or if you were smart and made a NAND backup of your EmuNAND, restoring that. It's much easier to replace SD cards than it is fixing a NAND chip when it's near dead from all the flashing and such.

2. I appreciate the fact you just asked instead of being hugely persistent and hell bent on this person to install custom firmware another way. The thing is I don't think people in this thread need a reminder of what's out there, they are well aware, but they wanted to use something different to achieve essentially the same goal as the modern setups. The way I see it, nobody really has a right to say anything on the matter given they didn't pay for the systems being used for this, it's the responsibility of the respective individuals whether people like it or not.

Message to anyone reading this:
If you can offer help to what these people use, then help, if you don't know anything on the matter, it's just best to leave the topic alone, and worry about your own stuff.
 

CoolMe

.. Nani??
Member
Joined
Apr 16, 2019
Messages
810
Trophies
0
Age
26
XP
729
Country
United States
Just update via system settings.

1. EmuNAND is a much safer approach to homebrew than messing with your system NAND. If something happened to your EmuNAND, the worst that happens is you have to either set it up all over again using the virgin SysNAND you have, or if you were smart and made a NAND backup of your EmuNAND, restoring that. It's much easier to replace SD cards than it is fixing a NAND chip when it's near dead from all the flashing and such.

2. I appreciate the fact you just asked instead of being hugely persistent and hell bent on this person to install custom firmware another way. The thing is I don't think people in this thread need a reminder of what's out there, they are well aware, but they wanted to use something different to achieve essentially the same goal as the modern setups. The way I see it, nobody really has a right to say anything on the matter given they didn't pay for the systems being used for this, it's the responsibility of the respective individuals whether people like it or not.

Message to anyone reading this:
If you can offer help to what these people use, then help, if you don't know anything on the matter, it's just best to leave the topic alone, and worry about your own stuff.
Oh! If Gateway works with the latest firmware then he should at least try it, with an emunand backup as last resort.
My response was based on the notion that he wasn't sure if it'll work/compatible or not, he seemed hesitant and i thought i'd present an easy alternative. It wasn't my intention to come off as preachy or anything like that, and i couldn't care less about what's someone's preferred way of running homebrew on their 3DS.
 

rocknard

Member
Newcomer
Joined
Mar 10, 2017
Messages
21
Trophies
0
Age
33
XP
157
Country
Hm... I don't get the tutorial very well (a little messy).

I have this:

-B9S and Luma (don't want fastboot3ds).
-Emunand GW3D 10.7.0-32E.
-old3DS_GW_v11.14.0-46E (downloaded from psxtools web mentioned here on last pages). Includes "updates" and "updates (update!)". I can't dowload the last "11.15.0-47" with 3dsnus (winxp problem maybe).

The tutorial say "if your emunand is 11.2 or below you don't need to downgrade ", so i must avoid the folder "updates" (contain 7 files) and do what? Since this tutorial start with v11.10, maybe his "downgrade" statement is only for that and not for the sysupdater files after update his 3ds, when you need to downgrade with that 7 files?

So, i'm on 10.7.0-32E and only need to "downgrade" with the 7 files from the "update" folder (booting on emunand with CFW to perform the downgrade) and then update normaly (with cfw or gateway?)? Can i use the update from "updates (update!)" if i want to avoid updating online?

Since author from sysupdater state to avoid running the app from a spoofer like gateway, i suppose i must use CFW to perform the task: "IMPORTANT: Don't run this with any sort of firmware spoofing enabled like Gateway mode/rx mode/whatever or it will brick!". And his author mention something about don't support higher firmware than 9.2.0 (don't get it: it's about downgrading until 9.2.0 or updating?).
 
Last edited by rocknard,

DeadSkullzJr

Developer
Developer
Joined
Sep 28, 2017
Messages
1,273
Trophies
0
XP
2,055
Country
United States
Oh! If Gateway works with the latest firmware then he should at least try it, with an emunand backup as last resort.
My response was based on the notion that he wasn't sure if it'll work/compatible or not, he seemed hesitant and i thought i'd present an easy alternative. It wasn't my intention to come off as preachy or anything like that, and i couldn't care less about what's someone's preferred way of running homebrew on their 3DS.
No worries, I didn't think you were being preachy, I was more so speaking more generally than specifically, sometimes I just make the mistake of not emphasizing that more accordingly, most people who know really are preachy and it kind of sucks. Anyways all he needs to do if he's worried is make a backup of his EmuNAND, if it didn't work the worst that happens is EmuNAND would never load, thus a NAND restore can fix it back. However given I run EmuNAND on one of my systems as well, I know it works because I have tried it.
 
  • Like
Reactions: CoolMe

djnate27

Well-Known Member
Member
Joined
Mar 15, 2009
Messages
164
Trophies
0
XP
1,195
Country
United States
Hm... I don't get the tutorial very well (a little messy).

I have this:

-B9S and Luma (don't want fastboot3ds).
-Emunand GW3D 10.7.0-32E.
-old3DS_GW_v11.14.0-46E (downloaded from psxtools web mentioned here on last pages). Includes "updates" and "updates (update!)". I can't dowload the last "11.15.0-47" with 3dsnus (winxp problem maybe).

The tutorial say "if your emunand is 11.2 or below you don't need to downgrade ", so i must avoid the folder "updates" (contain 7 files) and do what? Since this tutorial start with v11.10, maybe his "downgrade" statement is only for that and not for the sysupdater files after update his 3ds, when you need to downgrade with that 7 files?

So, i'm on 10.7.0-32E and only need to "downgrade" with the 7 files from the "update" folder (booting on emunand with CFW to perform the downgrade) and then update normaly (with cfw or gateway?)? Can i use the update from "updates (update!)" if i want to avoid updating online?

Since author from sysupdater state to avoid running the app from a spoofer like gateway, i suppose i must use CFW to perform the task: "IMPORTANT: Don't run this with any sort of firmware spoofing enabled like Gateway mode/rx mode/whatever or it will brick!". And his author mention something about don't support higher firmware than 9.2.0 (don't get it: it's about downgrading until 9.2.0 or updating?).
I think I confused myself somewhere down the line. I misspoke:
I followed the directions the best I could and updated my SysNand to 11.14 back when it released. My EmuNand was on 11.2 and Gateway worked beautifully. Yesterday I let the EmuNand update to 11.15, then I ran the sysUpdate.cia file and selected 'Downgrade'. Now Gateway only launches the splash screen before going blank. Not sure what I'm doing wrong.

Edit: Never mind. I figured it out.
 
Last edited by djnate27,
General chit-chat
Help Users
  • No one is chatting at the moment.
    DinohScene @ DinohScene: Open a thread in the respective section, you'll get more help there.