Hacking Games suddenly getting corrupted

ThePSGuy

Member
OP
Newcomer
Joined
Jan 17, 2018
Messages
24
Trophies
0
Age
45
XP
1,287
Country
France
Hello,

For obvious reason (not getting updates anymore), I recently made the jump from SX OS to Atmosphère on my Mariko unit with SX Core installed.

So Atmosphère is running OK except for the fact that I’m having an issue that never occured when I was on SX OS : for some reason, a few games that worked perfectly fine when I installed them are now unable to boot and tell me that some corrupted files have been found.

The Switch gives me the option to check for corrupted data which it did found after a few minutes but this doesn’t fix the issue at all. It just ask me to re-download the game.

Re-installing the game fixes the issue but this is a temporary workaround because the problem pop again after some time.

Now it’s time for some background information :

-I used this tutorial to jump from SX OS to Atmosphère : https://rentry.co/MarikoEmuNAND

-I’m running Atmosphère 0.19.5 on an emuMMC with FW 12.1.0 installed.

-My SD card is an original SanDisk card formatted to FAT32.

-I downloaded ITotalJustice’s latest signature patches and used the hekate.zip patches. I’m not sure if I should have used these ones or the fusee.zip ones but I guess I should have because I’m booting Atmosphère via Hekate (right?).

-I installed all my games using DBI Installer because I had a lot of random issues installing them with Goldleaf or Tinfoil.

-The games I’m talking about are Super Mario 3D All Stars and Need for Speed Hot Pursuit Remastered. I have already tried installing NSP files from a different source but the problem still occurs.

That’s it. Does anyone have encountered the same issue that I have and have an idea on how to fix it ? I want to insist on the fact that all my games works perfectly fine (initially) including the ones that eventually gets corrupted after some time.

Thank you very much.
 

Boydy86

Well-Known Member
Member
Joined
Jun 3, 2019
Messages
107
Trophies
0
Age
35
XP
268
Country
United Kingdom
Definitely sounds like an SD card issue. Trying to find a bargain, and or using the likes of ebay for removable storage has caused me headaches for years. Just not worth it. Buy only from reputable retailer, directly.
 

wiiNinja

Well-Known Member
Member
Joined
Jan 13, 2009
Messages
596
Trophies
0
XP
974
Country
United States
It does sound like the SD card is going bad. If you have a smaller SD card lying around, test out that theory by installing the same way you did with your current card, then test out one of the games that were corrupted. Even cards from legit sources go bad sometimes, and eventually.
 

ThePSGuy

Member
OP
Newcomer
Joined
Jan 17, 2018
Messages
24
Trophies
0
Age
45
XP
1,287
Country
France
Thanks for the answers everyone but why would the problem only happen now that I switched to Atmosphère? I have been using SX OS since late 2020 with this same SD card without any issue.
 

Kallrkyle

Well-Known Member
Member
Joined
Jul 23, 2021
Messages
211
Trophies
0
Age
50
XP
247
Country
Denmark
Thanks for the answers everyone but why would the problem only happen now that I switched to Atmosphère? I have been using SX OS since late 2020 with this same SD card without any issue.


Well TBH things just happens from time to time, like HDD gets bad sectors from one day to the next
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
16,684
Trophies
1
Age
27
Location
New York City
XP
11,234
Country
United States
Thanks for the answers everyone but why would the problem only happen now that I switched to Atmosphère? I have been using SX OS since late 2020 with this same SD card without any issue.
Atmosphere requires external patches to launch backups unlike SX OS and not all places have the most updated patches.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    SG854 @ SG854: https://youtu.be/m_6dkzL4VS4