Game Menu Gone... Unable to load game in DS or GBA

Discussion in 'M3 Adapter' started by Dis, Dec 7, 2006.

Dec 7, 2006
  1. Dis

    Dis Newbie

    I don't know wtf happen...
    I am using M3 (Early released FAT SD version)
    It nolonger has my game menu or pdf menu (both NDS and GBA Mode)
    I tried updating to lastest firmware and downgrading to older firmware and nothing works.
    PICS here: GBA Screen
    and DS Screen

    Anyone encounter the thing or has any solution for it?

    Formating SD card and using other SD cards doesn't helps either.
  2. Dis

    Dis Newbie

    After trial and error I found that the highest i could go up now is to 21...
  3. atticusfinch

    Newcomer atticusfinch Newbie

    Mar 1, 2006
    United States
    I'm not sure but mine started doing this about a month ago , I haven't found a solution yet. Hopefully somone will.

    btw it's also the fat sd m3
  4. Dis

    Dis Newbie

    Tried 21 Game Manager and can't played any games.
    It either hangs at 100% loading or didn't even load and gives me "PSRAM failed Message"
    Still work for movie playing with it's default player.
    Never tried Moonshell...

    Think maybe it's time I consider a slot-1 unless someone found a way to fix it soon.
  5. Dis

    Dis Newbie

    I send an e-mail to
    And below is the reply.

    Hi ,

    Your M3 should be faulty .
    It also be caused by the M3 case itself. Some people have had success by
    loosening the screw that holds the two halves of the case together.
    If you still can't fix the problem , you need to contact your reseller to
    replace it .



    1) I tried playing with the case tightening and lossening add in thick paper inside, tap up the battery, thick paper between M3 and NDS, Paper clip between M3 and NDS etc.
    You name it and I tired it.

    Results = Still the same


    2) My reseller only offer 12 months and I think that expired already.
    Cos I got the FAT SD M3 as soon as it came out, which is 100% > 12 months.

    So looks like I will probably be getting a new slot-1 now.
    And as for my M3, it's really a movie player ONLY now.


Share This Page