Hacking Game backup installs but crashes one minute in

Gep_Etto

Well-Known Member
OP
Member
Joined
Mar 1, 2021
Messages
114
Trophies
0
XP
226
Country
Brazil
UPDATE: THE PROBLEM IS SOLVED. I decided to have another go at the cheats thing so I got rid of my EdiZon folder, which was full of stuff, and copied over the folder from GitHub. For some reason I decided to try the game again before launching EdiZon, and it worked. So either it was the downloaded cheat files that were somehow getting in the way (unlikely since I had set dmnt_always_save_cheat_toggles = u8!0x0 in the system_settings.ini file) or the problem magicked itself away.

I also noticed that the game autosaves at exactly the moment when it was crashing before. Hopefully I won't have to deal with this again with future saves, auto or not.


UPDATE 2: SAVING WORKS FINE. Autosaves as well as manual saves do not crash the game. I still have no idea what caused this issue or what solved it, but I'm not a fan of looking gift horses in the mouth and I'm just glad that everything is working. I'm sorry that this post won't be very useful to anyone who finds it while Googling the same/a similar issue.

Hi all, I'm having a little problem getting a game to run. Hopefully somebody here can shine a light.

THE PROBLEM:
Bravely Default II installs with no errors, loads fine and starts a series of cutscenes after "New Game" has been selected from the title screen. As soon as the last cutscene ends, a tutorial page opens. After that page is dismissed and you get to the part where you can finally control your character for the first time, the game immediately crashes with the unhelpful message "The software was closed because an error occurred."

WHAT I'VE TRIED:
The first thing I thought was that it must have been a corrupt file or some problem with the installation that went undetected. So I tried installing in total three different downloaded backups (two .nsp and one .xci files from different sources) and finally a .nsp that I dumped myself with nxdumptool from another Switch where the game had been downloaded from Nintendo's eshop. I also tried different installers (Awoo, Goldleaf and TinWoo) and different installation methods (split .nsp from my microSD card, via USB with Quark and ns-usbloader, via a USB HDD and via LAN).

I did every permutation of the above and then decided to update my Switch. So I deleted everything but the Nintendo folder on my SD card, updated the Switch firmware via the OFW then downloaded the latest version of Atmosphère, Hekate and all the homebrew I used from their respective Github pages. Finally, I downloaded the latest sigpatches with All-in-One Switch Updater and tried my self-dumped .nsp again. Not just an update, but a fresh install! Unfortunately, none of this worked, it was just a huge waste of time and patience.

I remembered that some games do this intentionally as an anti-piracy measure, such as the DS version of Dragon Quest V, where there's actually a cheat that you can activate to bypass the problem and play normally. I tried but failed to get EdiZon SE to work (it just displays the first game on my home screen list and complains about dmnt being detached from the game process, whatever that means), and Checkpoint just claims that there are no cheats for this game, which is fair since it just came out but according to AIO Installer there is at least one cheat, so I'm left wondering if it's just refusing to work for some reason.

THE SOFTWARE:
I bought this Switch the month it came out, so it's a first wave model with nothing patched, if that makes a difference. I'm on 11.0.1|AMS M.18.1|S, With the latest version of everything I mentioned above as of yesterday afternoon, when I downloaded all of it. I am not using an eMMC/EmuNAND because my Switch is already banned anyway. Bravely Default 2 has no updates or DLC available yet, so what I'm trying to install is simply the base game.

MORE INFO:
Other games, both installed from the eShop before the ban and from downloaded backups, are running correctly. All my homebrew forwarders stopped working after the update and I haven't gotten around to reinstalling them, but launching homebrew from hbmenu works normally.

That's it. Hopefully all the information needed to crack this case is included in this post. If there's something important I left out, please ask me and I'll provide it. I've been looking forward to playing this game for a while now and this situation is really crumbling my cookie.
 
Last edited by Gep_Etto,

bigdom89

Well-Known Member
Newcomer
Joined
Sep 18, 2018
Messages
67
Trophies
0
Age
32
XP
906
Country
United States
UPDATE: THE PROBLEM IS SOLVED. I decided to have another go at the cheats thing so I got rid of my EdiZon folder, which was full of stuff, and copied over the folder from GitHub. For some reason I decided to try the game again before launching EdiZon, and it worked. So either it was the downloaded cheat files that were somehow getting in the way (unlikely since I had set dmnt_always_save_cheat_toggles = u8!0x0 in the system_settings.ini file) or the problem magicked itself away.

I also noticed that the game autosaves at exactly the moment when it was crashing before. Hopefully I won't have to deal with this again with future saves, auto or not.


UPDATE 2: SAVING WORKS FINE. Autosaves as well as manual saves do not crash the game. I still have no idea what caused this issue or what solved it, but I'm not a fan of looking gift horses in the mouth and I'm just glad that everything is working. I'm sorry that this post won't be very useful to anyone who finds it while Googling the same/a similar issue.

Hi all, I'm having a little problem getting a game to run. Hopefully somebody here can shine a light.

THE PROBLEM:
Bravely Default II installs with no errors, loads fine and starts a series of cutscenes after "New Game" has been selected from the title screen. As soon as the last cutscene ends, a tutorial page opens. After that page is dismissed and you get to the part where you can finally control your character for the first time, the game immediately crashes with the unhelpful message "The software was closed because an error occurred."

WHAT I'VE TRIED:
The first thing I thought was that it must have been a corrupt file or some problem with the installation that went undetected. So I tried installing in total three different downloaded backups (two .nsp and one .xci files from different sources) and finally a .nsp that I dumped myself with nxdumptool from another Switch where the game had been downloaded from Nintendo's eshop. I also tried different installers (Awoo, Goldleaf and TinWoo) and different installation methods (split .nsp from my microSD card, via USB with Quark and ns-usbloader, via a USB HDD and via LAN).

I did every permutation of the above and then decided to update my Switch. So I deleted everything but the Nintendo folder on my SD card, updated the Switch firmware via the OFW then downloaded the latest version of Atmosphère, Hekate and all the homebrew I used from their respective Github pages. Finally, I downloaded the latest sigpatches with All-in-One Switch Updater and tried my self-dumped .nsp again. Not just an update, but a fresh install! Unfortunately, none of this worked, it was just a huge waste of time and patience.

I remembered that some games do this intentionally as an anti-piracy measure, such as the DS version of Dragon Quest V, where there's actually a cheat that you can activate to bypass the problem and play normally. I tried but failed to get EdiZon SE to work (it just displays the first game on my home screen list and complains about dmnt being detached from the game process, whatever that means), and Checkpoint just claims that there are no cheats for this game, which is fair since it just came out but according to AIO Installer there is at least one cheat, so I'm left wondering if it's just refusing to work for some reason.

THE SOFTWARE:
I bought this Switch the month it came out, so it's a first wave model with nothing patched, if that makes a difference. I'm on 11.0.1|AMS M.18.1|S, With the latest version of everything I mentioned above as of yesterday afternoon, when I downloaded all of it. I am not using an eMMC/EmuNAND because my Switch is already banned anyway. Bravely Default 2 has no updates or DLC available yet, so what I'm trying to install is simply the base game.

MORE INFO:
Other games, both installed from the eShop before the ban and from downloaded backups, are running correctly. All my homebrew forwarders stopped working after the update and I haven't gotten around to reinstalling them, but launching homebrew from hbmenu works normally.

That's it. Hopefully all the information needed to crack this case is included in this post. If there's something important I left out, please ask me and I'll provide it. I've been looking forward to playing this game for a while now and this situation is really crumbling my cookie.

I too have this problem and IDK why can anyone please help???
 

bigdom89

Well-Known Member
Newcomer
Joined
Sep 18, 2018
Messages
67
Trophies
0
Age
32
XP
906
Country
United States
Did you try deleting your cheat files? That's apparently what worked for me, though I have no idea why. Also, if you're using Tinfoil, try another installer like TinWoo.
yes lol after fully and thoroughly reading your whole post I did delete the cheat code folder associated with the game and then it worked flawlessly. So thank you!
 

Retroboy

Well-Known Member
Member
Joined
May 28, 2015
Messages
2,983
Trophies
1
XP
3,166
Country
United States
check edizon settings and cheat files to make sure it is not trying to enable cheats on boot.

its not advised to enable cheats before the game has loaded up.

also enable cheats one at a time as many public users do not test their codes and dont work/crash
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • T-hug @ T-hug:
    Dune 2021 1080p HDRip X264 AC3-EVO
    Gift
  • kenenthk @ kenenthk:
    Dune? Reminds me of seeing my ex naked
    Gift
  • mr_switch @ mr_switch:
    Oh yeah Dune movie is out, watching it later
    Gift
  • mr_switch @ mr_switch:
    Here is hoping 2022 is a good year for DC cinematic universe
    Gift
  • gudenau @ gudenau:
    Honestly don't really know what Dune is.
    Gift
  • gudenau @ gudenau:
    Anyone here know much about Jetbrains InteliJ Idea?
    Gift
  • Sonic Angel Knight @ Sonic Angel Knight:
    Oh, T-hug was here :blink:
    Gift
  • Sonic Angel Knight @ Sonic Angel Knight:
    Hey, where the admins at? Come in the chat. I got a idea. How bout a Sound notification or something when someone tags you in chat? :ninja:
    Gift
  • DinohScene @ DinohScene:
    Post it in the v8 feedback thread
    Gift
  • Gift
  • OzKenny1983 @ OzKenny1983:
    Post what sorry? I'm guessing we were talking about this ages ago, but I haven't been on GBATemp in almost a year so my memory is failing me :-/
    Gift
  • DinohScene @ DinohScene:
    feedback and or bugs that may have popped up since the migration to XenForo 2!
    Gift
  • OzKenny1983 @ OzKenny1983:
    Umm...I think you might have the wrong person, since that may as well have been written in Chinese. I have nothing to do with the management of this site, nor have I ever been involved. I'm just a member, and hardly even qualify as that...like I said my last post was almost a year ago lol
    Gift
  • DinohScene @ DinohScene:
    Lol no, Sonic Angel Knight had an idea, best would be to post it in that thread haha
    Gift
  • OzKenny1983 @ OzKenny1983:
    Sorry, don't know Sonic Angel Knight either...
    Gift
  • The Real Jdbye @ The Real Jdbye:
    this new xenforo version keeps logging me out, whyh
    Gift
  • godreborn @ godreborn:
    not sure. I haven't had that issue. the only computer related issue I've been having is with my isp and the smtp server getting authentication errors randomly. I'm going to have to call them again. this started happening again after changing my password.
    Gift
  • godreborn @ godreborn:
    you may have to check the box that says "stay signed in." psx place used to have a problem like this for random people, including myself. that will prevent being logged out or it did anyway.
    Gift
  • The Real Jdbye @ The Real Jdbye:
    it's happened 3 times already and of course i ticked the box
    Gift
  • linuxares @ linuxares:
    Yeah happened to me as well
    Gift
  • Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    just installed gentoo, i came out alive somehow
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    honestly the install itself wasn't that hard, the hard part was getting my hardware to work
    Gift
  • x65943 @ x65943:
    Is it true what they say, did your neck sprout hairs afterwards?
    Gift
  • The Real Jdbye @ The Real Jdbye:
    good luck actually using it
    Gift
    The Real Jdbye @ The Real Jdbye: good luck actually using it