(Galaxy Eagle) GEi on 3DS 2.1.0-3u?

Discussion in '3DS - Flashcards & Custom Firmwares' started by sp3ctr3, Jul 20, 2011.

Jul 20, 2011
  1. sp3ctr3
    OP

    Newcomer sp3ctr3 Member

    Joined:
    Jul 20, 2011
    Messages:
    10
    Country:
    United States
    Well, I read the sticky, but kinda throwing this out in hopes that maybe it wasn't updated, or someone forgot to post.

    I got the Galaxy Eagle: (http://ge.ndsi.in/)
    Firmware: 1.4 I believe.
    Kernel: 3.4
    (Please, no negative comments. This is currently the only "cart" I got access to. Planning to get a Supercard DSTWO sometime to replace this.)

    And a 3DS:
    1.0.0-0u

    If I update the firmware on the GEi to 2.0 and then update my 3DS to 2.1.0-3u, will I still be able to use the GEi?


    tl;dr In short, is GEi compatible with the latest 3DS update?
     
  2. Slyakin

    Member Slyakin See ya suckers

    Joined:
    Oct 15, 2008
    Messages:
    4,450
    Location:
    Soviet Slyakin
    Country:
    United States
    I don't think that the GE has compatibility with the newest 3DS firmware; Wasn't it abandoned a while ago?
     
  3. sp3ctr3
    OP

    Newcomer sp3ctr3 Member

    Joined:
    Jul 20, 2011
    Messages:
    10
    Country:
    United States
    I don't think so? It had a new update just last month.
     
  4. Slyakin

    Member Slyakin See ya suckers

    Joined:
    Oct 15, 2008
    Messages:
    4,450
    Location:
    Soviet Slyakin
    Country:
    United States
    Oh, then chances are it has kernel upgrades somewhere. As to where, I'm sorry, but I don't know.

    The GE is a rather unknown cart; Someone else on the site should know.
     
  5. sp3ctr3
    OP

    Newcomer sp3ctr3 Member

    Joined:
    Jul 20, 2011
    Messages:
    10
    Country:
    United States
    Oh! Their site has everything I need.

    http://ge.ndsi.in/

    I was just asking if the GEi (Updated to 2.0 Firmware which "supports the latest 3DS 2.0 and DSi 1.4.2 as well".) was compatible with the latest 3DS update (2.1.0-3u).
     
  6. Slyakin

    Member Slyakin See ya suckers

    Joined:
    Oct 15, 2008
    Messages:
    4,450
    Location:
    Soviet Slyakin
    Country:
    United States
    I would believe so.

    You should test it for us! Any knowledge of the topic would be greatly appreciated!
     
  7. sp3ctr3
    OP

    Newcomer sp3ctr3 Member

    Joined:
    Jul 20, 2011
    Messages:
    10
    Country:
    United States
    Oh, I plan to. (OCD compels me to have the latest updates.)

    Just wanted to see if anyone else already tested and confirmed that they are compatible.

    Especially since, if I end up with an updated 3DS and an incompatible "cart", I'd be stuck with no real games to play.
     
  8. Tom

    Member Tom Gbatemp's Unofficial Modder

    Joined:
    Feb 9, 2009
    Messages:
    987
    Location:
    New jersey
    Country:
    United States
    the site says 3ds support so i think it'll work(not entirely sure as i don't have one )
     
  9. sp3ctr3
    OP

    Newcomer sp3ctr3 Member

    Joined:
    Jul 20, 2011
    Messages:
    10
    Country:
    United States
    It works on my 3DS perfectly. Just not sure if it'll still work if I get the latest 3DS update.

    UPDATE: Bricked my GEi yesterday trying to update to 2.0. It just froze at "5". >_< Got it exchanged with a new one though, and this one has the "Alex Rider" icon. My old one had the "Chessmaster" icon. So, is my new one with a newer firmware? It's supposedly a Acekard clone if that helps.
     
  10. kotaro_14

    Newcomer kotaro_14 Member

    Joined:
    Jun 11, 2011
    Messages:
    41
    Country:
    United States
    Well , the newest icon for the Acekard 2i has with the Chessmaster, but the Supercard DSTWO still has the Alex Rider. Just pop it in and see if it works on your 3DS. And you did make sure you updated your GEi on a Phat DS or a DSLITE right?
     
  11. sp3ctr3
    OP

    Newcomer sp3ctr3 Member

    Joined:
    Jul 20, 2011
    Messages:
    10
    Country:
    United States
    It works perfectly on my 3DS. Albeit, it's still on the 1.0.0-0u update.

    And I made my statements according to this:
    http://gbatemp.net/t257170-galaxy-eagle-i

    So, if Acekard 2i's latest icon is Chessmaster, I suppose I got an older firmware on my GEi? And thus, need to update? I actually don't have anything else other than my 3DS though.
     
  12. sp3ctr3
    OP

    Newcomer sp3ctr3 Member

    Joined:
    Jul 20, 2011
    Messages:
    10
    Country:
    United States
    Well, I kinda skimmed real quick on the rules, so I'm not sure if double posting is against the rules. >_< I'm pretty sure it is though, but I wanted to post a fairly important update.

    My brother recently got his own 3DS so I was finally free to update mine. Update went well and with a short prayer, inserted the GEi...Worked perfectly so far. It's detected, plays DS games all right so far, nothing wrong. Haven't done too extensive testing, but Mario Party started up just fine.

    tl;dr: 3DS 2.1.0-3u + GEi (Chessmaster Icon) = Working Perfectly so far.

    I'll test later on the GEi (Alex Rider Icon).


    UPDATE: Tested 2.1.0-3u 3DS on GEi (Alex Rider Icon), confirmed that it just shows an error page on start up. And I tested out my own GEi (Chessmaster Icon) some more, still no problems at all. All games work nicely and just like before.

    Anyone else with this "cart", feel free to update your 3DS as long as you have the "Chessmaster Icon" or at least know how to update your GEi to 2.0 firmware.


    Thanks to all for the help. And I hope the info I brought in helps at least one person out there. Happy gaming.

    P.S. - If anyone has any questions, feel free to PM me, just do some Google searching first. =/
     
  13. Shunrei

    Newcomer Shunrei Newbie

    Joined:
    Jan 11, 2012
    Messages:
    6
    Country:
    United States
    hey could you please upload the updated file system? mine can't get to work and i think i am at my limit now. :(
     

Share This Page