G6 Real loses all files 50% of the time when I put it in my computer.

Discussion in 'Other Flashing Hardware & Software' started by GuardianHX, Jul 3, 2008.

  1. GuardianHX
    OP

    Newcomer GuardianHX Advanced Member

    Joined:
    Aug 12, 2007
    Messages:
    52
    Country:
    Canada
    Weird... Yesterday, I put it in, to backup my saves for Etrian Odyssey, MMSF2, and etc, but it didn't auto-boot like it usually does, so I went to "My Computer" and opened up the volume...

    Nothing was there, thinking it was weird, I put it back in my DS, and the mini-loader showed a bunch of folders with jumbled letters, none of which did anything. Recuva didn't help to get back my files either, as everything was completely wiped.

    So I formatted it to be safe, put my stuff back on, and proceeded on with playing my games when I was bored...

    Today, I put it in, backed up my saves, took it out and it worked just fine.

    Later on, I went to add a new game to it, but when I put it in my computer, everything was gone once again. I checked the mini loader, but this time, all I got was a black screen and nothing happened no matter how many times I tried.

    So I formatted again...
    Fortunately, all that was lost was my Niece's Princess Peach save file, of which she only lost one or two levels of progress, however, will this happen again? Can somebody tell me what's going on?

    I was using the M3&G6DSReal firmware version 3.8 up until now, and noticed the website now has 3.7e back instead, so I downgraded, thinking maybe it was the system files?

    I don't know. My card has been wonderful all this time (It was my first flashcart, and I ordered another for a friend who's in the hospital right now.) and both of ours have been perfectly fine.

    I read in another topic to charge my card, so I left it in my computer for a few hours yesterday thinking it might have helped, but apparently not...
    Any idea as to what's happening?



    tl;dr: Everything gets erased when I put it in my computer every now and then, and I'm forced to format and re-write everything.
     
  2. sjones900

    Member sjones900 GBAtemp Advanced Member

    Joined:
    Jan 29, 2008
    Messages:
    808
    Location:
    TX
    Country:
    United States
    Make sure the reader is properly connected to the card and to the computer. Hope that helps

    (also try it in different computers not running vista.)
     
  3. GuardianHX
    OP

    Newcomer GuardianHX Advanced Member

    Joined:
    Aug 12, 2007
    Messages:
    52
    Country:
    Canada
    It has been, I've been extra careful all day and yet it still happened.

    Also, I'm running XP SP2, not Virusta.
     
  4. noONE

    Member noONE ~~~~~~~~~~~~

    Joined:
    May 24, 2007
    Messages:
    968
    Location:
    Linköping/Norrköping, Sweden.
    Country:
    Sweden
    yeah.. that have happened to my G6real a couple of times as well..
    not lately though, it was back in the 2.2-2.5 firmware days i believe..
    really annoying..
    haven't upgraded to 3.8 yet, still on 3.7e, so i wouldn't know anything about any 3.8 issues.

    I'm really careful when plugging the card into the reader / the reader into the PC.
    first you look so there's no dirt at the contacts, then you carefully put the card into the reader by slowly putting them together, and feel that they.. "grab" eachother, and slide it in all the way, after that you push the card a bit extra into the reader, to see that it's really well inserted.
    also, when you're plugging in the reader into the USB slot, do it quickly, less chance of a corruption then.
     
  5. GuardianHX
    OP

    Newcomer GuardianHX Advanced Member

    Joined:
    Aug 12, 2007
    Messages:
    52
    Country:
    Canada
    That's one thing I've noticed since I've had my card, it never recognizes the hardware unless you put it in quickly.

    Thanks for the help though, I'll be even more careful with putting the card in, I suppose.
     
  6. KyleCooper

    Newcomer KyleCooper Member

    Joined:
    Oct 12, 2007
    Messages:
    26
    Country:
    I had the same thing, it really is a matter of where you put that USB in. If you put it in the wrong way (like I did with my laptop's slightly older USB interface), you risk losing everything, including free space (I lost half of my card this way). Since then, 3.8 doesn't boot (I don't know if it's related) so I've gone back to 3.7e, and never use my laptop to plug it in, I always use my spouse's computer. Tough thing, will consider buying an SD card cart next time.
     
  7. jceusa

    Newcomer jceusa Newbie

    Joined:
    Jul 19, 2008
    Messages:
    1
    Country:
    United States
    I have a g6 real 16mb and today I was adding some data to it when it must have filled up.

    It threw several errors, the usb device completely disappeared from my pc and upon re-insertion into the ds, everything on the card is wiped and it booted to a mini-menu with jumbled characters.

    I put it back in the pc and now its saying the card is not even formatted.

    What a piece of junk!

    It should have just given me an error about not enough space to add the file, no?

    Any suggestions on saving my data? Thank you
     
  8. NetShira

    Newcomer NetShira Advanced Member

    Joined:
    Oct 18, 2006
    Messages:
    70
    Country:
    United States
    I have 4 of these in the family.... I've noticed the reader cards are to blame most of the time when we try to sync and suddenly the above happens (the light stays solid and if you leave it longer than a few seconds, it is very likely the file system will become corrupt). We've already taped up the entrance of one of the readers because it's failure rate was almost 100%. I am lucky we bought enough of these that we had extras... I can only imagine how pissed I'd have been if all I had to deal with was ONE of these defunct readers and were unable to try others...Syncing would never work.

    Some hints we've determined:
    1) Always stick the card in the reader and THEN connect the reader to the PC.
    2) If, when connecting, the reader light is solid for longer than 1 second (aka doesn't begin immediately flashing), remove it asap.
    3) Pushing the card ALL the way into the reader doesn't always work.. we usually do so and then back it off just a hair (like the thickness of a small wire) from the edge of the reader before inserting and we seeeeeeem to get better results more often.
    4) If no matter how many times you try to stick the reader into the computer it (the light) ALWAYS comes out a solid blue... reboot. We've found that after a fresh reboot we usually have better results (it's like the USB driver needed to be reloaded but can't put my finger on it)

    I hope these hints help... if not I'm sorry...I hope they do.

    PS: My son's card was fried so bad no PC (all 6 of them) in the family would not recognize it even existed when connecting the card. The way I was able to solve this was using the NDS to format the card (prev. mentioned as holding the start button while powering on the NDS with the G6 DSReal in the slot1) Afterwords I was able to reconnect the reader with that card to the PC after a fresh reboot and format it using the PC, copy system over, etc.
     
  9. Loop

    Member Loop GBAtemp Regular

    Joined:
    May 28, 2006
    Messages:
    104
    Location:
    New York
    Country:
    United States
    ^^^ what he said ^^^ [​IMG]
    the post above has v good advice

    however if you get the solid light on the card reader, personally I would never remove the reader from the USB port
    just shut down and restart the computer

    its bloody annoying but sometimes it just takes a few tries - although my reader seems to be getting worse and worse

    might be better to use the supplied female-to-male adapter cable - that way once you have it connected ok with that USB cable
    maybe that would reduce the amount of tries
    * only problem is I cannibalized mine to make a USB card reader for my xbox!!*

    I've come to the conclusion that its only a matter of time before it goes completely (leaving me with a useless card)
    so I ordered the M3 Real (microSD based cart) from dealextreme which should be here in a couple of weeks (fingers crossed)
     
  10. xJonny

    Member xJonny ...

    Joined:
    Aug 16, 2007
    Messages:
    1,395
    Country:
    This only happened once without being my fault during my months of using the G6 Real. It seems like it's not because of a "failure rate" but more of people not knowing how to use it properly.

    The procedure I did (to be safe):

    Clean contacts if necessary
    Plug G6 Real into reader (making sure it is firmly and fully connected)
    Plug reader into USB port (not through USB extension cables if possible)
    Transfer files
    "Safely remove hardware" in Windows and listen for the removed hardware windows sound/check the drive isn't there
    Remove G6 Real and play

    Things I did wrong that you shouldn't do:

    Plugged the G6 Real into the reader after I plugged the reader into the USB
    Pulled out the card reader from USB (without safely removing)

    These things didn't necessarily corrupt the card, but can do.
     

Share This Page