FW 4.0: List of it's IOSes and their versions!

Discussion in 'Wii - Hacking' started by Dan_Aykroyd, Jun 30, 2009.

Jun 30, 2009
  1. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Hi!

    As you might have read in some of my previous posts, I want to be sure that my freshly updated Wii to FW 4.0 has EVERY Nintendo latest IOS for that firmware version. I want to keep it that way, and manually patch the IOSes that I need for some homebrew. So far I think everything is OK, and I have patched:

    - IOS36 for to v1042 (IOS36-64-v1042.wad) to make ATD and StartPatch work
    - IOS60 (to v6174 - with "IOS Installer") to make VC software run from the SD card

    But before all this, I've fiddled around with other IOSes quite some time ago. Although I think I rollback them all, I just want to be sure that's so.

    So, my questions / requests are:

    1) Let's say I had some IOS patched / modded prior to updating to FW 4.0. Updating then, overwrote EVERY IOS with the Nintendo originals? Or only SOME IOS were overwritten (maybe IOSes were Nintendo patched something)? This would be one stone in being confident that my Wii is "quite official"

    2) Can someone please point to a link (if this was alredy posted) or post them yourself if its not available, each IOS and their versions? Please be sure that you haven't patched them and that you are running the official ones from Nintendo! To find out the version, go to AnyTitle Deleter, enter the System Files (I guess, it's the first option) and there, selecting each IOS, would show which version it is.

    Please let me know if you can help. I'm sure that it'll be useful for a lot of other users that want a "Virgin" Wii and you'll be greatly thanked!

    In any case, thanks in advance for your time and reading!
     
  2. ocdetective

    Member ocdetective GBAtemp Advanced Fan

    Joined:
    Mar 19, 2008
    Messages:
    601
    Country:
    Malaysia
  3. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    What do you mean by that? That the newest version listed in the "Version Number(s)" should correlate to FW 4.0?

    Oh, an another question. I noticed that the latest IOS60 version is the same as mine, but as I said I've patched it using "IOS60 Installer" in order to run VC games from SD. If I'm right, that only PATCHED it to allow to reintroduce the bug. Because I first thought that it downgraded the IOS to a prior version with the bug present. Can you please confirm me this? And if my reasoning is correct, is there a patcher for the IOS36, instead of downgrading it? It it were, then I'd have the latest version (FW 4.0) but patched with the bug, instead of having it downgraded to an early version (as I have now).

    Thanks!!!"!
     
  4. ether2802

    Former Staff ether2802 we have the techno...!!

    Joined:
    Oct 14, 2007
    Messages:
    4,350
    Location:
    Pto. Vallarta
    Country:
    Mexico
    IOS60-61 came only with FW4.0 cause the SysMenu hangs off IOS60 and WiiShop hangs off IOS61, so there are only one version of them, if you update thru the official Wii Updater, you can have them all and know wich versions are the latest, and can you post the reason of your need to know/have the "latest" version..?? [​IMG]
     
  5. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Yes! The reason: OCD (Obsessive Compulsive Dissorder) [​IMG]

    I'll compare one by one when I get home today, each IOS in the Wii with every IOS in the Wiki posted above.

    If some in the Wii are older than the latest FW 4.0 listed in the Wiki, am I safe to get those over NDUS and manually installing?

    Thanks!

    PS: I have bootmii as boot2 with NAND dumped, just in case [​IMG]
     
  6. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Well I compared them and every one was the latest version, except, of course, the IOS36 which was downgraded to a prior version.

    Now, the only thing that "troubles" me is the IOS254. I first deleted it, but before I did created a copy with WAD Creator (Waninkoko). Now, I've reinstalled it but I have my doubts it's correctly installed (even if it's a dummy IOS). So I went and downloaded it with NDUS and then MD5 checked them both (WAD Creator vs NDUS). It did not match, but that was not much since I've read that the NDUS copy is different than the installed Nintendo WAD because a header or something.

    Soo... could some helpful fella' dump their IOS254 v3 with WAD Creator and post the MD5 here for me to compare? I'm on FW 4.0 if it matters.

    Thanks! That'd be the last step to be sure that my Wii is 1:1 original (besides my manually patched IOSes).
     
  7. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Well, after I wrote this I realized that nevertheless, the MD5 won't match, because the WAD is created with a Wii binded key... am I right?
     

Share This Page