Forcing Gamecube games to run in 480i over Componite Cables?

Discussion in 'Wii - Hacking' started by floattube, Oct 7, 2013.

  1. floattube
    OP

    floattube Member

    Newcomer
    16
    0
    Apr 14, 2013
    United States
    So I have a soft modded Wii, lots of Gamecube games on my hard drive. I load these games using USB Loader GX. Now I have an SDTV that has component input, but the TV doesn't output 480p. That's not a problem for Wii games because I can set them to play at 480i, however Gamecube games still try to run in 480p. I have no composite cables to switch to, or I would just do that. I can't find any way to make the games run in 480i instead of 480p.
     
  2. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    Just change your system to use 480i. That will work with component cables.
     
  3. floattube
    OP

    floattube Member

    Newcomer
    16
    0
    Apr 14, 2013
    United States
    Doesn't affect the Gamecube games loaded on USB Loader Gx...
     
  4. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    Try running a retail disc and see if it has the same effect. That will tell you if it's a software issue.
     
  5. floattube
    OP

    floattube Member

    Newcomer
    16
    0
    Apr 14, 2013
    United States
    Yep, it's software related. Any advice to continue from here?
     
  6. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    So it runs fine from a retail disc?
     
  7. floattube
    OP

    floattube Member

    Newcomer
    16
    0
    Apr 14, 2013
    United States
    Yes, it sure does.
     
  8. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    Then try a different loader. I suspect GX is forcing the 480p bit if VIDEO_HaveComponentCable() returns true.
     
  9. floattube
    OP

    floattube Member

    Newcomer
    16
    0
    Apr 14, 2013
    United States
    Okay... what loaders work with Dios Mios?
     
  10. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    Cfg Mod and Wiiflow
     
  11. floattube
    OP

    floattube Member

    Newcomer
    16
    0
    Apr 14, 2013
    United States
    Just tried both of those, neither of them work. There is even an option in Wii Flow to set it to NTSC 480i, but it still screwed up.
     
  12. Hozu

    Hozu GBAtemp Regular

    Member
    277
    67
    Aug 25, 2010
    Canada
    The DIOS MIOS splash screen is always in 480p if component cables are detected, but it should return to 480i unless the loader is set to force 480p. You'll have to either use composite cables to avoid this issue, or you could turn off the TV for the duration of the splash screen.
     
  13. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,974
    3,758
    Apr 2, 2011
    United States
    The Twilight Zone
    You could try Devolution as well, but that requires disc validation.
     
  14. floattube
    OP

    floattube Member

    Newcomer
    16
    0
    Apr 14, 2013
    United States
    Wow, I feel like a dimwit. A few games I have on my Wii don't give me the option of progressive scan and those were the games I was testing this on. Tried a different game and waited, it started right up. I'm gonna order composite because not all the games work with the component. Thanks for the info though, I really appreciate it.
     
  15. Leo Alves

    Leo Alves GBAtemp Regular

    Member
    117
    17
    Dec 16, 2012
    Brazil
    try this on USB loader GX or CFG Usb LOader:

    On USB Loader GX, go to Settings > Loader Settings, and set ''GC Force Interlace'' to ON

    on CFG Usb Loader mod choose the game, go to options and set ''Video Patch'' to OFF

    this worked for me and disabled the Progressive Scan Screen on games that have it
     
    lastninjagaijin likes this.
  16. lastninjagaijin

    lastninjagaijin Member

    Newcomer
    20
    1
    Oct 9, 2013
    I don't have that option for me, only gamecube force progressive on off i think for latest r1209
     
  17. Fishaman P

    Fishaman P Speedrunner

    Member
    3,243
    507
    Jan 2, 2010
    United States
    Wisconsin
    Gee, what a conundrum...
     
    lastninjagaijin likes this.
  18. lastninjagaijin

    lastninjagaijin Member

    Newcomer
    20
    1
    Oct 9, 2013

    Oh I know lol it achieves the same end, just thought I would mention that for r1209 the option is worded differently.. for anyone that might have been confused by that. I'm ok with progressive vs interlaced, but personally my brain implodes when trying to sort out component vs composite for instance. So for people that have 'lysdexia' (ahah I'm sure that's how they'd spell it) when it comes to option menus, I thought'd I'd clarify :)