Hacking "Forced" 1.09 Firmware Upgrade [DStwo]

Link420

New Member
OP
Newbie
Joined
Apr 3, 2011
Messages
1
Trophies
0
XP
5
Country
United States
Hello everybody, I'm new to the flashcart world so please forgive my ignorance on the subject. After doing some research I found the DStwo to be the best cart currently on the market so that is what I chose, and so far I am very happy with it. I ordered my cart from Real Hot Stuff and received it yesterday. I followed the iMenu setup guide over on GBAtemp and got everything setup and it worked fine except for upgrading the Firmware. I do have a 3DS but will not be using the DStwo in it as of now, I am awaiting confirmation that it is safe before doing so, and I am content with using it on my DSLite for now.

Continuing on to what I was saying about the Firmware, when I loaded the software and then clicked on the DStwo menu in the iMenu it would not load the Firmware update I also rulled out that it already had the update due to it loading as "Fish Tycoon" so I investigated further. I decided to delete the file and downloaded Firmware 1.05 off of the website and tried that, lo-and-behold it detected and asked if I wanted to "Update" although it was a downgrade due to it having shipped with "beta-1.06" according to the popup, I chose to proceed thinking perhaps their is an issue in the "beta" firmware preventing it from updating to 1.09. So with 1.05 now on the system I tried updating to 1.09 again, still no luck. Investigated again why it is not working, I decide to put the 1.05 and 1.09 firmware files next to each-other and found an inconsistency, these are both US firmware files as well and downloaded off the official SC site. The working Firmware update "1.05" was named "ds2update.dat" wheras the non-working "1.09" update was named "dstwoupdate.dat" So I renamed the "1.09" update file with the name used in the "1.05" update, just chaning the word "two" to its numerical form "2" put it in and it worked, the popup came up asking if I wanted to update from "1.05-1.09" I accepted, it worked. Icon changed from "Fish Tycoon" to "SC2". I suppose I am posting this if anyone is haing any issues with upgrading to "1.09"

TL;DR - To upgrade from to "1.09" I had to change the file name

EDIT: I should also add that this was on EOS 1.11
 

Terminator02

ヽ( 。 ヮ゚)ノ
Member
Joined
Apr 10, 2010
Messages
4,516
Trophies
0
Location
Somewhere near monkat
XP
1,002
Country
United States
hmm, that's weird, it worked perfectly fine for me when i just loaded EOS (1.11) and the firmware (1.09) before i put iMenu on my card

but thanks for posting this up, good to know in case anyone else gets this problem

Edit: also it's fairly safe to use the ds2 on the 3ds for now, as it just shows up as alex rider on the log, not a flashcart, so nintendo can't tell if you're either playing alex rider or using a flash cart (they can't ban everyone who played alex rider)
 
General chit-chat
Help Users
    kenenthk @ kenenthk: Anyone that questions this will have their dick bitten off by our Chihuahua