Flashcart for DSI XL 1.4.5E . . . . .Help plzzz!

Discussion in 'NDS - Flashcarts and Accessories' started by Skhan1990, Aug 19, 2013.

  1. Skhan1990
    OP

    Skhan1990 Newbie

    Newcomer
    3
    0
    Aug 17, 2013
    Ok so i have a nintendo dsi xl which has the version 1.4.5E

    Ive tried using a cheap ass fake, which i shouldn't have as it didn't work.

    I need a solid recommendation from someone. What flash cart will work with a dsi xl running on a 1.4.5E version


    Thanks
     
  2. Plstic

    Plstic Guru Meditation Error

    Member
    619
    218
    Apr 21, 2010
    United States
    Milwaukee WI
    The supercard dstwo is your best bet.
     
  3. Ryukouki

    Ryukouki See you later, guys.

    Member
    4,949
    2,614
    Jan 31, 2008
    United States