Fixing error codes: 86420 etc. (Mario Kart, SSBB)

Discussion in 'Wii - Nintendo Wi-Fi Connection' started by peddengba, Apr 17, 2008.

  1. peddengba
    OP

    peddengba Member

    Newcomer
    15
    0
    Nov 6, 2002
    I have seen alot of topics and discussions about this but no one have made an easy explanation how to solve this!

    Therefore... I'm doing it! [​IMG]


    Ok, THE PROBLEM: You have an wireless router and you can access internet with your Wii (Shop channel, Everybody votes etc. works fine) you can also access Nintendo WFC, BUT when your Wii are searching for others players (Mario Kart Wii WFC for example) it dosent find any and then all of a sudden "Error code: 86420" comes up... and says: Connection broken (or something)


    what to do... [​IMG]


    THE SOLUTION: In the wireless router TURN OFF "SPI Mode" in the firewall settings! ...simple... [​IMG]


    ANALYSIS: Because the SPI scans every package recieved through the router and since it's task is to remove "Internet Background Noise", turning this mode OFF allowes the WFC data to be treated correctly and not like "Background Noice" (causing the 86420 error).

    Works on Mario Kart Wii WFC, should work on SSBB also but since I live in Europe I don't have that game yet... [​IMG]

    Last, a word of caution: If you don't know anything about routers you should really consider asking someone to help you.


    Ok, let me now if this has helped you... (I wanna beat some n00bs om Mario Kart) [​IMG]

    Peace!
     
  2. otto888

    otto888 I break things for a living.

    Member
    312
    42
    Mar 12, 2008
    United States
    Would SPI be Multicast on some routers? I don't see SPI in my router settings.
     
  3. Shinster

    Shinster GBAtemp Regular

    Member
    224
    0
    Jun 22, 2007
    I have my firewall turned off so it's ok.
     
  4. kemosabe

    kemosabe GBAtemp Regular

    Member
    130
    0
    Sep 16, 2006
    Gambia, The
    its not working for me
    i installed some vc games and some channels and all of the sudden i cant play mario kart online anymore.
    before i installed the vc games and the hacked channels it worked like a charm.
    could it be that nintendo banned my wii because od the hacks i installed?
    ive changed nothing on my internet or router settings and i even tried a second copy (original); but it didnt worked either
    even all the channels like weather or voting, the shop and the mario kart channel are working fine, so theres no problem with my internet configuration.
    so, could it be that im banned?
    edit:
    i even deleted all the .wad data and reseted my wii. still not working
     
  5. sjones900

    sjones900 GBAtemp Advanced Member

    Member
    808
    15
    Jan 29, 2008
    United States
    TX
    try connecting to a friends wifi see if that works.
     
  6. Skysurfer

    Skysurfer Newbie

    Newcomer
    1
    0
    Aug 13, 2008
    yeah