Fixed a Purple Screen of (Death)

Discussion in 'Switch - Tutorials' started by ChrisHoi64GenkiDeChu, Oct 6, 2018.

  1. ChrisHoi64GenkiDeChu
    OP

    ChrisHoi64GenkiDeChu Newbie

    Newcomer
    2
    Jun 23, 2018
    Netherlands
    Yesterday I got a persistent Purple Screen on my Switch, turns out it is a rare error, for which I couldn't find a solution online.
    It couldn't load anything but the SX OS menu. Thought it was bricked.

    The quick answer is: I fixed it by running SX Menu's inbuilt GPT Repair mode.
    So if you're using SX, try that first.

    What I did before it happened:
    Made a NAND backup using SX 2.0 Menu on my 5.0.X Switch.
    I only backed up Boot01, Boot02 and SYS.
    It finished, then the SX menu crashed.
    Waited for 2 minutes, did a hard power-off.

    Turned back on my switch holding Vol+.
    Entered the SX menu and tried to run Custom FW.
    Then a Purple Screen.
    Hard power-off.

    Back in the SX menu, I tried running Original FW.
    Purple Screen.

    Luckily I could enter the SX menu everytime after I turned the Switch off, so I tried several different settings;
    uninstalled and installed Auto-RCM, booting without SD Card, booting without dongle, etcetera.
    Noting worked. Everytime I tried to boot either Firmware I got the Purple Screen.

    Then I copied the backed up NAND I made earlier to my PC. Turns out the SD card had faulty sectors.
    Tried restoring my NAND using a clean SD Card in SX menu; Boot01 and Boot02 succeeded. SYSnand "failed=(some memory location error)"

    Used A different, newly formatted SD card, same error; SYSnand restore failed.

    I was out of options, and just tried using the inbuilt GPT repair mode in SX Menu 2.0
    It did the job. Fast and easy.

    My Switch loaded both Original and Custom FW without any problems.
    Also I didn't loose any data at all.

    Hope this helps for people encountering a Purple Screen of (not really Death).
     
  2. a9lh-1user

    a9lh-1user GBAtemp Fan

    Member
    4
    Apr 1, 2016
    Germany
    Thanks for the explanation what worked for you.
    IMHO it shows only that SX OS has features that are very dangerous for the average user and should not be used :)
     
    Hmed and thaikhoa like this.
  3. Ericthegreat

    Ericthegreat Not New Member

    Member
    8
    Nov 8, 2008
    United States
    Vana'diel
    Last edited by Ericthegreat, Oct 6, 2018
    Tinnetju and Hmed like this.
  4. robingilh

    robingilh GBAtemp Regular

    Member
    5
    Dec 21, 2009
    France
    not far from a computer
    "Hey, I just fixed an SD error with the only thing that worked on my switch : SX O..."

    "How dare you use a repair function you dirty SX apologist! Don't you know that it can burn down your house?"
     
    yusuo and Victorum like this.
  5. Hugopugo

    Hugopugo Member

    Newcomer
    1
    Oct 31, 2018
    Portugal
    This didnt work for me unfortunately... after i restored my nand backup i got this purple screen too.... tried everything and nothing worked, including gptrepair ;(

    unfortunately i had to return my switch to the store i bought and received a new one (told them i turned on one day and this happened) wait until they get inside that switch hehe...

    hopefully this works for others... im never restoring my nand again... seems like a risk restoring your nand

    anyone know why this is happening? is the nand backup corrupted?
     
Loading...