Fix TWL FIRM after A9LH install without pre-A9LH backups?

Discussion in '3DS - Flashcards & Custom Firmwares' started by seijinshu, Jun 14, 2016.

  1. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    I did my A9LH install back in Febuary, and I never did fix my TWL FIRM. I also lost all the NAND backups from before the A9LH installation since the HDD partition they were on got f*cked up by OS X's bootcamp assistant wanting to disable a boot device since it said it would cause issues.

    How do I fix my TWL FIRM?
     


  2. angelus kun

    angelus kun GBAtemp Fan

    Member
    345
    87
    Aug 7, 2015
    Mexico
    in my dreams
    i think you can make a nand backup and reinstall the TWL clean cia from THAT iso site
     
  3. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    I will go do that, and hope I get it running again.

    — Posts automatically merged - Please don't double post! —

    Did not work. Same error. This is due to the TWL NAND probably dead.
     
  4. astronautlevel

    astronautlevel The Young Descendent of Tepes

    Member
    4,039
    4,980
    Jan 26, 2016
    United States
    That Nightly Site™
    This is probably a problem with TWLN, your best bet is to downgrade to 9.2.0, then upgrade again w/o restoring a backup.
     
  5. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    Oh fun... I will try that and hope nothing gets too bad... Wait wouldn't that remove A9LH?
     
  6. astronautlevel

    astronautlevel The Young Descendent of Tepes

    Member
    4,039
    4,980
    Jan 26, 2016
    United States
    That Nightly Site™
    Not if you have FIRM write protection enabled (Luma3DS always does this, cakes you need to enable a setting)
     
  7. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    I use Luma, so hopefully nothing goes wrong. Making backups anyways!
     
  8. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    So my sysnand bricked, but thanks to luma, recovery mode saves the day!

    — Posts automatically merged - Please don't double post! —

    uh oh, An error has occurred. Unable to update. The System will now turn off. *Presses OK*

    — Posts automatically merged - Please don't double post! —

    I did have a patch AGB Firm, patched TWL Firm (Aurora's one) and patched home menu.
     
  9. phalk

    phalk Handheld Maniac

    Member
    426
    260
    Apr 23, 2009
    Brazil
    Plailect's guide says it in caps and bold that you should remove it before proceeding or you would brick.
     
  10. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    To clarify:
    I am one of the Arm9LoaderHax pioneers, or one of the first to get it up and running.
    I did it way back in February a few days after it got made public and available for o3DS.
    I did it long before OTP helper and PlailSysupdater were a thing, let alone never touched that guide.
    I am currently fixing TWLN due to how the old A9LH screwed it up, and I no longer have a NAND backup from before all the A9LH shenanigans due to my HDD killing its partition table. I have a backup from before all of this happened (the downgrade) plus I have my PandaNAND.
     
    Last edited by seijinshu, Jun 14, 2016
  11. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    Any help? @astronautlevel, do you think it is my patched stuff?
    I can restore the 11.0 sysnand. does 9.2 downgrade fix the TWLN? If so, should I grab it before restoring 11.0?
    I also did do a few updates. I did 10.6 -> 10.7 & 10.7 -> 11.0 on my sysnand
     
  12. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,089
    5,166
    Mar 17, 2010
    Norway
    Alola
    Get the right system titles from the 11.0 upgrade pack for your region (you can download it with 3DNUS by putting in 11.0.0-33 in the Title ID box, USA in the version box (assuming your 3DS region is USA) and selecting Old 3DS/New 3DS depending on which model you have)
    This is just to make sure you don't install the wrong titles as that is a likely cause for your brick.
    Example:
    [​IMG]
    The errors are due to me having the update servers blocked so don't worry about that :P
    You can find the title IDs of the titles you need on http://3dbrew.org/wiki/Title_list
    FBI should work for installing those few titles, but if the install fails on any of them you should report back. I had a few modded system titles installed and sysupdater would just error due to them when I was trying to update, after that I ran FBI to finish the install and it said a lot of system titles already existed and wouldn't install them, in the end I got a bricked emuNAND.
     
  13. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    Hmmm... I wonder if downgrading to 9.2 still fixed my TWLN, idc about the CTRNAND at this point. I just wonder if the downgrade was all that was needed to fix TWLN, since I can't upgrade to 11.0 from SysNAND (I must restore the 11.0 SysNAND)
     
    Last edited by seijinshu, Jun 14, 2016
  14. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    I'm grabbing TWLN to be safe and restoring my sysnand backup.
    I'm going to bed, checking back in the morning.
     
    Last edited by seijinshu, Jun 14, 2016
  15. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    I'll try this out on my 11.0 and then back to 9.2 and hope the thing ain't a lost cause.
    EDIT: SH******T! 3DBrew is down!
    EDIT2: D*MNIT! ALL THE *BREWS DOWN!
     
    Last edited by seijinshu, Jun 14, 2016
  16. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    Bah, the brews are still down!
     
  17. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    OK, got a cached version of 3DBrew working, and I grabbed Clean 11.0 Home Menu, AGB_FIRM & TWL_FIRM
    Installing then testing!

    So I cannot install home menu due invalid version info. I think I'm going in and deleting Home Menu and then installing it again. I DID get the spoof version, so I should grab a clean one.

    NOOO! I cannot use the one from 3DNUS!!!!!
    I get invalid signature!

    @astronautlevel do you know what to do?

    Anyone? I get to 99% before the error appears.
     
  18. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
  19. phalk

    phalk Handheld Maniac

    Member
    426
    260
    Apr 23, 2009
    Brazil
    Can you boot in CFW or restore back to 9.2.0? The signature error is because of the lack of permissions, probably.
     
  20. seijinshu
    OP

    seijinshu ...

    Member
    483
    120
    Jan 6, 2016
    United States
    ...
    Umm... This is a9lh sysnand
    This item is also directly from 3DNUS (11.0 Home Menu).

    Sent from my LG-H811 using Tapatalk
     
    Last edited by seijinshu, Jun 14, 2016