Final Fantasy XIII asks for Update in order to play

Discussion in 'Xbox 360 - Games & Content' started by dsrules, Mar 14, 2010.

Mar 14, 2010
  1. dsrules
    OP

    Member dsrules GBAtemp Psycho!

    Joined:
    Sep 20, 2005
    Messages:
    3,288
    Country:
    I pop Final Fantasy XIII into the xbox360 and it asks to Update in order to play it

    anyone knows what the update will be or and is it safe to update if the drive has been ixtremed???
     
  2. T-hug

    Chief Editor T-hug Always like this.

    pip
    Joined:
    Oct 24, 2002
    Messages:
    8,599
    Location:
    England
    Country:
    United Kingdom
    Yes the update will be safe but I don't think ixtreme is safe at all anymore, you need LT FW (LiteTouch) to supposedly be safe.
     
  3. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,711
    Country:
    United Kingdom
    It is probably just the avatar updates but before you do check and see if you are not on the 7 series kernel rather than the 8 as that means you have a good chance gaining a JTAG box if you want to- region free, homebrew, no more discs necessary and hacked games for one.

    As for DVD drives no firmware update can touch them but as Thug4L1f3 says if you plan on doing anything on Live you need LT.
     
  4. bburress01

    Newcomer bburress01 Newbie

    Joined:
    Mar 14, 2010
    Messages:
    2
    Country:
    United States
    Ya, mine tells me I need to update then fails and says the disc is unreadable... which should not be true the disc has no flaws and is recognized on startup.
     
  5. dsrules
    OP

    Member dsrules GBAtemp Psycho!

    Joined:
    Sep 20, 2005
    Messages:
    3,288
    Country:
    I still haven't update mine yet. Since, my 360 is more than 2 years old, I might try to Update it to the newest System Files before trying it on FF13 again.

    bburress01, do your other games work after the update failed?
     
  6. bburress01

    Newcomer bburress01 Newbie

    Joined:
    Mar 14, 2010
    Messages:
    2
    Country:
    United States
    Yes they do, although the newest game I have is Fable 2. They seem to work fine.
     
  7. dsrules
    OP

    Member dsrules GBAtemp Psycho!

    Joined:
    Sep 20, 2005
    Messages:
    3,288
    Country:
    I updated my System files to October 2009 2.0.8955.0, and FF13 didn't ask for Update anymore [​IMG]
     

Share This Page