1. cloudfe

    cloudfe GBAtemp Fan
    Member

    Joined:
    Feb 24, 2013
    Messages:
    355
    Country:
    Belgium
    I was planning to install it in NSP, do you think it will make a difference?
     
  2. taka24

    taka24 Newbie
    Newcomer

    Joined:
    Mar 7, 2016
    Messages:
    1
    Country:
    France
    hello, excuse me. thank you for your work, but can you do it for the Japanese version? to have French subtitles. thank you.
     
  3. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    So French is not a western language anymore? :ph34r:
     
    tabzer likes this.
  4. cloudfe

    cloudfe GBAtemp Fan
    Member

    Joined:
    Feb 24, 2013
    Messages:
    355
    Country:
    Belgium
    Just one last thing: if I already have Atmosphere 0.8.8 installed, can I just paste the titles\0100000000000037\exefs.nsp from 0.8.9? Or do I need to install the whole 0.8.9?
     
  5. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    I don't think you need to reinstall whole build
     
  6. NemRe

    NemRe Member
    Newcomer

    Joined:
    Feb 25, 2017
    Messages:
    22
    Country:
    United States
    AMS 0.8.9 it's already available officially
     
  7. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    Yes, first post updated.
     
  8. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    Package updated with proper timestamps for English subtitles in "Credits & Bonus Audio" took from PC release. As there is nothing for other western languages, desynchronization still is there, but not for English.
    Thx to Kaldaien for help.
     
    tabzer likes this.
  9. Raugo

    Raugo GBAtemp Fan
    Member

    Joined:
    Nov 22, 2014
    Messages:
    465
    Country:
    Spain
    Thanks @masagrator for this fantastic job. Since you know how to modify the nros, would by possible to edit it to launch directly the FFX without the selector screen?
     
  10. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    From what I checked GameLauncher serves as intermediary to set settings for games. If swapping executables would be possible to do, then it would run on default settings (which is Japanese). But it's just my opinion.
    I don't have how to test it right now (broken Switch), but on Atmosphere 0.8.9 try to take
    Code:
    romfs\.nrr\ffx_phyreApp_2015.nrr
    romfs\nro\ffx_phyreApp_2015.nro
    and put it to sdcard as
    Code:
    romfs\.nrr\ffx_GameLauncher.nrr
    romfs\nro\ffx_GameLauncher.nro
    if it's not working, then next method would be editing exefs. But this will require making patch for every version of game independently.
     
  11. Raugo

    Raugo GBAtemp Fan
    Member

    Joined:
    Nov 22, 2014
    Messages:
    465
    Country:
    Spain
    I tried it before the release of ams 0.8.9 and didn't work. I don't know if ams 0.8.9 add something that allow that modification. I will try it latter
     
    Last edited: May 3, 2019
  12. Raugo

    Raugo GBAtemp Fan
    Member

    Joined:
    Nov 22, 2014
    Messages:
    465
    Country:
    Spain
    Tried with ams 0.8.9 and didn't work.
     
  13. VitGil

    VitGil Newbie
    Newcomer

    Joined:
    Sep 18, 2019
    Messages:
    5
    Country:
    Kazakhstan
    Hello. Forgive me for writing off topic, but masagrator or someone else could you share the sips utility (A simple IPS32 patch generator) with me? I have no way to compile it myself.
    I just registered and can not write personal messages, so I have to write here. Sorry one more time.
     
  14. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    If you mean for Windows, then it also doesn't compile for me.
    I'm writing patches manually.
     
  15. VitGil

    VitGil Newbie
    Newcomer

    Joined:
    Sep 18, 2019
    Messages:
    5
    Country:
    Kazakhstan
    Yes for Windows. Is there an instruction how to write a patch manually? If so, can you point to it?
     
    tabzer and ZeroFX like this.
  16. tatundria

    tatundria GBAtemp Fan
    Member

    Joined:
    Feb 24, 2009
    Messages:
    352
    Country:
    Argentina
    Hi, is it possible to update Final Fantasy X/X-2 Undub compatibility to FW 9.1.0 with atmosphere 0.10.1?
     
    Last edited: Dec 14, 2019
  17. Raugo

    Raugo GBAtemp Fan
    Member

    Joined:
    Nov 22, 2014
    Messages:
    465
    Country:
    Spain
    The console firmware and the atmosphere version does not affect to the mod. The same mod works in any firmware or atmosphere version the only thing can break de mod is a update of the game.
     
  18. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    ...or bugs in CFW. And I think this is it, because another issue that was present was for layeredfs and exefs_patches in 0.10.0 first prerelease, which shares similarity to nro_patches. Write an issue here:
    https://github.com/Atmosphere-NX/Atmosphere/issues
     
    Last edited: Dec 14, 2019
    tabzer likes this.
  19. tatundria

    tatundria GBAtemp Fan
    Member

    Joined:
    Feb 24, 2009
    Messages:
    352
    Country:
    Argentina
    I don’t get it. Is it compatible or not?
     
  20. masagrator

    OP masagrator The developper
    Member

    Joined:
    Oct 14, 2018
    Messages:
    2,139
    Country:
    Poland
    Dunno. If it's not working, then it's not fault of the mod. This you should understand.
     
    Last edited: Dec 15, 2019
    Fadi5555 likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Fantasy, Final, Undub