Homebrew FCEUltra RX - A new fork.

D

Deleted User

Guest
Here are a few forwarders for stand-alone RX. @mastershoes @Flo_o created these, along with my forwarder. I just directed the channels to "fceurx".

They are Wii only, if vWii is needed, please request.
Great stuff! Thank you.
Small edit: Sorry to ask for too much, but do you have one that looks like the Vibestar or the Qwertymodo one?
 
Last edited by ,
  • Like
Reactions: RunningSnakes

Flo_o

Well-Known Member
Member
Joined
Mar 18, 2017
Messages
161
Trophies
0
Age
35
XP
465
Country
  • Like
Reactions: RunningSnakes

Muliro

Well-Known Member
Newcomer
Joined
Sep 4, 2019
Messages
64
Trophies
0
Age
29
XP
261
Country
Brazil
Hello, Niius.
Do you think it's possible to add a scanlines filter in this one?
The one in the snes emulator looks really good on LED panels.
Thank you
 
D

Deleted User

Guest
Off to a new question. Is there any fix to the fact there is no sound at all on the emulator interface? It has been like that for a few months and I don't know if it's a known bug or a issue on my end.
 

Sogun

Member
Newcomer
Joined
Jan 11, 2011
Messages
19
Trophies
0
XP
898
Country
Hello @niuus

A couple of years ago I asked for a feature that would let you save some settings (horizontal and vertical crop, screen position and color palette) per game.
User @Cecilmax already posted a modified FCE Ultra GX which allowed to save crop settings per game. There was a short message exchange when I asked for the feature. Here's his original topic.

Do you think you can work on this? (My original post).


Also, is there an official FCE Ultra GX topic? I recall there was one but I can't find it. I was going to post there too.


Thank you very much.
 

SaulFabre

Wii scene/hacking & Wii VC well-known guy
Member
Joined
Feb 6, 2019
Messages
1,130
Trophies
1
Age
22
Location
Ecuador
Website
saulfabreg-wiivc.blogspot.com
XP
2,457
Country
Ecuador
Nice work with that @niuus

But I have a issue and a suggestion for put in the next version.

The issue is when i use FCE Ultra RX (but also Snes9x RX) in "autoboot ROM" mode (when i put ROM loading arguments in the meta.xml file of the emulator), the game loads and plays fine, but when i click in the "Exit" or "Main Menu" option when i press HOME button it doesn't bring me back to the Homebrew Channel (or the Wii Menu if i use with DOL forwarders), but it brings me to the emulator, which shouldn't do the FCE Ultra RX (because old NES emus for Wii such FCE Ultra GX or FCEUX TX this option of exiting the game when in autoboot mode returns to Homebrew Channel or Wii Menu).

1.PNG 2.PNG 3.PNG

I am using these arguments in the meta.xml file for load a rom automatically in FCE Ultra RX:

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<app version="2">
  <name>FCE Ultra RX</name>
  <coder>NiuuS, Tantric</coder>
  <version>1.7.0</version>
  <release_date>20190119</release_date>
  <short_description>Nintendo Emulator</short_description>
   <long_description>
A big fork of FCE Ultra GX with new improvements.
   </long_description>
   <arguments>
   <arg>sd:/apps/myNESgame/rom</arg>
   <arg>game.nes</arg>
   </arguments>
   <ahb_access/>
</app>

I'm using FCE Ultra RX v1.7.0 but still that problem persists, which isn't present in FCE Ultra GX or FCEUX TX.

Can you fix this issue?

And the suggestion for a next version is: can you add the original Wii Virtual Console palette to the emulator? I see that the "restored Wii VC" palette is here but not the original Wii VC palette, which is included in the FCEUX TX emulator. Can you add this please?

Thanks for your great work!! :)

@SaulFabre
 
Last edited by SaulFabre,

SaulFabre

Wii scene/hacking & Wii VC well-known guy
Member
Joined
Feb 6, 2019
Messages
1,130
Trophies
1
Age
22
Location
Ecuador
Website
saulfabreg-wiivc.blogspot.com
XP
2,457
Country
Ecuador
@niuus have you read this? please sorry if i "disturb" you too much but i was waiting for long for a new version which has autoboot feature and the selectable palette "original Wii VC palette" from SuperrSonic, which both was integrated in FCEUX TX.
Nice work with that @niuus

But I have a issue and a suggestion for put in the next version.

The issue is when i use FCE Ultra RX (but also Snes9x RX) in "autoboot ROM" mode (when i put ROM loading arguments in the meta.xml file of the emulator), the game loads and plays fine, but when i click in the "Exit" or "Main Menu" option when i press HOME button it doesn't bring me back to the Homebrew Channel (or the Wii Menu if i use with DOL forwarders), but it brings me to the emulator, which shouldn't do the FCE Ultra RX (because old NES emus for Wii such FCE Ultra GX or FCEUX TX this option of exiting the game when in autoboot mode returns to Homebrew Channel or Wii Menu).

View attachment 271560 View attachment 271561 View attachment 271562

I am using these arguments in the meta.xml file for load a rom automatically in FCE Ultra RX:

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<app version="2">
  <name>FCE Ultra RX</name>
  <coder>NiuuS, Tantric</coder>
  <version>1.7.0</version>
  <release_date>20190119</release_date>
  <short_description>Nintendo Emulator</short_description>
   <long_description>
A big fork of FCE Ultra GX with new improvements.
   </long_description>
   <arguments>
   <arg>sd:/apps/myNESgame/rom</arg>
   <arg>game.nes</arg>
   </arguments>
   <ahb_access/>
</app>

I'm using FCE Ultra RX v1.7.0 but still that problem persists, which isn't present in FCE Ultra GX or FCEUX TX.

Can you fix this issue?

And the suggestion for a next version is: can you add the original Wii Virtual Console palette to the emulator? I see that the "restored Wii VC" palette is here but not the original Wii VC palette, which is included in the FCEUX TX emulator. Can you add this please?

Thanks for your great work!! :)

@SaulFabre
 

SaulFabre

Wii scene/hacking & Wii VC well-known guy
Member
Joined
Feb 6, 2019
Messages
1,130
Trophies
1
Age
22
Location
Ecuador
Website
saulfabreg-wiivc.blogspot.com
XP
2,457
Country
Ecuador
Hey there @niuus

Please don't think i am a troll, (because I'M NOT A TROLL), but i've made a pull request in your FCE Ultra RX for check and test my modifications of FCEURX for add a proper autoboot ROM function and add a new missing color palette to the emu. Here you can read more info: https://github.com/niuus/FCEUltraRX/pull/5

Tell me if you can check and accept the modifications i've made.

@SaulFabre
 
  • Like
Reactions: niuus

niuus

Well-Known Member
OP
Member
Joined
Mar 4, 2016
Messages
1,521
Trophies
1
XP
2,560
Country
Venezuela
Hey there @niuus

Please don't think i am a troll, (because I'M NOT A TROLL), but i've made a pull request in your FCE Ultra RX for check and test my modifications of FCEURX for add a proper autoboot ROM function and add a new missing color palette to the emu. Here you can read more info: https://github.com/niuus/FCEUltraRX/pull/5

Tell me if you can check and accept the modifications i've made.

@SaulFabre
Okey, i'll check those, no problem.
 
  • Like
Reactions: SaulFabre

SaulFabre

Wii scene/hacking & Wii VC well-known guy
Member
Joined
Feb 6, 2019
Messages
1,130
Trophies
1
Age
22
Location
Ecuador
Website
saulfabreg-wiivc.blogspot.com
XP
2,457
Country
Ecuador
@niuus How I can compile properly FCE Ultra RX and Snes9x RX? for test the latest code used and also test my mods.

Tried with my setup of:
  • devkitPro 3.0.3
  • devkitPPC r26
  • libogc 2.2.1
  • all the ported libraries (portlibs) files
  • the necessary files for GC / Wii development
But it didn't work becuase i always get this same error:

upload_2021-8-8_15-47-34.png


Tried updating the devkitPPC and libogc and others but still doesn't work.

ANY help?

EDIT: I think i saw the cause of this problem, i had to install @FIX94's libwupc (https://gbatemp.net/threads/libwupc...library-for-wii-homebrew-applications.371574/), by putting all the libwupc folders with files in C:/devkitPro/portlibs/ppc/
And now it starts compiling normally:
upload_2021-8-8_15-57-26.png


EDIT 2:
The compiling finally was successful. Now, time to mess up with some code for make my mods and compile them... :)

EDIT 3: Still need help about what is the setup of devkitPro (devkitPPC) for compile properly Snes9x RX and FCE Ultra RX, always got stuck in those errors in these versions, (except of the official FCE Ultra RX source code from @niuus which i don't have problems), as shown:

Snes9x RX official from @niuus:

upload_2021-8-8_16-36-25.png


Snes9x RX Mod by me, @SaulFabre https://github.com/saulfabregwiivc/Snes9xRX/

upload_2021-8-8_16-44-48.png


FCE Ultra RX Mod by me, @SaulFabre https://github.com/saulfabregwiivc/FCEUltraRX/

upload_2021-8-8_16-45-49.png


Any help please?
 
Last edited by SaulFabre,
General chit-chat
Help Users
  • Julie_Pilgrim @ Julie_Pilgrim:
    everytime someone says a celeste level was so hard that they had to turn on assist mode my ego goes up a bit
    +1
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    does anyone here have gbatemp
    Gift
  • MightyJAK @ MightyJAK:
    I don't understand the question. "Have"? as in, owning the the website?
    Gift
  • Sicklyboy @ Sicklyboy:
    I have gbatemp
    Gift
  • Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    now you can rep this site wherever you go!
    Gift
  • Sicklyboy @ Sicklyboy:
    Have been for the past 5+ years ;)
    +1
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    also holy shit i realized you can click the @ next to names in chat to tag users, how did i not notice this before
    Gift
  • Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    me when someone asks me who made the song "Runaway"
    +1
    Gift
  • MightyJAK @ MightyJAK:
    Anybody here got a GDEMU?
    Gift
  • Sicklyboy @ Sicklyboy:
    I got a (presumed) clone from Aliexpress, but haven't installed yet
    Gift
  • MightyJAK @ MightyJAK:
    I've got a clone, it works fine, but I can't get it to play nice with my SDcard reader.
    Gift
  • Sicklyboy @ Sicklyboy:
    like an sd card slot extension thing?
    Gift
  • MightyJAK @ MightyJAK:
    Yeah, to load from (and save data to) an SD card plugged into the serial port.
    Gift
  • Sicklyboy @ Sicklyboy:
    You test that extension thing through a regular usb reader on your pc? Could just be a shit one. Bought one for my 3d printer and it just straight up doesn't work
    Gift
  • MightyJAK @ MightyJAK:
    it can't be plugged into a USB reader (it's made from a regular SD card to USB adapter, but with the USB end modded to a Dreamcast serial plug)
    Gift
  • MightyJAK @ MightyJAK:
    It was working fine before I installed the GDEMU, but now the Dreamcast doesn't recognize it when I boot up Dreamshell.
    Gift
  • Sicklyboy @ Sicklyboy:
    ahhh I gotcha. yeah haven't looked at it that much so I'm not super familiar with the hardware
    Gift
  • MightyJAK @ MightyJAK:
    Can't find any threads about this particular issue on GBAtemp or the wider intarwebz. Saw one video on YouTube that seemed relevant, but it was some dude with the same issue, no solutions offered in the comments. :/
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    my teacher was showing me something and i noticed they had gbatemp open in another window
    Gift
  • SpazzyShinobi @ SpazzyShinobi:
    when worlds collide
    +1
    Gift
  • MightyJAK @ MightyJAK:
    Your teacher is ONE OF US... ONE OF US...
    +1
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    they could be in this very chat, they could be any one of us
    Gift
  • MightyJAK @ MightyJAK:
    InB4 "Julie, get back to work on your homework, that assignment is due tomorrow."
    +1
    Gift
    MightyJAK @ MightyJAK: InB4 "Julie, get back to work on your homework, that assignment is due tomorrow." +1