FCE Ultra GX, SNES9x GX 007, Visual Boy Advance GX 1.0.5

Discussion in 'Wii - Emulation and Homebrew' started by djdynamite123, Nov 19, 2008.

  1. djdynamite123
    OP

    djdynamite123 Master Of Hardcore!

    Banned
    3,791
    1
    Sep 21, 2008
    Redcar, England UK
    Visual Boy Advance GX
    [​IMG]
    1.0.5 - November 19, 2008
    SDHC works now
    Frameskipping tweaks
    Fixed snapshot loading issue
    Full widescreen support
    Changed scaling
    Zooming fixed (thanks eke-eke!)
    PAL timing changes - EURGB60 mode forced
    Wii - Added console/remote power button support
    Wii - Added reset button support (resets game)
    Wii - Settings file is now named settings.xml and is stored in the same folder as the DOL (eg: apps/vbagx/settings.xml)
    GameCube - Added DVD motor off option
    GameCube - Fixed GBA loading issue
    http://code.google.com/p/vba-wii/downloads/list


    SNES9x GX
    [​IMG]
    007 - November 19, 2008
    added: SDHC support
    added: SD/USB hot-swapping
    added: zoom saving
    added: IPS/UPS/PPF patch support
    added: Qoob modchip support (thanks emukidid!)
    added: Added console/remote power button support (Wii only)
    added: Added reset button support - resets game (Wii only)
    changed: Settings file is now named settings.xml and is stored in the same folder as the DOL - eg: apps/vbagx/settings.xml (Wii only)
    fixed: swc, sfc file support
    fixed: inverted sound channels
    fixed: some game crashes
    fixed: snapshot saving for games with SPC7110, BS, DSP, or CX4
    fixed: justifier support
    fixed: superscope turbo button
    fixed: widescreen support
    fixed: ActRaiser 2 issues
    fixed: Invalid memory accesses in C4 and OBC1. MMX3 Toxic Seahorse stage now can be emulated with HDMA. (zones)
    fixed: Updated snapshot to prevent desync. Added some variables related to APU and HDMA. (gocha)
    fixed: zoom issues (thanks eke-eke!)
    fixed: original modes (thanks eke-eke!)
    fixed: vertical scaling for filtered/unfiltered modes (thanks eke-eke!)
    http://code.google.com/p/snes9x-gx/downloads/list



    FCE Ultra GX
    [​IMG]
    2.0.7 - November 18, 2008
    Special thanks to eke-eke & KruLLo for contributions, bugfixes, and tips
    Video code rewritten - now has original, unfiltered, filtered modes
    Zoom option
    16:9 widescreen support
    Full widescreen support
    SDHC support
    SD/USB hot-swapping
    A/B rapid-fire
    Turbo option
    Video cropping (overscan hiding) option (thanks yxkalle!)
    Palette changing fixed
    Fixed audio 'popping' issue
    Wii - Added console/remote power button support
    Wii - Added reset button support (resets game)
    Wii - Settings file is now named settings.xml and is stored in the same folder as the DOL (eg: apps/fceugx/settings.xml)
    GameCube - Added DVD motor off option
    http://code.google.com/p/fceugc/downloads/list
     


  2. oneleggedjack

    oneleggedjack GBAtemp Regular

    Member
    299
    0
    Sep 25, 2008
    United States
    has anyone made a wad for any of these yet?
     
  3. djdynamite123
    OP

    djdynamite123 Master Of Hardcore!

    Banned
    3,791
    1
    Sep 21, 2008
    Redcar, England UK
    download autoinjectuwad, read the readme, and inject the new .dol yourself to your old wads [​IMG]
     
  4. OSW

    OSW Wii King

    Former Staff
    4,796
    6
    Oct 30, 2006
    you're FAST man! thanks for the heads up [​IMG] did you get the news first from tehskeen?

    oh i just you can get updates when google code pages are updated! thats awesome. is that how u do it?

    love your post layout too!
     
  5. djdynamite123
    OP

    djdynamite123 Master Of Hardcore!

    Banned
    3,791
    1
    Sep 21, 2008
    Redcar, England UK
    no problem mate, yeah i talk to brakken and go over tehkseen sometimes [​IMG]
    erm, i injected all these new releases, and they code dump as wads!!
    even with the correct folders and files in place, these releases have to be run through HBC [​IMG]
     
  6. harryk

    harryk GBAtemp Regular

    Member
    207
    0
    Oct 8, 2008
    Australia
    I just injected Forsaekn's channels and will try them later.

    Is it normal that there's a yellow "WARNING: Homebrew mode (...)"
    and 8 files besides the new WAD (which I delete?) after the injection?

    also: what's the correct region number for PAL in the injector.ini? GBAtemp and Google don't seem to know anything about this.
     
  7. ploggy

    ploggy WAKA! WAKA!

    Member
    1,263
    706
    Aug 29, 2007
    United Kingdom
    Will someone upload ready made channels of these new emulators.?

    Every time I try I get Error ret= 4100 [​IMG]

    Thanks [​IMG]
     
  8. kedest

    kedest GBAtemp Psycho!

    Member
    3,287
    110
    Feb 6, 2007
    Netherlands
    cool. I've updated all of them, it's good to see these emulators are in active development
     
  9. ceelo

    ceelo GBAtemp Regular

    Member
    238
    54
    Mar 9, 2008
    United States
    I just checked the NES and SNES ones - they dont have a wii.dol to make a channel for... has anyone made a wii channel using these? Can I use the gcn dol? Its there.. I tried the boot.dol in the apps folder, but didnt work...
     
  10. harryk

    harryk GBAtemp Regular

    Member
    207
    0
    Oct 8, 2008
    Australia
    Creating the Channels with the boot.dol works fine. The problem is, you have to change the Source code first so it doesn't code dump when started via Wii Channel.
     
  11. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    641
    Nov 2, 2008
    Cote d'Ivoire
    I can't save/load emulator generated saves with the new VBA GX =/
     
  12. djdynamite123
    OP

    djdynamite123 Master Of Hardcore!

    Banned
    3,791
    1
    Sep 21, 2008
    Redcar, England UK
    should be able to...hmm
    harryk hope you can edit the sources so they can be as channels, also take out REMOVE the return to loader, and just leave the return to wii menu [​IMG]
    i would but my XP wont compile propperly [​IMG]
     
  13. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    641
    Nov 2, 2008
    Cote d'Ivoire
    strange, it told me that the save was created successfully, but when I try to load it, it say: "fail trying open the save file!" I check the save folder and there no emulator generated saves... maybe my game generated saves are causing it? I didn't have this problem with 1.0.3 =/
     
  14. DigitalSquirrel

    DigitalSquirrel GBAtemp Regular

    Member
    258
    0
    Oct 26, 2008
    United States
    Anyone know about the timing for FCEU and SNES? How accurate are they to the actual systems?
     
  15. Sick Wario

    Sick Wario Club Nintendo

    Member
    1,225
    62
    Jul 24, 2006
    NNID: godrugal
    i love these emus and the updates are amazing! 1 problem though. after i updated the folders in the apps dir of the SD card sometimes my save states work, sometimes not. metroid zero mission, minish cap and mario bros 3 saves all wont load. some do though. i'm talking about SNES9x, VBA and FCEU. am i updating it wrong or something?
     
  16. Jacobeian

    Jacobeian GBAtemp Advanced Maniac

    Member
    1,881
    122
    May 15, 2008
    Cuba
    accuracy is the same as the last PC versions of fce ultra and snes9x

    speed is 100% for all games I've played (snes and nes), was not always the case when running on gamecube

    why not trying yourself to make an opinion ?
     
  17. blueoakleyz

    blueoakleyz GBAtemp Regular

    Member
    237
    0
    Jun 26, 2008
    United States
    custom channel for snes please!
     
  18. kevenz

    kevenz GBAtemp Regular

    Member
    287
    1
    Oct 20, 2008
    Canada
    ^^They don't work as channel.

    I wish someone would edit the source to make them playable as channel.
     
  19. djdynamite123
    OP

    djdynamite123 Master Of Hardcore!

    Banned
    3,791
    1
    Sep 21, 2008
    Redcar, England UK
    already been discusses in other threads, it's been "worked on" due to the new save, will give auto code dump
     
  20. drabag

    drabag GBAtemp Regular

    Member
    227
    9
    Oct 26, 2002
    France
    Bordeaux
    Hello, I've got some problems with new Snes & VBA versions.
    I've made the update (from 006 and 1.0.4 which worked great) for both of them, so when I try to launch them (from HBC 9) I've got black screen and wiimote disconnected - have to reset wii !
    What kind of problem could it be ?
    The worst is that the problem keep on when I try to re-install old versions [​IMG]

    Someone please ?

    PS : PAL Wii 3.2E with 0.3 Gamma and Menu Patcher v1 installed