1. HungNswitch

    OP HungNswitch Member
    Newcomer

    Joined:
    Sep 27, 2018
    Messages:
    24
    Country:
    Denmark
    Hi,

    Im on OFW 6.0.1 using Reinx.
    The other day I unplugged the SD card from my nintendo switch (Didnt change anything in the SD card).
    Afterwards, I am unable to use my SD card when I am using Hekate 4.2.

    - Tried a new SD card, exfat and fat32 format. Still same issue.
    - OFW recognize SD card, but Hekate 4.2 still does not.
    - Nintendo switch could format the SD card without any issue.

    The big problem is that I cannot restore NAND cause of Hekate does not recognize SD card.

    The error I get is:

    "[FatFS] Error: NOFAT
    Failed to mount SD card (FATFS Error 13).
    Make sure that a FAT partition exists.."

    I will pay the person who solve this for me!
     
  2. HungNswitch

    OP HungNswitch Member
    Newcomer

    Joined:
    Sep 27, 2018
    Messages:
    24
    Country:
    Denmark
    Now I have this new error:

    "Failed to init SD card.
    Make sure that it is inserted.
    Or that SD reader is properly seated/"

    @CTCaer would you please help me? I will pay you.
     
  3. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    Your sd card is not seated properly.

    Try to do this test:
    http://i.gzn.jp/img/2017/08/25/clear-cases-nintendo-switch/s05.jpg
    In the image you can see a black padding above the sd card reader. Try to find it's location on your switch by raising the stand.

    Then press that spot and try to load a cfw or backing up BOOT0/1 for example.
    Sth small though. Not a full backup. And keep pressing it.

    Check results.
     
  4. fire888

    fire888 Member
    Newcomer

    Joined:
    Jul 4, 2016
    Messages:
    16
    Country:
    Indonesia
    @HungNswitch did u ever solve the problem ?
    cause suddenly today this happened to me.

    @CTCaer if it's not seated properly, why ofw could read the microsd ?
     
  5. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    Because OFW supports 1bit data bus.
    I don't.

    And this will stay like that, because it's better to fix the problem than having 1/4 of max speed.
    And also to identify this issue.
     
    mathew77 and NoNAND like this.
  6. fire888

    fire888 Member
    Newcomer

    Joined:
    Jul 4, 2016
    Messages:
    16
    Country:
    Indonesia
    fair enough

    but which black padding that u said ?
    is it this : https://www.dropbox.com/s/42xt3fr3zgbq26t/test.jpg?dl=0 ?


    let me narrate a little.
    yesterday I was playing mario rabbids, and then I want to play on tv, so I put it on dock.
    and just as I choose to open the game again, it hangs.
    after it hangs, I turn it off.
    I thought that because it has been turned off, I might as well change the microsd to play other games (I used 3 microsd 128 gb to install different games)
    so I changed the microsd, like usual then put the jig and r4i dongle, and voila, it blanks a while (there's no rei like usual), and then there's the red notes : "error : failed to init sdcard"

    I have tried the 3 microsds that worked perfectly before and all suffers the same.
    all microsds can be read on pc (so the microsds should still be good), and the switch can read it on ofw (so the microsd slot on switch should be good too ?).

    is this the case of that black padding ?

    edited :
    forgot to put that that error was with reinx (and all microsds used exfat format)
    have tried exfat and fat32 format and still the same
    then I tried hekate/atmosphere.
    with fat32 i got : "[FatFS] Error: NOFAT
    Failed to mount SD card (FATFS Error 13).
    Make sure that a FAT partition exists.."

    with exfat hekate, i got : failed to mount sdcard.

    I hope this bit of info can help u to help me track down the cause.. thx
     
    Last edited by fire888, Dec 17, 2018
  7. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    Try to init your sd card.


    That means deleting the partition and wiping and initializing MBR.
    You can do this via diskpart commands in windows.
     
  8. fire888

    fire888 Member
    Newcomer

    Joined:
    Jul 4, 2016
    Messages:
    16
    Country:
    Indonesia
    still dont know whats wrong.
    I even tried to ask my friend to replace the sd slot and it didnt help.
    I have to push the card and sometime (like about once in an hour - I mean tens of tries and in an hour I might succeed once).. I would succeed.. and cfw would load. after getting in game, all fine, until I turn it off again and have to reboot.. and this thing happened again.. really2 stressful.
     
    Last edited by fire888, Dec 21, 2018
  9. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
     
  10. fire888

    fire888 Member
    Newcomer

    Joined:
    Jul 4, 2016
    Messages:
    16
    Country:
    Indonesia
    done that too
    I delete partition with diskpart
    create partition with diskpart

    but when i try convert mbr, it error with msg :
    virtual disk service error:
    the specified disk is not convertible. cdroms and dvds are example of disks that are not convertible

    anyway, then I mark the partition active with disk management windows,
    and I format it to exfat.
    copy files for hekate that I downloaded from : http://www.r4i-sdhc.com/R4SDongles.asp (because I used dongle r4)

    tried it again.
    and it failed again with msg : failed to init sdcard (like usual if exfat format)
     
  11. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    Well the most important part of that is the MBR init. Aka wipe.
    If this is not done, you'll continue to have the same problem.
     
  12. Kafluke
    This message by Kafluke has been removed from public view by porkiewpyne, Dec 21, 2018.
    Dec 21, 2018 Show
  13. rbakaou

    rbakaou Newbie
    Newcomer

    Joined:
    Jan 10, 2019
    Messages:
    8
    Country:
    France
    Hi CTCaer,
    Having same issue described. tried to maintain pressure on the spot but didin't work. Any last idea before i try to open the case to fix the micro sd reader? or any tips on how to do the fixing?
     
  14. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    You tried to wipe your card first?
    Re init MBR.
    delete partitions and delete mbr. And then init it with it (NOT GPT, but MBR).
    Create partition and try again.
     
  15. rbakaou

    rbakaou Newbie
    Newcomer

    Joined:
    Jan 10, 2019
    Messages:
    8
    Country:
    France
    Hi CTCaer,
    I just tried to re init MBR.
    I used gparted. deleted parition. then created new mbr (msdos in gparted menu) then created a new parition. and connected the sd card to the switch without adding any new file just to see if the switch can get the sd card info. but still getting the error about sdcard not beign mounted or seated properly.
    Any idea i should try next thanks?
     
  16. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    If that didn't work, then the problem is the sd card reader's connector :/
     
  17. rbakaou

    rbakaou Newbie
    Newcomer

    Joined:
    Jan 10, 2019
    Messages:
    8
    Country:
    France
    Ouch. a lot of people getting this .didn't expect the nintendo switch reader to be this fragile. gonna be hard to get a replacement where I am but will try. thanks for your support. and great work on hekate.
     
  18. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    Thanks.
    Try to re seat it first, before replacing it. 99% of the problems are there.
     
  19. rbakaou

    rbakaou Newbie
    Newcomer

    Joined:
    Jan 10, 2019
    Messages:
    8
    Country:
    France
    Hi, i'm back to get you updated.
    As CTCaer said I opened the switch and disconencted and connected properly the reader and now it works like a charm. every time. Well done to CTCaer for figuring it out. So even normale non hacked switch may have this issue and you won't even know about it cause OFW won't notify you.
    Maybe even some of my installation issues could be related to this like tinfoil wifi installation.
     
  20. CTCaer

    CTCaer Developer
    Developer

    Joined:
    Mar 22, 2008
    Messages:
    1,154
    Country:
    Greece
    ^_^

    With how many they are, you can easily call it a production fault.
    Just add some extra padding to make it tight with the case
     
  21. MegaKyurem

    MegaKyurem WAAALUIGI
    Member

    Joined:
    Jul 4, 2016
    Messages:
    227
    Country:
    United States
    I'm getting this error but only when I have the sdcard in FAT32. When It's in exFat, it works fine. I have a 64gb sd card formatted to Fat32 with AOMEI partition assistant. Could it still be the switch's sd card or is it the formatting software?

    Update: I formatted the sd card using guiformat and diskpart and the sd card works now. For anyone else getting this error, make sure you try that method first, as your switch's sd card slot might not be broken. (A clear sign of this is if your sd card works when it's formatted to exFat)
     
    Last edited by MegaKyurem, Jan 28, 2019
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - partition, [FatFS], Failed