EZV 3in1 - Broken Sword won't run

Discussion in 'GBA - Flashing Hardware and Software' started by zombielove, Jul 12, 2007.

Jul 12, 2007
  1. zombielove
    OP

    Member zombielove GBAtemp Regular

    Joined:
    Jun 3, 2007
    Messages:
    270
    Country:
    Australia
    I can't get Broken Sword to run. Just goes to a black screen after showing the GBA bios screen.

    I'm using an EZ 3 in 1 and a DS Linker (N-Card clone), running 3in1 expansion pack tool. I've tried re-downloading the rom, and have tried both US and European versions. I've tried in both NOR and PSRAM modes.

    Mario Party won't start either. I get a screen saying "Saving...."

    Anyone know what I can do?
     
  2. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,745
    Country:
    United Kingdom
    Did you patch the rom with GBATA or EZ4Client? (if one try the other)
     
  3. Destructobot

    Member Destructobot Crave the Hammer

    Joined:
    Oct 15, 2006
    Messages:
    5,005
    Location:
    Portland, OR
    Country:
    United States
    Don't use the EZ4 Client except for games that use 1024Kbit Flash saves. Use GBATA for everything else. Games that use EEPROM and Flash save types need to be patched. Games that use SRAM save types do not.

    The EZ4 Client causes lost saves when used with the 3in1 Expansion Pack Tool in PSRAM mode.
     
  4. zombielove
    OP

    Member zombielove GBAtemp Regular

    Joined:
    Jun 3, 2007
    Messages:
    270
    Country:
    Australia
    Thanks for the replies.

    Didn't think I would have to patch since everything else was working fine with clean roms. I'll try patching with GBATA.

    Oh yeah, I get a corrupted save message when I play Metroid Zero Mission. I figured out what's causing it though: Started the game in PSRAM, saved and tried to run it in NOR. If I run it in PSRAM mode it's fine.

    Edit: All working now! Thanks!

    ....But Broken Sword is kind of disappointing. Wish it was on DS.
     

Share This Page