EZ-IV 1.76 Boktai 1-3 w/ solar patch white screen

Discussion in 'GBA - Flashing Hardware and Software' started by [Truth], May 24, 2015.

  1. [Truth]
    OP

    [Truth] GBAtemp Advanced Fan

    Member
    836
    350
    Mar 21, 2006
    Germany
    Mushroom Kingdom
    Hi,
    since kernel 1.76 I get a white screen on bootup with Boktai 1-3 with the solar patch by Prof. 9 applied.
    The games booted fine on 1.74.

    Can someone confirm the issues?
     
  2. migles

    migles Mei the sexiest bae

    Member
    6,899
    4,632
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    i played the first game on my ez iv with the last kernel just fine...
    but i didn't applied any patch, i downloaded the rom from that paradise website, which already comes pre-patched
     
  3. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,500
    9,318
    Nov 21, 2005
    The pre patched/scene patched stuff is not as nice or configurable as Prof. 9's work though migles.

    I assume you tried booting by holding L and A. If I have time later I will report back.

    It is not the first time that this patch set has caused problems though.
     
    migles and [Truth] like this.
  4. [Truth]
    OP

    [Truth] GBAtemp Advanced Fan

    Member
    836
    350
    Mar 21, 2006
    Germany
    Mushroom Kingdom
    That did the trick, thank you.

    Why is that reboot before booting the game no longer the standard in 1.76?
     
  5. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,500
    9,318
    Nov 21, 2005
    It had not been standard for many years, possibly even since some version of the EZ3. Before the 2013 edition and the microSD updates though most people used (either because it was suggested, because it was in the pack or because the skin makers used it) the Modulo Reset hacked loader which did default to/force a hard reset, albeit to sort a different problem.
     
  6. migles

    migles Mei the sexiest bae

    Member
    6,899
    4,632
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    i didnt knew you could configure it.. its nice to know that, i kinda hated the controls the pre-patched rom used..
     
  7. [Truth]
    OP

    [Truth] GBAtemp Advanced Fan

    Member
    836
    350
    Mar 21, 2006
    Germany
    Mushroom Kingdom
    Is the modulo reset hacked loader available for 1.76?
     
  8. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,500
    9,318
    Nov 21, 2005
    [Truth] likes this.
  9. kuwanger

    kuwanger GBAtemp Regular

    Member
    227
    89
    Jul 26, 2006
    In v1.76 change byte at 0x6802e from 0x00 to 0x26. This is a very nasty hack to change a soft reset into an (bios undocumented) hard reset. Funny truth is, I'm not really sure this is actually how v1.74 and earlier did it, but it does seem to work.

    Still not real progress on updating fix_colors. Nor any word from the ezflash team, so *sigh*. A shame too because to be honest it was a long pain patching the font function in the past and hard to justify now that they're "active".

    PS - On an unrelated note, I really dislike how slow the later firmwares are at loading games so I tried doing various things and found out that (1) making a 2GB partition and formatting to FAT16 doesn't make it any faster and (2) apparently the new firmware supports FAT16 64KB clusters which a nice oddity putting in the same boat as the Windows NT line (NT3.1 to XP at least).
     
    migles, [Truth] and Localhorst86 like this.
  10. [Truth]
    OP

    [Truth] GBAtemp Advanced Fan

    Member
    836
    350
    Mar 21, 2006
    Germany
    Mushroom Kingdom
    Thanks a bunch.

    Could you tell me the offset for the cleaned-up version draxoon uploaded a while ago?
    I uploaded the ezfla_up.bin here.
     
  11. Localhorst86

    Localhorst86 GBAtemp Advanced Fan

    Member
    914
    469
    Jul 17, 2014
    Germany
    My Nintendo works for Dad
    It should always be offset 0x6802e. At least it was on the clearlooks skinned version I was using.
     
  12. [Truth]
    OP

    [Truth] GBAtemp Advanced Fan

    Member
    836
    350
    Mar 21, 2006
    Germany
    Mushroom Kingdom
    Hmm, it didn't work for me.
     
  13. Localhorst86

    Localhorst86 GBAtemp Advanced Fan

    Member
    914
    469
    Jul 17, 2014
    Germany
    My Nintendo works for Dad
    Maybe you flashed the unmodified version? I took your file, patched location 0x6802e from 0x00 to 0x26 and flashed it to my ezflash iv. Works fine, games always start with a reset.

    EDIT: Simply try applying the IPS to the ezfla_up.bin. That should work.
    usual disclaimer: I do not take responsibility for that file, use at your own risk.
     

    Attached Files:

    Last edited by Localhorst86, May 31, 2015
    tiduscrying and [Truth] like this.
  14. [Truth]
    OP

    [Truth] GBAtemp Advanced Fan

    Member
    836
    350
    Mar 21, 2006
    Germany
    Mushroom Kingdom
    Yes, looks like I mixed something up.
    Checksum of my edited file and original with your IPS applied match.
    Now it´s working, thanks.

    P.S.: Which Clearlooks 1.76 version are you using?
    I didn´t find a good patched one with font fixes applied etc.
     
  15. Localhorst86

    Localhorst86 GBAtemp Advanced Fan

    Member
    914
    469
    Jul 17, 2014
    Germany
    My Nintendo works for Dad
    I am a friend of minimalism so I made my own skin using draxoons toolkit. This has font and hard reset patch applied. It's a mixture of a few different skins and my own splashscreen.

    EDIT: I am not yet entirely happy with this skin, I might still make a few changes, especially the icons.

    EDIT2: a new, nicer skin version can be found here: http://gbatemp.net/threads/ez-flash-iv-skin-1-76-ez-flat-iv.389868/
     
    Last edited by Localhorst86, May 31, 2015
    [Truth] likes this.
  16. ubergeek77

    ubergeek77 Post editing world champ.

    Member
    556
    256
    Dec 6, 2014
    United States
    I've applied the skin with the patch applied, and I can load the game now without pressing L, but I can't save the game or any of the time settings. This is the same for all 3 Boktai games at the moment. Actually, NONE of my games are saving, and I can't seem to figure out why. Can anyone help?

    Nevermind, I just got my card today and had no idea these games needed to be patched for saving to work. Thanks for the reset patch though! It works nicely.
     
    Last edited by ubergeek77, Jun 12, 2015