EZ-Flat IV 2.05 - A skin for your EZ-Flash IV card (Kernel 2.05)

Discussion in 'GBA - Flashing Hardware and Software' started by Localhorst86, Jul 12, 2017.

  1. Localhorst86
    OP

    Localhorst86 GBAtemp Maniac

    Member
    6
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    The issue is the GSS-patching which you can disable in 2.05 entirely via the keyset.cfg. The EZ-Flash will still apply the savegame patches (i.e. no need to patch the ROMs with the crappy PC software, just slap the No-Intro roms on there).

    Seein as you are using 2.01 your ROMs are probably already patched. At that point there is no real need for you to update, 2.05 is not faster at loading ROMs than 2.01, the compatibility is only slightly improved due to the 2.03 firmware (iirc) introducing some AP patches for games like the NES Classic Series, Legacy Of Goku titles etc..
     
  2. Invader TAK

    Invader TAK Member

    Newcomer
    3
    Aug 14, 2008
    United States
    Great skin! But just wondering, are there any other KEYSET.CFG GSS exclusions that are worth adding on top of the three you already included?
     
  3. Localhorst86
    OP

    Localhorst86 GBAtemp Maniac

    Member
    6
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    Any games that crash with GSS enabled (which are a lot)
    I have disabled GSS on my EZ-Flash IV and EZ-Flash Reform carts entirely via the keyset.cfg to maximize compatibility, I do not care for in-game-reset myself and therefore did not extend the list.
     
    Last edited by Localhorst86, Feb 28, 2018
  4. Invader TAK

    Invader TAK Member

    Newcomer
    3
    Aug 14, 2008
    United States
    Yeah I currently have it disabled as well. I'll probably just leave it disabled as well because I have quite a few games loaded on the micro SD and I don't wanna have to go through each one just to see how they react to GSS.
     
  5. Metalchef

    Metalchef Newbie

    Newcomer
    1
    Mar 4, 2018
    Italy
    But is the best 2.03 or 2.05?
    With 2.05 not work soft reset
     
  6. Localhorst86
    OP

    Localhorst86 GBAtemp Maniac

    Member
    6
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    Soft Reset works fine on 2.05 if you enable it in the keyset.cfg file.
     
  7. Metalchef

    Metalchef Newbie

    Newcomer
    1
    Mar 4, 2018
    Italy
    I enabled it but not working

    I used ez client for gba files.
     
    Last edited by Metalchef, Mar 4, 2018
  8. Localhorst86
    OP

    Localhorst86 GBAtemp Maniac

    Member
    6
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    It does work. If it's not working there's something you're not doing right.

    1. Make sure that you're using clean ROMs, preferably from the no-intro set.
    2. Do not patch them using any sort of Software for the PC (i.e. gbata or EZ-Flash Client)
    3. Double check that the "DISABLE_GSS" flag in the keyset.cfg file is set to 0 (DISABLE_GSS = 0)
    4. Verify that the game you're trying to soft reset is not listed at the very end of the keyset.cfg file.
    5. If the "USE_KEYSET" flag is set to '1', take note of the Button combination in the keyset.cfg file. If it is set to '0', the button combination is "L+Up+B"
     
    zfreeman likes this.
  9. MrCokeacola

    MrCokeacola Member

    Newcomer
    1
    Feb 26, 2018
    Canada
    Just picked up an EZ Flash IV for super cheap (shhh don't tell anybody go buy an omega). Love this skin wish I knew about it sooner.
     
  10. epyon

    epyon Newbie

    Newcomer
    1
    Feb 10, 2016
    Brazil
    Great work dude. But I can't update to 2.05.
    I always on the black screen and nothing happens. What's the problem? Help me!!!!
     
  11. Localhorst86
    OP

    Localhorst86 GBAtemp Maniac

    Member
    6
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    -Does the update not work or did the update install properly and now the card doesn't boot anymore?
    -How do you launch the update?
    -What EZ-Flash Version are you using (miniSD, MicroSD, Reform)?
    -What SD Card are you using (Brand, Size, Class)
     
  12. epyon

    epyon Newbie

    Newcomer
    1
    Feb 10, 2016
    Brazil
    The update process not work.
    I've the miniSD version.
    My microSD: Sandisk 16GB Class 4.
     
  13. Localhorst86
    OP

    Localhorst86 GBAtemp Maniac

    Member
    6
    Jul 17, 2014
    Germany
    Nintendo works for my dad
    For the miniSD version you need a non-sdhc card to install firmware kernels. The bootloader/kernel installer does not supprt sdhc cards.
    Try using a card <= 2Gb
     
    epyon likes this.
  14. epyon

    epyon Newbie

    Newcomer
    1
    Feb 10, 2016
    Brazil
    Humm... I already expected. Thanks man :yaysp:
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice