Ez Flash Omega not saving on Fire Emblem

Discussion in 'GBA - Flashing Hardware and Software' started by Solus, Aug 10, 2018.

  1. Solus
    OP

    Solus Newbie

    Newcomer
    1
    Aug 10, 2018
    United States
    I just got my Omega a couple of days ago and have been trying to use it to play Fire Emblem and Fire Emblem: The Sacred Stones. In both of these games, I encountered an error where after saving, waiting 5-10 seconds like the manual says, and then shutting off my GBA, the game would not actually save properly. When I try to open the game up again, the save file is missing the "resume chapter" buttons to get right back into the game. I can actually load up that save, but the save actually appears to be an autosave from a long time ago. I have run into this error basically every time I close out of the game. I tried using save states to save my progress instead of the ingame save feature, and while those worked a bit better, they also got corrupted. I tried updating from the stock firmware to FW:5 K:1.03. I even tried switching to a new, faster microSD card that I had freshly formatted with the SD card formatter, and I'm getting the exact same problems. Is there anything that I can do to try to get the saves to work properly with these games or am I SOL until the devs do some kind of update.

    Specs:
    GBA SP AGS 001 (USA)
    Sandisk Ultra 32gb micro SDhc Class 10
    EZ Flash Omega FW:5 K:1.03
     
  2. RetroVortex

    RetroVortex GBAtemp Regular

    Member
    3
    Mar 10, 2008
    They have though. In the test flight thread thread just under this one they speak about how they disabled Fire Emblem's auto-save and allow you to save manually and at the end of the chapter. Have you tried that one?
    It's in the first post of that thread.
     
  3. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    Fire Emblem series games have high frequently saving rate in the battle scene. it would save every time after a character moved. the save rate will cause microsd locked in some condition. so we have to remove the auto-save in the 1.04 fw6 release.
     
    mitch200584 likes this.
Loading...