Hacking EZ-FLASH JR won`t boot

nazgul76

New Member
OP
Newbie
Joined
Nov 6, 2020
Messages
4
Trophies
0
Age
45
XP
27
Country
Brazil
Hi there!

I recently bought an EZ-FLASH Jr and updated to the latest firmware (FW5K105RC) as soon as I received it.
The thing wouldn't boot anymore, I got a "GAME BOY" with a "(R)" screen and nothing else...

I've tried different SD cards (8, 16 and 32Gb formated in FAT32, 32Kb), different Kernel files (ezgb.dat) on different units (GBC, GBA and GBA SP).
I did this for about an hour and then quit, left the thing on the desk and went lunch.

When I returned, I tried one more time and it worked just fine... WTH...
Well I thought it could be something related to FW5 and downgraded to FW4.
Now the thing won`t work again :-(

I saw on their website that EZ-FLASH Jr has some brick protection:
  • System on chip level recovery mode, prevent upgrade dead
Does anyone know how it works?
What am I doing wrong here?
 
Last edited by nazgul76,

EZ-Flash2

Official EZ-FLASH Stuff
Member
Joined
Jul 16, 2003
Messages
903
Trophies
0
XP
2,768
Country
China
There are a few key questions to ask

When the Gameboy logo appears, is there a full Nintendo logo below?

When the previous question is valid

Can you see the LOADING and OSINIT in the next screen?
 

EZ-Flash2

Official EZ-FLASH Stuff
Member
Joined
Jul 16, 2003
Messages
903
Trophies
0
XP
2,768
Country
China
There is no Nintendo logo, it’s blank where it should be.

If that's the problem, this is the game console not detecting a cartridge insert, I'm guessing it's a bad contact.

Try using a cotton swab with anhydrous alcohol to wipe the metal contact points of the cartridge.
Plug and unplug several times in the console slot to find a steady spot.
 

nazgul76

New Member
OP
Newbie
Joined
Nov 6, 2020
Messages
4
Trophies
0
Age
45
XP
27
Country
Brazil
Well I’ve tried 3 different units that are working just fine with other cartridges and EZ-FLASH Jr doesn’t work with any of them.
If fact when I try to boot EZ-FLASH Jr it’s blank where the Nintendo logo should be but there is the “(R)” symbol, so it’s detecting “something”.
It’s different if I turn the unit on with no cartridge inserted (black bar).

Tried to clean the contact points of the cartridge with no success.
 
Last edited by nazgul76,

EZ-Flash2

Official EZ-FLASH Stuff
Member
Joined
Jul 16, 2003
Messages
903
Trophies
0
XP
2,768
Country
China
Well I’ve tried 3 different units that are working just fine with other cartridges and EZ-FLASH Jr doesn’t work with any of them.
If fact when I try to boot EZ-FLASH Jr it’s blank where the Nintendo logo should be but there is the “(R)” symbol, so it’s detecting “something”.
It’s different if I turn the unit on with no cartridge inserted (black bar).

Tried to clean the contact points of the cartridge with no success.

if only ® displayed. no nintendo. you may contact your dealer for a replacement.
 

nazgul76

New Member
OP
Newbie
Joined
Nov 6, 2020
Messages
4
Trophies
0
Age
45
XP
27
Country
Brazil
Here's the problem:

gb.jpg
 
General chit-chat
Help Users
    KennieDaMeanie @ KennieDaMeanie: If you play an electric guitar at a beach will you shock people