EZ-Flash IV won't boot games on my GBA SP

Discussion in 'EZ-Flash' started by MartinAugustsson, Mar 11, 2014.

  1. MartinAugustsson
    OP

    MartinAugustsson Member

    Newcomer
    46
    15
    Jan 17, 2012
    Hello! I recently got my EZ-Flash IV home. When trying to start games, I have no success. The first games I tried to add, and start was Pokemon Fire Red and some rom hacks. One of the roms booted up just fine. Until after I chose a gender and was about to choose a name. Then the game freezes and makes sounds like in the video I have posted. Same goes for Minish Cap (as I used to demonstrate in the video).
    I'm using the patcher that came with the pack for EZ-Flash IV to add games to the SD card. I'm using a MINI SD card.
    However, I can run minish cap and fire red from NOR with no problems at all

     
  2. dragonblood9999

    dragonblood9999 GBAtemp Maniac

    Member
    1,367
    370
    Sep 27, 2007
    Canada
    the video is private
     
  3. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,696
    9,565
    Nov 21, 2005
    United Kingdom
    Sounds like you have dodgy contacts between the miniSD and the EZ4.

    Clean the miniSD contacts first, if you can then do the EZ4 ones. Otherwise remove and insert it a bunch of times and it should get better.

    Otherwise it may be that you have a dodgy miniSD.
     
  4. MartinAugustsson
    OP

    MartinAugustsson Member

    Newcomer
    46
    15
    Jan 17, 2012
    The video is now public
    Edit: I have tried cleaning the miniSD, but can not get inside the flash card
    Also, would I be able to flash with ezfla_up.bin if the SD card is acting up?
    What's strange is that, exactly after selecting gender in pokemon is freezes. Every time, at the same spot (I have tried other fire red roms)

    Edit 2: At the moment I'm using a hama miniSD card 256 mb that I took from a digital camera we had at home, while wating for a microSD, non HC that I later will use with an adapter
     
  5. MartinAugustsson
    OP

    MartinAugustsson Member

    Newcomer
    46
    15
    Jan 17, 2012
    So, it's probably the SD card then?
     
  6. MartinAugustsson
    OP

    MartinAugustsson Member

    Newcomer
    46
    15
    Jan 17, 2012
    You are a GOD. My ignorance left me waiting for a long time before I fixed it. I tried cleaning the miniSD again and insert it a few times and now it's working like a charm!
     
  7. w1nd0wsb00t

    w1nd0wsb00t Newbie

    Newcomer
    2
    0
    Mar 20, 2014
    Netherlands
    Exact the same problem!
    I ordered a Ezflash IV from realhotstuff.hk (EZ402 2006.03)
    I didn't now where to get the 2013 version.
    I ordered a Trancend 2GB miniSD in a store closeby.
    Flashed the original ez_up.bin and after that didn't worked
    I tried clearlooks, also didn't worked.
    Some problem as above and some games had a black or white screen.
    Cleaned the new MiniSD card and the newly opened Ezflash iv, also didn't work for me.
    Tried putting it in like a 50 times, also with no success.

    What can be the problem?
    Maybe a faulty Flashcard or faulty psram or something else

    I am trying different things now for almost a week.
     
  8. Mikesahhh

    Mikesahhh Mikes

    Newcomer
    77
    9
    Nov 4, 2012
    I have this exact same problem aswell with my newly bought EZ Flash IV and its either the problem in that video or black or white screen but weridly a few games seem to work like Super Mario World: Super Mario Advance 2 (allthough it may crash in middle of gameplay sometime) I messaged my buyer about the issues and he replied with
    "Sorry, because relatively old product, production molds aging, resulting in some ez iv such a problem, you can return it to us, we will give you exchange a new, thank you kind for your understanding."
    So I guess I have to send my cart back to them and hope the new cart I get will be better -_-