EZ Flash IV MicroSD : Blank screen when starting some games

Discussion in 'GBA - Hardware, Devices and Utilities' started by j2k15, Jun 29, 2016.

  1. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    Hi there,

    I bought a EZ Flash IV MucroSD device because I read that its compatibility is really better than the SuperCard SD (I currently have).

    I'm using it for GBA only (and accessory with .gb and .gbc files).

    I've installed latest Kernet on it (v1.77) and downloaded the latest client software (EZ4_20140306).

    I've formatted a 2 GB MicroSD card and created on it a folder "Roms GBA".

    I've successfully patched few NES classics (using IPS) and with the Client Software copied them to the MicroSD card. The folder "Saver" has been created with the .sav files.

    I had to shorten longer file names (games would not start - black screen) but after renaming them and their .sav file, they almost work like a charm (not start at the first attempt).

    With few other games, it works. My problem is with all DK Country games.

    When I start one, I get a blank screen and nothing happens. I've patched them using Client Software of course.

    I've the same issue with some Mario Advanced games.

    I don't know if I do something wrong but it seems compatibility is worse than an old SuperCard SD.
    Anyone else experienced the same ?

    I'm on Win 7 64-bit. I don't know if it matters or not...
     
  2. HiddenRambler

    HiddenRambler GBAtemp Regular

    Member
    147
    327
    Nov 20, 2015
    I think you're running into the hard reset issue. Some games need the "hard reset" mode to start properly and show a white screen when started with A button. To do this scroll to the game and hold down L when pressing A to start the game.
     
  3. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    Hi, I tried this.
    Console is well restarting but game does not start.

    I'm testing on a fat DS.
    I'll try also this weekend on my GBA SP.
     
  4. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    Tried on SP... Same issue. :-(
    I'll look to send it back. I'm disappointed by this cart.
     
  5. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    I tried older kernels and also another Micro SD and still same issue.
    I'll definitely send it back.
     
  6. HiddenRambler

    HiddenRambler GBAtemp Regular

    Member
    147
    327
    Nov 20, 2015
    Just tried donkey kong country and donkey kong country 2 on my Micro SD Ez Flash IV using a GBA SP. Didn't even patch it. Started up just fine. there was a white screen for 1.5 seconds and then the Rare logo came and game started. Perhaps you cart is defective, i'd recommed you try a different GBA before going through the hassle to send it back?
     
    Last edited by HiddenRambler, Jul 12, 2016
  7. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    I tried on a DS Fat and GBA.
    I tried on another DS Lite. All same results.
    Seller accepted to send a replacement.
     
  8. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    Hi,

    I received a new one and it's now working like a charm !
     
  9. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    For my info, is the default Firmware available somewhere ?
    I'd like to completely reset the faulty one ?
    Is there a way to complete remove Firmware and then reinstall ?
     
  10. tiduscrying

    tiduscrying that butt...

    Member
    467
    429
    Jun 12, 2012
    United States
    HELL
    Download the appropriate firmware from this site. Extract the file and rename it "ezfla_up.bin" if it isn't named that already. Put it on the root of your Micro/MiniSD card and boot your console holding the "R" button. It will then flash the firmware.

    If you're looking to flash an "old" firmware (I don't know if its the one that came with your card though), download version 1.75. If you want the latest and greatest on the card, flash version 1.77 or 1.76. Both versions added pretty nice fixes to the firmware and made my cart a lot speedier than it was before!
     
  11. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    The thing is that all the problems I described here above are occuring with all firmware from this site.

    The replacement one I receive just works out of the box. So I don't want to mess this one up.

    The faulty one, since some games are working, mostly don't and that the OS is launching, I cannot imagine that it's hardware issue.

    So I would like to start from a clean sheet.

    What I noticed, even if I reinstall firmware, some data persists (e.g. language preference). So I'd like to know if there is a way to really erase everything and then reinstall 1.76 or 1.77.
     
  12. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    Hi, I know it's an old topic but even if I have received a replacement one, the seller let me keep the first one.
    I come across it yesterday and was wondering if I could manage to repair it to give it to a friend.

    So my question was: is it possible to totally erase all firmware / settings from the cart to restart from a clean sheet ?
     
  13. ltsheppard

    ltsheppard Member

    Newcomer
    31
    3
    Aug 27, 2015
    Gambia, The
    Start it up with no sd inserted and press R. It will delete the firmware.
     
  14. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    Thanks, I'll do this !
    So I tried to erase.
    Then I tried with 1.77, not working.
    I erased again and reinstalled 1.72 but same result.
    I don't think this cart can be repaired.

    Note: that even if I erased the firmware, settings like language preferences persisted...
     
    Last edited by j2k15, Mar 29, 2017
  15. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    I saw this:
    https://gbatemp.net/threads/ez-flash-iv-problems-noob-question-please-help.380008/

    I'll try on my EZ Flash IV micro SD. Never know...

    [EDIT]

    Paper trick does not solve the issue.

    I turned on sound while trying and it really hear strange sounds for games not starting.
    I also tried to copy a game to the NOR and when doing so it's working fine.

    Only when I start games the issue is coming.
    Any advice is welcome.

    [EDIT 2]

    Trying again with the paper, I got some better results.
    Only 2 games were not working.

    I tried another thickness and again initial problem !

    After many tries, I think I found the good "thickness" making all my games run.

    It's really a bad assembling issue. It's a shame to deliver products with a so low quality and that this product passed the quality control if such a thing exists in this company.
     
    Last edited by j2k15, Mar 31, 2017
  16. Blue_Lizard

    Blue_Lizard Newbie

    Newcomer
    2
    0
    Apr 29, 2017
    Where did you buy it from? Some carts are just faulty. Contact the seller and ask them for help. If it's broken they should just replace it.
     
  17. j2k15
    OP

    j2k15 Member

    Newcomer
    24
    0
    Jun 24, 2016
    United States
    I bought it from eBay.
    I got a replacement one but the seller let me keep the faulty one.
    So I tried to fix it to give it to my cousin.
    I could fix it with the paper trick.