Ez Flash IV lite & Moonshell

Discussion in 'EZ-Flash' started by alx886, Nov 9, 2006.

Nov 9, 2006

Ez Flash IV lite & Moonshell by alx886 at 1:35 AM (1,990 Views / 0 Likes) 11 replies

  1. alx886
    OP

    Newcomer alx886 Newbie

    Joined:
    Sep 18, 2006
    Messages:
    1
    Country:
    Hi Everyone:

    I'm a real noob when it comes to this. I'm a little lost as to what I have to do in order to play video/mp3 files. I'll tell you what I have done so far.

    I converted a file from AVI to dpg I believe using DPG tools

    That's about as much as I have been able to muster.

    Here's my issue. I've downloaded Moonshell, but for my particular unit it's not working. I do have a couple questions.

    1. I belong to other forums with regards to other topics and nothing upsets people more than questions that have been asked a million times before. If you know that my answer is somewhere pleaes point me in the right direction to a guide or something I can read where I can learn and I don't have to ask so many questions.

    Ok, now that the disclaimer is done, here we go.

    1. I have copied a file called moonshell.ds.gba on to my micro SD card, but when I boot up the EZ Flash 4 I don't see it. I can only see it if I remove my Passcard 3 then it boots into GBA but trying to run the file still doesn't work, the menus are in chinese and I don't know what they're saying (by the way how do I change that to english??)
    2. I try to execute the file (the video file) but obviously it won't run
    3. I tried using the core software to compile my version of moonshell and it comes up with like 3 files with the NDS extension, non of them run, am I doing something wrong?


    If anyone out there has a guide of some sort or can tell me what I'm doing wrong I'd greatly appreciate it.

    Here's my hardware

    Nintendo DS Lite
    EzFlash IV Lite /w Micro SD Slot
    1GB Micro SD Card
    EZPASS 3

    Please let me know. Thanks in advance to all of you that can help me out.

    Best Regards,

    Alx [​IMG]
     
  2. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    1. Get the latest stable version here.

    2. Decompress the zip/7z somewhere.

    3. Insert your EZ4's SD card in your reader and if need be connect that to your PC.

    4. Run the program setup.exe that came in the Moonshell archive.

    5. Select your language, click the save to ini button, click OK.

    6. Select your SD card from the the menu, click OK.

    7. Under "ROM Image" deselect all the bouttons except the one labled EZ-Flash 4, pick a clock plug in if you want, deselect the "When existing, backup is created." button and then click Setup.

    8. Deselect the "After closed" button, click OK.

    Congrats! Moonshell is on your SD and ready to go... Only it's named something naff (_BOOT_MP_EZSD_EZ-Flash4_SD.nds.bin) so you migh want to name it something else, like just "Moonshell.bin". Leave the .bin extension alone, though, if you do. The moonshell file should now show up and be executable from the EZ4 DS menu.

    As you have alread figured out, movies will need to be converted to DPG's before Moonshell will play them. MOD's, MP3's etc, though can go straight on your SD however. Once Moonshell is running just find the media you want to view/hear on your SD, select it/them and go. [​IMG]

    As to setting the EZ4's GBA menu to English. Select the 4th icon on the GBA menu (next to last), press the A button. On the next menu, leave the top item highlighted and press A. Select "English" and then press A. [​IMG]
     
  3. Valshar

    Newcomer Valshar Member

    Joined:
    Jul 13, 2006
    Messages:
    33
    Country:
    Portugal

    I followed your steps, noticing that when I leave only EZ4 option checked, there's a window on the side saying:

    for EZ-Flash4

    This cannot be written.
    The resume and bookmark cannot be used.

    I unchecked the resume function and tried anyway. Now trying out the program, when I launch it an error screen pops up saying that an error occurred, either the resume function ain't compatible, or the shell folder has been erased, or whatever, and asking to reformat the media and install again.

    Is (at least) this version of Moonshell incompatible with EZ4? or is there anything else I have to do?
     
  4. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    Are you sure you unselected the resume function? As you may notice unselecting it wasn't in my instructions as it should have defaulted that way. Another thing it sounds like you may have done is not written the files directly to the SD from the setup tool, and then failed to copy over the "shell" directory it creates and the files that directory contains. Oh... And don't use the EZClient on any of the Moonshell files, just write them to the SD directly.

    If you downloaded the 1.41 version I pointed you at, yes it's compatible w/ the EZ4 (it's on my SD and running currently) or I wouldn't have pointed you at it. [​IMG] Sorry, but my instructions are exactly what I did to get the version of Moonshell I have working on my EZ4 to run from a fresh download. Either you didn't follow my instructions exactly or something else I couldn't possibly trouble shoot from here is wrong.
     
  5. Valshar

    Newcomer Valshar Member

    Joined:
    Jul 13, 2006
    Messages:
    33
    Country:
    Portugal
    I think I followed all your steps correctly, but I'll try again from a fresh download and I'll say something later!
     
  6. Valshar

    Newcomer Valshar Member

    Joined:
    Jul 13, 2006
    Messages:
    33
    Country:
    Portugal
    Ok, I quit.I get that same error every single time...
     
  7. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    When you tried was there a folder named "shell" created on your SD?

    Or unzip this on your SD.
     
  8. faceless

    Member faceless pink sugar heart attack

    Joined:
    Jan 5, 2003
    Messages:
    567
    Country:
    United States
    i was just about to post on this too...

    1.41 doesn't seem to work when compiled for the EZ4... it hangs at this screen...

    but that premade 1.40 above works...

    [​IMG]
     
  9. cory1492

    Member cory1492 GBAtemp Maniac

    Joined:
    Jun 23, 2005
    Messages:
    1,489
    Location:
    Home, WhereElse?
    Country:
    Canada
    Do all the steps above, and replace (on your SD card) "_BOOT_MP_EZSD_EZ-Flash4_SD.nds.bin" with the one in this archive (source changes were included):
    Moonshell141-EZSD_only-09-11-2006-b.zip
    Other than plugin options, none of the other ones should matter.

    Alternately, here 1.41 pre-built (just have to copy the contents over to your SD card)
    Moonshell141-EZSD_only-11-27-2007.zip

    Thanks RatX for the mirror to host these on!

    PS: there may be another official revision once the new EZ4 driver (read and write) is fully stabilized. There is also an alternate version of 1.41 working on EZ4 with all the shell files built into the ROM.
     
  10. faceless

    Member faceless pink sugar heart attack

    Joined:
    Jan 5, 2003
    Messages:
    567
    Country:
    United States
    sweet, that first zip did the job.

    even works built as one big file like i do with my supercard...

    thanks alot!
     
  11. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    Now this is odd, I made that with the setup tool at the link that I supplied (I downloaded yonks ago, though, not when I posted instructions in this thread). When I run said setup it declares itself as 1.41. I just built it again to make sure and it worked, however, when executed on my DS it declares itself as 1.4 not 1.41. I figured the lack of version bump in the DS executable was just an oversight on Infantile Paralyzer's part. [​IMG] I suppose I could redownload the setup tool and try again...

    Sorry guys.

    Now to find out why my supposed 1.41 setup builds 1.4 executables. [​IMG]
     
  12. Valshar

    Newcomer Valshar Member

    Joined:
    Jul 13, 2006
    Messages:
    33
    Country:
    Portugal
    Nice, it's working now! Thanks a lot!
     

Share This Page