1. MrAPT1

    OP MrAPT1 Member
    Newcomer

    Joined:
    Dec 28, 2012
    Messages:
    11
    Country:
    United States
    So recently I reformatted my mini SD for my EZ flash IV, and I noticed that after I added all of my games and save files back, something odd happens when I'm in the menu.

    Basically, when I scroll down the menu of games or saves in my GBA or saver folder until I can no longer see the redirectories, both of the redirectories to the respective folders become blank files that say they take up 0 space that use the white square icon/broken image icon rather than being folder files that use the folder icon.

    Now, this isn't harmful, but it is a bit strange, and I'm wondering if I formatted the card wrong or something. Anyone know what's up? I'd like to be able to fix this because it's annoying me.
     
  2. FAST6191

    FAST6191 Techromancer
    Reporter

    Joined:
    Nov 21, 2005
    Messages:
    33,453
    Country:
    United Kingdom
    Are the 0 K files named things like tetriswo.rld -- 8.3 names but with the 11 characters instead being the first 11 characters of the game name it might have come from?

    Equally the loader has issues displaying more than 80 files a directory, as you can stick games in different directories and should never really have to go into the saver directory in loader this does not matter so much.
     
  3. MrAPT1

    OP MrAPT1 Member
    Newcomer

    Joined:
    Dec 28, 2012
    Messages:
    11
    Country:
    United States
    Nah, nothing like that.

    Yeah, I'm aware of that issue, though I have far less than 80 files in my GBA directory, so I don't quite think that's the problem.

    I've taken some screenshots, if it helps.
    [​IMG]

    This is the original directory, before I go into any menus. The folders look fine here.

    [​IMG]

    Here is when I'm inside the GBA directory. Notice that the folder directories are still fine at the top.

    [​IMG]

    Finally, here is the issue. Just scrolling down until you can no longer see the folder directories causes them to look corrupt for some reason when you scroll back up.

    Hopefully now that I've provided images the problem can be better diagnosed.
     
  4. MrAPT1

    OP MrAPT1 Member
    Newcomer

    Joined:
    Dec 28, 2012
    Messages:
    11
    Country:
    United States
    No more replies? Seems no one has any idea what could be causing it, I guess. :(
     
  5. FAST6191

    FAST6191 Techromancer
    Reporter

    Joined:
    Nov 21, 2005
    Messages:
    33,453
    Country:
    United Kingdom
    I confirmed it on mine. To my eye it looks like the folder icons are not cached and they eventually return to mine.
     
  6. MrAPT1

    OP MrAPT1 Member
    Newcomer

    Joined:
    Dec 28, 2012
    Messages:
    11
    Country:
    United States
    Sorry for the late reply, but anyways...

    So this is something that happens to everyone every so often and it eventually fixes itself?
     
  7. kuwanger

    kuwanger GBAtemp Advanced Maniac
    Member

    Joined:
    Jul 26, 2006
    Messages:
    1,510
    Country:
    United States
    AFAIK, this is just a defect in the file manager display. That is, every folder (include . and ..) that scroll off the screen pressing up/down will come back on with a blank icon and a 0 size. Meanwhile, pressing left/right will cause the whole screen to refresh and it'll show the proper icon/no size. So, yeah, more or less what FAST6191 was saying. The funny bit is the code does an almost proper line grab/line redraw--if you have the right sort of background, you'll notice that wherever the selection bar is when it goes back to unselected, the area is off by a pixel height. I had thought about trying to fix all of the above, but I never got around to it since at that point it'd basically be easier to rewrite the whole thing and I hadn't been willing to put in the effort. :)
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Directories, Flash,