EZ Flash IV 1.77 white screen on SSF2TR

Discussion in 'GBA - Flashing Hardware and Software' started by rs1n, Aug 24, 2016.

  1. rs1n
    OP

    rs1n Advanced Member

    Newcomer
    81
    20
    Jul 26, 2013
    United States
    Hi,

    I recently updated my EZF4 to firmware 1.77. As some others had already noticed, it no longer recognized my miniSD card. So I changed to using a microSD (Kingston 16GB, class 4) card. I basically copied everything from the miniSD card over to the microSD card. Everything works fine on the microSD card, except for one of my games: Super Street Fighter 2 Turbo Revival. This game was working fine on the miniSD card, even with the Akuma bugfix patched into the ROM. Now, however, I get a blank screen when loading from the microSD card. Oddly, if I copy it into NOR, then it runs fine. (The ROM without the Akuma patch exhibits the same issue, by the way.) All my other ROMs seem to work just fine reading from the microSD card.

    I am curious if anyone has run into this issue, or if they help me deduce whether I have a defective microSD card (does anyone with the newer microSD EZF4 card have this issue with this specific ROM)? Is it a firmware issue that causes problems with this specific ROM?

    Any help would be truly appreciated!
     
    Last edited by rs1n, Aug 24, 2016
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,865
    9,778
    Nov 21, 2005
    United Kingdom
    What happens if you hold L and press A?
     
  3. rs1n
    OP

    rs1n Advanced Member

    Newcomer
    81
    20
    Jul 26, 2013
    United States
    Wow, thank you for the quick reply -- it worked. With the ROM selected, I held L and pressed A and it loaded just fine. Can you give me a bit of detail in what is/was going on? I have been out of the loop for about 2 years now I think.
     
  4. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,865
    9,778
    Nov 21, 2005
    United Kingdom
    Sorry, meant to there but got called away.

    If you were using an old firmware it was likely the modulo RESET loader as that was what we pushed for years and years. It does a hard reset before the game loads, mainly to work around a bug with DS mode but still does it on GBA. When the EZTeam decided to start updating loaders again it went back to soft reset because they seem to go for that these days (it varied on different loaders for different carts). L and A is the combo to force a hard reset to launch.
    Kuwanger did make a mod for a few of the newer versions to hard reset again if it is going to be an issue for you but if you are happy enough to do it for this game, and there are others that prefer soft reset as it is slightly quicker. I have not got the threads bookmarked but they will not be hard to find.
     
    pponto likes this.
  5. Gyron

    Gyron GBAtemp Regular

    Member
    280
    89
    Dec 10, 2014
    pponto likes this.
  6. rs1n
    OP

    rs1n Advanced Member

    Newcomer
    81
    20
    Jul 26, 2013
    United States
    Thank you both (FAST and Gyron) for your replies. I think I'll stick with my Clearlooks 1.77 for now until someone updates it to have that feature built-in like Flat and Bluenight.
     
  7. Localhorst86

    Localhorst86 GBAtemp Advanced Fan

    Member
    950
    486
    Jul 17, 2014
    Germany
    My Nintendo works for Dad
    This IPS should patch any 1.76 and 1.77 kernel firmware to use the hard reset. Warranty not included.
     

    Attached Files:

  8. rs1n
    OP

    rs1n Advanced Member

    Newcomer
    81
    20
    Jul 26, 2013
    United States
    I'll give it a whirl this weekend. Any particular IPS patcher recommended?
     
  9. Localhorst86

    Localhorst86 GBAtemp Advanced Fan

    Member
    950
    486
    Jul 17, 2014
    Germany
    My Nintendo works for Dad
    Any should do. I use lunar ips myself

    Gesendet von meinem UMI_SUPER mit Tapatalk
     
  10. rs1n
    OP

    rs1n Advanced Member

    Newcomer
    81
    20
    Jul 26, 2013
    United States
    So I finally had a chance to find my misplaced SD card adapters. The patch worked (I like lunar ips as well) insofar as patching the firmware is concerned. However, attempts to update the firmware only got me a black screen (it didn't even get as far as showing the text normally seen during firmware updates).
     
  11. Localhorst86

    Localhorst86 GBAtemp Advanced Fan

    Member
    950
    486
    Jul 17, 2014
    Germany
    My Nintendo works for Dad
    Try a different SD card. The bootloader that updates the firmware is a lot pickier.

    Gesendet von meinem UMI_SUPER mit Tapatalk