EZ-Flash 4 problem

Discussion in 'GBA - Flashing Hardware and Software' started by mlooty, Aug 11, 2013.

  1. mlooty
    OP

    mlooty Member

    Newcomer
    13
    0
    May 19, 2006
    I'm not sure if i am posting in the right place but i seem to have a problem with the ez flash 4 cart and i was wondering if there is any fix or suggestions that can help me with this.

    I got a ez flash 4.everything loads up the menu normally but when i choose a game and load it. it boots up to the gba splash screen and it stays stuck on the screen
    I have tried other roms Where it load the rom showing the file loading % and boots to the gba splash screen it doesn't go past it. there is no nintendo logo on the bottom. It seems to be happening to all roms i tried.

    I have patched the roms using the ez client and i am also using a Mini SD card as well. Also i can also flash the software ezflash_up.bin file by pressing the R button on bootup. So everything seems to be functioning except loading roms.

    Does anyone know a way to fix this or is my cart is faulty?

    Thanks
     
  2. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,436
    4,751
    Mar 17, 2010
    Norway
    Alola
    Does anything show instead of the Nintendo logo? E.g. a garbled mess.
    Try fixing the header with GBATA (the option is under Header Viewer): http://filetrip.net/gba-downloads/tools-utilities/download-gbata-gba-tool-advance-07a-f223.html
    That will restore the logo which should under normal circumstances enable homebrew to boot which would otherwise get stuck on the splash screen. However it shouldn't be needed for retail games, as they normally have the correct header. It's worth a try though.
     
  3. mlooty
    OP

    mlooty Member

    Newcomer
    13
    0
    May 19, 2006
    Nothing shows under the gameboy logo it is totally clear.

    Its just the same splash screen for e.g where there is no game inserted in the slot that's what i see.
     
  4. mkmalls19
    This message by mkmalls19 has been removed from public view by tj_cool, Aug 11, 2013.
    Aug 11, 2013
  5. Nusdogg

    Nusdogg GBAtemp Fan

    Member
    369
    45
    Feb 3, 2013
    United States
    St. Paul, MN
    Does it work with actual game cartridge?
     
  6. macmanhigh

    macmanhigh THC = Truly High Caliber

    Banned
    699
    112
    Mar 29, 2012
    United States
    BuddsVille,CA
    Maybe try Formating the SD card before patching roms to it........if not try different Micro card
     
  7. Auyx

    Auyx GBAtemp's Unofficial Sanic impersonator

    Member
    246
    26
    Jun 20, 2007
    Staffordshire
    If I remember correctly there are two kinds of firmware for the EZ IV one of witch resets the device before the game starts and one which does not. Try flashing an older firmware that does not reset and see if that lets the roms boot.
     
  8. mlooty
    OP

    mlooty Member

    Newcomer
    13
    0
    May 19, 2006
    Yes the games all work and there is nothing wrong with it.

    I will retry that again it and since i don't have a spare mini SD i will try it with the mirco to mini adapter.

    Ok i will try it.
     
  9. Count Duckula

    Count Duckula .

    Member
    615
    150
    Aug 17, 2008
    -Does the game load if you flash it to NOR (press select instead of A to choose the ROM, then A to confirm)?
    -Definitely try another SD card, you could try formatting the card with the Panasonic formatter also: http://panasonic.jp/support/global/cs/sd/download/
    -You could try another firmware like Auyx said, personally I use this one (it is the reset version of the latest fw) and know many others do: http://ezflash.sosuke.com/viewtopic.php?f=13&t=17257
    -I've had the GBA get stuck on the splash screen before the ez-flash menu loads, but just re-seating the cart in the GBA fixes that. Likely not relevant if you get past the menu
     
  10. mlooty
    OP

    mlooty Member

    Newcomer
    13
    0
    May 19, 2006
    -Does the game load if you flash it to NOR (press select instead of A to choose the ROM, then A to confirm)?


    I have tried to flash it to NoR
    which shows the erasing and shows the writing in MB.
    so when it finishes writing in NOR does it meant create a another file inside the system? As i do not see it in the file browser. I don't think that the game has written to NOR

    I have formatted my mini sd card with the Panasonic formatter.I did a full format

    I have also used a micro-mini sd adapter formatted to FAT as well

    I have patched the roms with the ez client and have used an older firmware and the problem is that when the rom is loaded 100% it goes straight to a white screen.

    I am able to upgrade the firmare but the error is the same splash screen on the latest firmware.

    Both of the cards seems to suffer the same problems.

    I am now experiencing problems in the file browser when i try to open the saver folder it gives an error "[Sector:3F e13a] data :O".

    Would these signs now prove that my ez flash 4 is actually defective?
     
  11. Count Duckula

    Count Duckula .

    Member
    615
    150
    Aug 17, 2008
    After the game is flashed to NOR, it should be listed in the file browser at the top level (eg as soon as you open the file browser, where you select 'SD Card' to see all the ROMs on the miniSD).

    The error when entering the saver folder is odd, as that is stored on the miniSD not the internal NOR/RAM.

    The symptoms you list certainly dont sound good, I'm no expert on failed carts so cant say for certain its failed hardware. Give it a bit and see if anyone who knows more can offer any suggestions I guess, otherwise try for a refund/replacement.
    2 units both dead would seem unlikely, where did you buy them from?

    May be of some use: http://ezflash.sosuke.com/viewtopic.php?f=12&t=15234
     
  12. mlooty
    OP

    mlooty Member

    Newcomer
    13
    0
    May 19, 2006
    The game doesn't flash to NOR i have tried flashing the game and still there isn't listed in the file browser

    I got the ez flash 4 from a friend who ordered it last month in mid-july which was lucky to get which was received last week and given to me.
    so i'm not sure if a replacement is possible as it seems to be rare to get theses days. But i will tell him about it.

    I just feel very unlucky that this problem seems very unique compared to other people's problems on their EZ Flash 4.
    maybe it could be a failed hardware since I'm not knowledgeable in that field.

    anyone have any ideas?