ROM Hack ExeFSNameError after patching a 3ds rom

NatzAshe

New Member
Newbie
Joined
Aug 28, 2014
Messages
4
Trophies
0
Age
30
XP
24
Country
The game in discussion is Super Robot Wars UX, and I got 10 patch files(.xdelta) targeting code.bin from Exefs and 9 other binaries from Romfs.

I extracted the folder and binaries from the original cia with Hackingtoolkit9ds(version12), and patched the binaries, and rebuilt the cia file with Hackingtoolkit3ds(version9), because there was a bug with version12 related to Visual Studio.

As a result, the resulting cia was installed and ran perfectly with Citra emulator on pc, but when I tried to install it to my actual 3ds with FBI, it resulted in an "Invalid argument" error, specifically result code 0xD8E08025, Permanent level, Invalid NCCH.

And I tried to check if the FBI was malfunctioning, and tried custom-install(installs cia to 3ds sdcards) to see if my pc could install the modded cia.
But it wasn't functioning either, and resulted in an error message stating -> Exception occurred: ExeFSNameError: could not decode from ascii: b'\xc7\xfav\xdf\xffQ\x19J'

The original cia file was dumped from my 3ds, and the unmodded cia dump could be reinstalled back to my 3ds, so it probably wasn't a corrupt dump.

Is there a method to unpack a cia, mod the file, and rebuild it so that it can be installed back into my 3ds machine? Or is there a method to dump a functional cia installation from my pc to my 3ds machine?
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Sonic Angel Knight @ Sonic Angel Knight: Hey, where the admins at? Come in the chat. I got a idea. How bout a Sound notification or...