Error starting FBI from the homebrewlauncher (and some n3ds rxTools bugs?)

Discussion in '3DS - Homebrew Development and Emulators' started by Dylan the Tactician, May 9, 2016.

?

Have you ever even seen/heard of this error?

  1. Yes

    36.4%
  2. No

    63.6%
  1. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    While attempting to use the homebrewlauncher version of FBI on a New 3ds, I encountered an issue that seems to not exist on the rest of the internet. Here's my google search to "prove" it.
    Google Search

    My Error is as follows:
    "Fbi has encountered a fatal error!"
    "Failed to set syscore CPU time limit: D8E05BF4"
    "Press any button to exit."

    I've gotten this error on vanilla sysnand (Menuhax->CTRBootManager->HBMenu->FBI)
    and on rxtools pasta sysnand (Menuhax->CTRBootManager->rxTools(version, currently 3.0beta2)->Pasta->Menuhax->CTRBootManager->HBMenu->FBI)

    I'm trying to get to FBI so I can install some GBA cia's on sysnand so they run on the reinand rednand that's setup. The reason I don't try to install FBI over sysnand health&safety is that when I try to, I get the errors "Opening SercureInfo_A... Failed!" and "Opening SecureInfo_B... Failed!", and it doesn't give me the option to install it. Yes, I'm aware this was "fixed" with this or that rxTools version. I've tried 4 different versions of rxTools (2 nightlies, official 3.0, beta 3.0) and get the same errors each time.
    Also, blackscreen when I try to run FBI through rxmode sysnand.

    SOMEONE PLEASE HELP ME IT'S DARK AND SCARY AND I'M ALONE IN THIS APPARENTLY UNIQUE ERROR
     
    Last edited by Dylan the Tactician, May 9, 2016


  2. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,656
    720
    Aug 22, 2015
    United States
    Hell
    Use a different cfw, rxTools is the worst cfw rn. Also, try injecting FBI into h&s with decrypt9. Theres a guide somewhere on here for making your own (search universal inject master and you can probably find it)
     
    hobbledehoy899 likes this.
  3. Quantumcat

    Quantumcat Dead and alive

    Member
    10,425
    5,500
    Nov 23, 2014
    Australia
    Canberra, Australia
    You could solve this by setting up arm9loaderhax with updated sysNAND. You only have to install GBA cias once and the patches are inbuilt into Luma CFW. You'll have a lot of trouble getting help for rxTools as it's outdated now. For the a9lh guide, search google for plailect a9lh guide (it's a GitHub page).
     
    Xenosaiga and ih8ih8sn0w like this.
  4. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    I have that and it's already setup, but I don't think that can inject to sysnand. If I'm wrong please by all means correct me
    [edit1]
    OK YOU WERE RIGHT
    I check decrypt9 again, and realized: maybe it would help to select "sysnand settings" when I want to inject it into sysnand"
    I'm doing this on a friend's 3ds and therefore don't feel like messing with a9lh. The only reason I use rxTools is dumping certain things, injecting FBI, and running Pasta to install gba cia's. This was mostly for the FBI issue, actually.
     
    Last edited by Dylan the Tactician, May 9, 2016
  5. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    nothing on what might've caused the FBI issue?
     
  6. Link0

    Link0 Member

    Newcomer
    22
    5
    Sep 17, 2009
    Netherlands
    You're not alone anymore at least! i've just encountered it myself.

    For me it happens on an o3DS running Luma, so it's definitely not something related to rxTools.
    I'll try injecting it tomorrow with Decrypt9 and then we'll see what happens. Maybe an older version of FBI might also solve it, considering how recent your post is.

    I'll let you know if i get anywhere.
     
  7. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    Maybe.
    Hey, can you upload a screenshot? I wasn't able to because of the fact that it was a time based thing (I don't have that 3ds on me anymore), and I think people need to see what it LOOKS like.
     
  8. Link0

    Link0 Member

    Newcomer
    22
    5
    Sep 17, 2009
    Netherlands
    I'm doing this remotely too, so no i can't.
    I did however solve it by putting FBI on the SD card again, so i guess it's a corruption bug of some sort. I checked the hashes of the zip files, which were identical, so maybe something went off during the copying to the SD card

    Or to be more precise, we first went down to older versions which worked, and then the latest one started working.
     
  9. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    (Actually I never got it working, I ended up injecting it into H&S and it worked there)
     
  10. opmas

    opmas GBAtemp Regular

    Member
    124
    7
    Jan 9, 2016
    This is what I am encountering now. Using O3ds and this is the only thing I know how to install fbi. Any workaround?
     
  11. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    NO ONE RESPONDED TO THIS WITH AN ACTUAL ANSWER WHEN I POSTED THIS
    OK I WAS THE FIRST ONE TO HAVE IT AND NOW OTHER PEOPLE ARE HAVING IT POP UP

    SOMEONE HELP

    @Steveice10
    I BELIEVE IN YOU
     
  12. opmas

    opmas GBAtemp Regular

    Member
    124
    7
    Jan 9, 2016
    I tried to download the fbi 2.1.1 and it is still the same. I dont wanna go through the injecting part to H & S
     
  13. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,656
    720
    Aug 22, 2015
    United States
    Hell
    What have you tried so far? And what are you trying to install (just a name that I can search on that iso site will be enough)
     
  14. opmas

    opmas GBAtemp Regular

    Member
    124
    7
    Jan 9, 2016
    Just downgraded my 03ds from 9.5 to 9.2. Im now in the process of setting up emunand. I loaded the pastacfw which ran fine it goes back to Home menu. then go back to HBL to launch FBI, but that is what I am getting. Failed to set syscore cpu time. I tried to replace the fbi 2.2.0 with the previous version and still the same thing
     
  15. opmas

    opmas GBAtemp Regular

    Member
    124
    7
    Jan 9, 2016
    Anyone who encountered this? I tried different sd card and does the same.
     
  16. opmas

    opmas GBAtemp Regular

    Member
    124
    7
    Jan 9, 2016
    Found a solution. Just install the lower version specifically FBI 1.4.17
     
  17. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    it showed that error directly after boot. No menu was loaded, just straight to error.
    It was that version.
     
  18. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,656
    720
    Aug 22, 2015
    United States
    Hell
    What *hax version are you using? (it should say it at the top of the rainbow screen next to debug)
     
  19. Dylan the Tactician
    OP

    Dylan the Tactician GBAtemp Regular

    Member
    256
    72
    Jan 12, 2016
    United States
    Denied
    Don't remember. I don't have access to the 3ds anymore, and I never got the chance to take a picture.

    Damn.

    I think it was 2.1 though.
     
  20. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,656
    720
    Aug 22, 2015
    United States
    Hell
    That is probably why... FBI (afaik) currently is built for 2.5 (or whatever it is). I don't know the details, but I'm pretty sure smea expanded the available memory between 2.1 and current. Someone more reliable can probably correct me though. Just use 1.4.xx if you are going to continue to use 2.1