"ERROR! ret -1029" Little help?

Discussion in 'Wii - Hacking' started by Dork, Apr 3, 2011.

  1. Dork
    OP

    Dork Newbie

    Hello, I am currently ripping my hair out when trying to install a certain WAD. I have Wii firmware 3.2U, cIOSrev21 using IOS249 as a base, and have Hermes cIOS222v5 installed.
    The wad I am trying to install was created off CustomizeMii, the base wad is the USB Loader GX forwarder, I also tried the channel. I create the wad without any problems, but when I try to install
    it, I get the infamous "ret -1029" error. Every other WAD I try works but this one. I tried installing different cIOSrevs, different WAD Managers, no luck.

    I would like to post the wad I am trying to install, but it is against the rules, but I could post the boot.dol I am trying to inject if necessary.

    EDIT: I am aware of what the error means, but I don't know how to fix it

    I also found this written by Waninkoko on twitter:

    "Getting -1029 error? Fix your WAD! Byte 0x1F1 of the ticket should be 0x00 (or 0x01 if using the Korean common key). "

    I have no idea how to change the byte either. [​IMG]
     
  2. lulwut

    lulwut GBAtemp Fan

    Member
    331
    0
    Mar 19, 2010
  3. wiimanofthenorth

    wiimanofthenorth GBAtemp Regular

    Member
    286
    23
    Jan 18, 2011
    Select a different IOS to use for install... 36 for example.
     
  4. Dork
    OP

    Dork Newbie

  5. Dork
    OP

    Dork Newbie

    Tried that, then I started getting "ret -2011" or "ret -1022"
     
  6. brausm08

    brausm08 GBAtemp Advanced Fan

    Member
    721
    17
    Nov 15, 2009
    United States
    USA - Midwest
    it's just a USB Loader GX forwarder you're trying to install??? if it truly is a .wad problem...why not just find a different one...there's only about 10,000 of them out there....
     
  7. drewmerc

    drewmerc GBAtemp Regular

    Member
    137
    1
    Mar 20, 2007
    multi mod manager use it to patch ios36 and then use it to install the wad
     
  8. Dork
    OP

    Dork Newbie

    Nope, just gave me a "ret -1022" when trying to install.
     
  9. M1r0

    M1r0 GBAtemp Fan

    Member
    354
    0
    Jun 25, 2010
    United States
    Isn't ret -1002 the unfixable error of death? I saw that in another topic where some else go the error, and Mauifrog posted it.
     
  10. techboy

    techboy GBAtemp Advanced Maniac

    Member
    1,720
    21
    Mar 15, 2009
    United States
    Pennsylvania
    That's -1012 and -1024.

    -1022 is a content hash issue. It's a common error for poorly-made warez releases that haven't been re-signed, but since this wad came out of CustomizeMii, it's probably corrupt. CustomizeMii wads typically shouldn't have this issue.

    Get/make another wad.
     
  11. mauifrog

    mauifrog DA KINE WiiHacker

    Member
    1,585
    90
    Jan 21, 2010
    United States
    No ret 1024 is the bad one, accompanied by a syscheck with no trucha bug on ios that are known to have the patch.

    1022/1029 means that the tmd of the wad is no good. Get another wad.
     
  12. M1r0

    M1r0 GBAtemp Fan

    Member
    354
    0
    Jun 25, 2010
    United States
    Thanks for clearing that up [​IMG]
     
  13. Dork
    OP

    Dork Newbie

    Alright, I tried another wad, this time I tried the Static base wad which came with CustomizeMii.
    Still didn't work. I am really becoming less patient over this as I have tried pretty much everything
    but nothing will install this wad, is there some kind of way I can install this wad manually?
     
  14. M1r0

    M1r0 GBAtemp Fan

    Member
    354
    0
    Jun 25, 2010
    United States
    Do nonedited wads work okay?

    Edit: As in not edited by you
     
  15. mauifrog

    mauifrog DA KINE WiiHacker

    Member
    1,585
    90
    Jan 21, 2010
    United States
    Perhaps more details on what your trying to do, what you have done, etc will help get you an answer.
     
  16. cobleman

    cobleman GBAtemp Maniac

    Member
    1,458
    19
    Jun 23, 2009
    Australia
  17. Dork
    OP

    Dork Newbie

    Yes, I could install a non-edited Static Base and USB Loader channel.
     
  18. Dork
    OP

    Dork Newbie

    Alright, this is what I am trying to do:

    I am trying to create a custom channel for a homebrew app I like to use a lot, so I took the boot.dol of this app and injected it into
    the USB Loader channel using CustomizeMii, I then edited the banner and icon properly. I create the WAD without any errors. I can install the un-edited USB Loader channel
    but when I try to install my custom channel, it gave me the "ret -1029" error. When I tried to install it on other base ios, I would get "ret -2011" or "ret 1022".
    So then I tried to inject the boot.dol into the Static Base wad given in CustomizeMii, I took the animations and layout from the USB Loader channel, added them to the
    static base, edited the banner and icon properly, created wad successfully, tried to install, didn't work.

    I have absolutely no idea why this is happening, and I am very frustrated.
     
  19. Dork
    OP

    Dork Newbie

  20. M1r0

    M1r0 GBAtemp Fan

    Member
    354
    0
    Jun 25, 2010
    United States
    [​IMG], What we've been saying the whole time...