ermm what to do with a 2.1.0-4J ?

Discussion in '3DS - Console, Accessories and Hardware' started by Arkansaw, May 6, 2015.

  1. Arkansaw
    OP

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
    I thought play-asia was trying to clear stock, but didn't expect them to send me this :blink:
     
  2. iCEQB

    iCEQB GBAtemp Advanced Fan

    Member
    674
    446
    Nov 2, 2013
    United States
    Well, the most convinient FW imo is the 4.5.0 which you can update it to with a game card.
    But of course if you feel funny, you can update to any exploitable FW, which range from 4.5.0 to 9.2.0.
    Or if you don't want the hassle you can also go straight to the latest one (9.7.0) and "enjoy" your games via a Sky3DS flashcard.
    Smea also released a region free loader for the latest FW in conjunction with Cubic Ninja.

    Or if you feel realy funny you can do a hardmod and update to every single FW while also backing them all up, in the hopes that there might a bootloader exploit one day for a lower FW to which you could then downgrade to.

    I don't know if downgrading is also possible with a software exploit, but afaik it should be, GW is also doing that.
     
    Arkansaw likes this.
  3. Arkansaw
    OP

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
    I was lucky in the sense I bought it with a JP cart...so I *should* be able to update to a safe version and downgrade again
    too bad I can't keep the original firmware..since no hard mod
     
  4. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,815
    4,570
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    update to 4.0~4.5 using a real game (heres a list of games with firmware versions) http://3ds.essh.co/
    then you can gateway it.. keep in mind, you will need to get a japanese one...

    how about the browser version? there was not a requirement about the browser being not such old one? for the ocarina\cubic xploit
     
  5. iCEQB

    iCEQB GBAtemp Advanced Fan

    Member
    674
    446
    Nov 2, 2013
    United States
    He would need to to talk to a dev about it. Technically yes, but afaik nobody ever made a working ROP chain for versions which are that low.
    Rxtools afaik is working with FWs around the 2.x.x range (at least the rxtools thread title states this?)
     
  6. Arkansaw
    OP

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
    I read somewhere that units ending with .0 don't even have a browser so those would require a 4.x cart

    I will just take a deep breath and update to 8.x by cart...
     
  7. iCEQB

    iCEQB GBAtemp Advanced Fan

    Member
    674
    446
    Nov 2, 2013
    United States
    from there you should be able to downgrade to 4.5.0 (if you want of course)
     
  8. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    760
    185
    Mar 28, 2011
    United States
    Updating to 8 is an unnecessary risk--the risk that the browser exploit won't work for you because nobody knows exactly what versions it works for and yours may be too old. Just update it to 4.x and use the profile exploit.

    That being said, if you update it to 8, be sure to tell us how it goes. If you update it to 8 and can't get it to work, your only option may be to use a non-Gateway CFW, and install a .cia of an 8.x browser. But I don't know if there actually is a non-Gateway CFW that does that and will work on -4J.
     
  9. Arkansaw
    OP

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
    I only have the one imported game which I knew could be useful for this purpose, but it is not a 4.x since I didn't import the game for that specifically...and unlikely to get more JP carts

    so upgraded and browser exploit is working...so it should be fine once I get the downgrade pack. too bad I can't hold on to the "antique" fw
     
  10. iCEQB

    iCEQB GBAtemp Advanced Fan

    Member
    674
    446
    Nov 2, 2013
    United States
    Well, I don't know if those old FW versions are still on the NUS, but if they are it shouldn't be a problem to get back to them.
    The gateway team doesn't downgrade via CIAs, they use their own format, which is missing a few things, like correct NDS whitelist version from the lower FW (that's why a few peeps had problems with their blue card after downgrading).
    Would be cool if someone would write a down-/upgrader which can also up-/downgrade emuNAND.
     
  11. mid-kid

    mid-kid GBAtemp spamBOT

    Member
    879
    962
    Aug 2, 2012
    Here you can find all firmware versions we know exist on the NUS: http://yls8.mtheall.com/ninupdates/reports.php
    Too bad I won't be able to return to 1.0, my broken console's original FW version. :P
     
  12. Arkansaw
    OP

    Arkansaw GBAtemp Advanced Fan

    Member
    993
    194
    Jul 23, 2005
    Trinidad and Tobago
  13. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    760
    185
    Mar 28, 2011
    United States
    If it was missing a correct whitelist version, wouldn't that mean everyone would have problems with the blue card after downgrading?
     
  14. iCEQB

    iCEQB GBAtemp Advanced Fan

    Member
    674
    446
    Nov 2, 2013
    United States
    Afaik that's pretty much what happened. Maybe it was region dependent?
    Or more likely the whitelist was never touched during the downgrade, so people that came from FW 6.x never had that issue, because the blue card still worked on that FW.
    But I'm pretty sure that 9.x downgraders had their problems after the procedure, which is why they threw the timwarp.cia thingy in there as well after downgrading.