Edit: It is safe to update to 6.2 using atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Kubas_inko, Nov 20, 2018.

  1. Shadow147

    Shadow147 Member

    Newcomer
    1
    Oct 1, 2018
    China
    Yeah that won't work though because you have to boot stock firmware to use the save transfer programme which will then burn fuses anyway, so I might as well just update normally, no?
     
  2. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    No you don't

    — Posts automatically merged - Please don't double post! —

    Same way you would hack any other firmware, but with the newest version of Atmosphere
     
  3. Shadow147

    Shadow147 Member

    Newcomer
    1
    Oct 1, 2018
    China
    Huh?? But the transfer thing is in System Settings > User > Transfer Your User and Save Data-- is there another way to transfer saves from an unmodded console that I don't know about? Because to get to that menu you are already in the stock firmware...
     
  4. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    CFW doesn’t change anything in the settings (it doesn’t even much of the OS at all)
     
    Last edited by ZachyCatGames, Dec 4, 2018
  5. Shadow147

    Shadow147 Member

    Newcomer
    1
    Oct 1, 2018
    China
    Ohhhhh so the CFW encompasses everything you see from when you boot the system, including system settings and all that? I was thinking it was just the stuff in the Album tab... If not, I'm stupid.

    So as long as I used choidujour to install the update and set it to AutoRCM, I could go into the settings, use the save transfer tool, and I still wouldn't burn any fuses?

    The tool does require wifi as well so I guess that is kind of a ban risk?
     
  6. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    Yup, also anything that can be done without CFW can be done with CFW

    If you use atmosphere and don’t do anything until after transferring the saves you should be fine
     
  7. Shadow147

    Shadow147 Member

    Newcomer
    1
    Oct 1, 2018
    China
    So I upgraded via choidujournx (such a great programme!) and everything seems to be running fine, however I'm getting error code 2137-8007 when I try to start the save transfer tool on my CFW switch, even though my unmodded system has no problems, and is on the exact same network with exactly the same settings.

    The internet barely has any info on this error code... Any ideas?

    EDIT:

    Scratch all that-- I had gotten a notification for a controller update which I previously cancelled because I cancel all updates out of instinct now, but then realised it was probably the controller update that came with the 6.2.0 package I just installed via choidujournx, so I installed it.

    Now it's telling me there's a system update, and in the system settings 'system' tab, it just says "system update ready" under system update.

    I don't really understand how that's possible, as beforehand it was showing 6.2.0 as the firmware, and I've been in CFW the whole time...

    Do I need to update it from system settings as well after installing via choidujournx?? That seems sketchy...
     
    Last edited by Shadow147, Dec 5, 2018
  8. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    I have no idda how you got an update nag on 6.2.0 (unless N released an update or something). But you should be able to get rid of it by starting your system in maintenance mode, you can probably get it to load by holding vol up and down after launching the fusee payload
     
  9. Shadow147

    Shadow147 Member

    Newcomer
    1
    Oct 1, 2018
    China
    I know right?

    Will try tomorrow and let you know!
     
  10. Doboulgyser

    Doboulgyser Newbie

    Newcomer
    1
    Dec 6, 2018
    Germany
    Sry i have a noob question.

    When i did understand everything right then i should do as follows:

    1. I use my Switch FW 3.0.0 with Serial XAJ1... got a old bundle on Black Friday :) to make a Nandbackup
    2. Then I use choidujour or Nintendo Update Service to update to 6.2.0
    3. I can then download from eshop my bundle game
    4. Then i can mod it with the methods from reddit by using fusee jelee hekate and atmosphere

    is that right? ofcourse i after that never go online again

    Sry for my bad english its not my native language
     
    Last edited by Doboulgyser, Dec 6, 2018
  11. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    That should work :P

    Use ChoiDujourNX to update, because if you use Nintendo's update thing you won't ever be able to downgrade back to 3.0.0 in the future
     
    BIGdoubleD and Doboulgyser like this.
  12. Doboulgyser

    Doboulgyser Newbie

    Newcomer
    1
    Dec 6, 2018
    Germany
    very much thanck you i will do exactly that.
     
    ZachyCatGames likes this.
  13. Shadow147

    Shadow147 Member

    Newcomer
    1
    Oct 1, 2018
    China
    Okay so the first time I tried booting into maintenance mode from hekate, I got some error about key derivation being failed? So then I rebooted and tried it again and it just booted into CFW normally.

    There is no option in hekate to boot into maintenance mode, and the normal method doesn't work, as I'm in autoRCM in order to preserve my fuses.

    Any ideas?

    EDIT:
    Sorry for the back and forth-- So after some research, I realised that when I was booting after having installed 6.2.0 via choidujournx, I didn't have the 'PreventGCUpdate' option anywhere, so this has likely done something shit...
     
    Last edited by Shadow147, Dec 6, 2018
  14. firephoenixdxd

    firephoenixdxd Member

    Newcomer
    1
    Mar 21, 2018
    Austria
    in front of my pc
    is 6.1.0 safe? accidentally updated
     
  15. Doboulgyser

    Doboulgyser Newbie

    Newcomer
    1
    Dec 6, 2018
    Germany
    Yes 6.1.0 is safe.
    also is 6.2.0 with a bit work.

    I did as i said I updated with choidujournx to 6.2.0 to grab my bundle download game.
    Choidujournx activated the auto rcm.
    But now the only boot option that works for me is fusee cfw 6.2.0. athmospher 0.8.1
    i cant boot into stock and i do not have the PreventGCUpdate option.
    also sometimes i get the same error about key derivation being failed
     
    Last edited by Doboulgyser, Dec 7, 2018
  16. NRamos

    NRamos Member

    Newcomer
    2
    Aug 12, 2018
    Puerto Rico
    Is there any updates regarding for those that use SX OS CFW? Do we still need to wait for TX to give us an official announcement to be able to use SX OS CFW in 6.2.0?
     
  17. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    I’ve been trying to find a way to get into maintenance mode with Fusée/Hekate, when/if I find a way I’ll tell you :)

    PreventGCUpdate just disables the cartridge slot so that it doesn’t get updated, only thing you would have lost by not enabling it is being able to use gamecards on while on 3.0.2 and below
     
  18. Shadow147

    Shadow147 Member

    Newcomer
    1
    Oct 1, 2018
    China
    Thank you, ma dude!!

    I got this interesting, if a little passive-aggressive reply in another thread:

    "This reads like Rudy Giuliani talking about the cyber.

    The first time you booted into any firmware >= 4.0.0, without any NOGC patches, your gamecard slot was updated.
    The method described in the first posting to get nogc patches up and working is defunct - at least as far as running atmosphere is concerned.

    Atmosphere 0.8.1 should have automatically applied nogc patches to safe your ass - seems like you didn't use the most current version.

    Other than that you could have doubled down and used these nogc patches as well: https://gbatemp.net/threads/i-heard-that-you-guys-need-some-sweet-patches-for-atmosphere.521164/

    Both of those methods work (even in combination) - and you should have gotten a "your gc slot doesnt respond, please reboot or contact nintendo" message on boot. If you didn't your gamecard slot firmware is updated. No way to downgrade.

    What you "should do now" is up to you - "what is best firmware to have" is a silly game to play - that gets old after the first time (you are not the first one trying to play it though - so have solace in that).

    You are getting the update nags, because you went online with your system. Having a ban deathwish or something. Asking for the yes please give me update nags, all the time Nintendo treatment. The intelligent persons approach would have been to use 90DNS (https://gbatemp.net/threads/90dns-dns-server-for-blocking-all-nintendo-servers.516234/) even before installing a CFW - so Nintendo gets blacked out in everything you do online. (No online play either. No "easy" game updates. Thats the tradeoff, with Atmosphere - at least currently. (No emunand))

    edit: Didn't step far enough into Rudy Guliani thought process mode.

    5 Fuses burned means firmware 4.0.0-4.1.0 to begin with. So this guy didnt ever need to prevent the Gamecard slot update, because he always had it.
    See: https://switchbrew.org/wiki/Fuses

    But hey - I also often start talking about stuff I have no Idea about what it means... Not.

    Atmosphere 0.8.1 didnt apply the NOGC patch in his case - because he already had the update on the system (4.0.0+). Most likely."

    Not sure what he means about already having the gamecart update, but yeah. Maybe this update nag is just the gamecart update then? That might also be too big a risk to take though.
     
  19. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    The nag doesn’t have anything to do with the cart update, the cart update is automatically done without telling you
     
  20. doobiedoobiedoo

    doobiedoobiedoo Newbie

    Newcomer
    1
    Jul 6, 2018
    United States
    is most homebrew apps compatible with 6.2 now? Anyone have problems with specifically the old tinfoil and usb install?
     
Loading...