DVD Drive Won't Eject

Discussion in 'Wii - Hardware, Devices and Utilities' started by Pharrox, May 6, 2008.

  1. Pharrox
    OP

    Pharrox Member

    Newcomer
    2
    Mar 4, 2007
    United States
    I have a modded Wii with Wiinja Deluxe that has been working fine since I got it about a year ago. Today I went to switch games, but when I inserted the new one it took it but made a very wierd grinding sound. I immediately tried to eject it but all it did was make the grinding sound again and wouldn't eject the disk. When I went to play it, the game worked fine, however. I have a replacement case, so I can see the DVD drive. From what it sounds and looks like to me, when I hit the eject button it tries to eject the disk but the magnet won't release it. It was working fine a couple hours ago and hadn't been touched since. I think it happened once before, but after hitting eject a few imes it eventually came out.

    Any suggestions as to what could be causing this or how to fix it? I think I might try to take the Wii apart to see if I can get it to eject by lifting the magnet.



    Thanks.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice