DSx86 v0.15

Discussion in 'GBAtemp & Scene News' started by Another World, Jun 20, 2010.

Jun 20, 2010

DSx86 v0.15 by Another World at 10:15 AM (2,103 Views / 0 Likes) 9 replies

  1. Another World
    OP

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    DSx86 v0.15
    Update
    [​IMG]

    DSx86, the Intel 80286 EMU for the DS, has received an update. See the release notes for more information[/p]

    [​IMG] Off-site Download
    [​IMG] Source
    [​IMG] Homepage
    [​IMG] Compatibility Wiki
    [​IMG] Discuss
     
  2. Disco

    Member Disco GBAtemp Fan

    Joined:
    Nov 10, 2006
    Messages:
    374
    Location:
    Croatia
    Country:
    Croatia
    On wiki it says that blake stone: aliens of gold works perfectly but it isn't.
    I tried with version 0.14 and it gives me some 386 error when the game tries to enter the menu, and with version 0.15 it goes all the way to the level loading and then gives the sam 386 error.
     
  3. Overman1977

    Member Overman1977 GBAtemp Regular

    Joined:
    Feb 22, 2009
    Messages:
    253
    Country:
    Canada
    Then go ahead and change the compatibility wiki.
     
  4. Disco

    Member Disco GBAtemp Fan

    Joined:
    Nov 10, 2006
    Messages:
    374
    Location:
    Croatia
    Country:
    Croatia
    I don't know how to do that, but it would be nice of you if you could do that for me [​IMG]
    Raptor: Call of shadows doesn't work either it gives the same error.
     
  5. Overman1977

    Member Overman1977 GBAtemp Regular

    Joined:
    Feb 22, 2009
    Messages:
    253
    Country:
    Canada
    ok, i can do that...give me what the problems are exactly and i'll update...you can do it tho by joining the site that hosts the wiki.

    if you have trouble let me know and just give me a list of the issues and games u are having probs with.
     
  6. Disco

    Member Disco GBAtemp Fan

    Joined:
    Nov 10, 2006
    Messages:
    374
    Location:
    Croatia
    Country:
    Croatia
    It says : ''386 opcodes not suported!''

    Same error for raptor and blake stone.
     
  7. Overman1977

    Member Overman1977 GBAtemp Regular

    Joined:
    Feb 22, 2009
    Messages:
    253
    Country:
    Canada
    I've tried out both of those games and I'm getting the same error...I'll be updating the wiki presently.
     
  8. Another World
    OP

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    are you both sure that game didn't have a 286 and a 386 version? because the dsx86 emu only supports 286 games.

    -another world
     
  9. nl255

    Member nl255 GBAtemp Advanced Maniac

    Joined:
    Apr 9, 2004
    Messages:
    1,998
    Country:
    Some games might include both the 286 and 386 version in the same executable and test if they are on a 386 by trying to use 386 opcodes. If the 386 opcodes fail, then the game knows it is on a 286. Hopefully DSx86 will get the option to ignore 386 opcodes (i.e. handle them the same way they would work on a real 8086/286) rather than crash to the debugger soon.
     
  10. Another World
    OP

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    there has already been added support for many of the 386 op-codes.

    -another world
     

Share This Page