DSTWO crashing and corrupting MicroSD cards

Discussion in 'Supercard' started by Issac, Feb 15, 2013.

Feb 15, 2013
  1. Issac
    OP

    Member Issac Mini-mod

    Joined:
    Apr 10, 2004
    Messages:
    4,454
    Location:
    Sweden
    Country:
    Sweden
    Hey hey!
    I bought a DSTWO (pre-ordered) from the shoptemp back when it was brand new, but I never got it to work. I bought it bundled with an 8GB MicroSD card, and whenever I went into the in-game menu (the DSTWO's in-game menu: for saves, cheats and that) it crashed/freezed. Then after rebooting, all the graphics were garbled and it wouldn't run any games.

    I figured it was all because of the MicroSD card, and never thought too much of it. I still had my M3 simply (or, Original R4 in another shell :P) and it always worked.

    Then after a while, I really wanted to leave the R4 world getting the DSTWO to work, so I used my old MicroSD card that I used with the R4, which never failed me... Bam, it got corrupted right away, same procedure.

    So, upon entering the DSTWO's in-game menu, the cart crashes and corrupts the MicroSD card.
    Is this something well known? Is my card faulty? Am I doing something wrong?

    (I've regularly updated the firmware, though not for a while now. I only use it in my DSLite. Tested several MicroSD cards.)

    EDIT:

    This guy here has similar problems, and he hasn't got any help besides "try a different microSD" from the official forum since 2011 :/ http://forum.supercard.sc/forum.php?mod=viewthread&tid=9216
     
  2. samurayjp

    Newcomer samurayjp Member

    Joined:
    Jul 3, 2008
    Messages:
    29
    Country:
    Brazil
    I am reseller DSTwo.
    I noticed this problem for some time.
    The problem is the USB adapter that comes with the DSTwo.
    The adapter PCB XC-RD-803 is one that has the problem.
    It is generally recognized in PC as FNK TECH 0100.
    Try another adapter that should solve the problem.

    I made a video showing what happens.


    Lately I get the adapters have different PCB and the problem was solved.
     
  3. Issac
    OP

    Member Issac Mini-mod

    Joined:
    Apr 10, 2004
    Messages:
    4,454
    Location:
    Sweden
    Country:
    Sweden
    I read something about the USB adapter being the fault. The problem I have with that theory is that I never even used that USB adapter, I've used a couple of other "multi card readers" that were bought in stores. And they never corrupted anything else.
    I can try to use another one of those and see if it was the card reader along with the DSTWO that didn't match well. (We buy a new one each time we buy a new Camera).

    I'll update once I've tried! :) Thank you for the reply!
     
  4. Firebug2009

    Newcomer Firebug2009 Member

    Joined:
    Jan 7, 2013
    Messages:
    15
    Country:
    Canada
    ive went through many micro cards and too many trips back and forth to the store trying to return them as faulty for different ones..they would all corrupt sooner or later...usually if i was transferring to much data at once...i use one of those SD sleeve things now..just put the micro in it, and then put that in my laptops built in card reader....i wont use those usb things anymore! it wasnt just the ones i got with my ds2's, but ones that came with my r4ids.cn cards as well, and even a 7in1 multireader i bought...they all suck


    EDIT: i just watched your video on full screen, and it was wierd to watch, i have the excat same sony viao lol, it was strange
     
  5. Issac
    OP

    Member Issac Mini-mod

    Joined:
    Apr 10, 2004
    Messages:
    4,454
    Location:
    Sweden
    Country:
    Sweden
    Yeah, I've used my laptop's built in card reader which provided me with the corruption, multireaders, and even tried the USB adapter that came with both the M3 Simply and the DSTWO..

    But now, I downloaded the latest firmware and EOS, and used the latest multireader we had. Just loaded one game, but i tried (quick-) saving and loading around 30 times, resetting, and everything. Everything works!

    So this is a solved issue now, it WAS the card readers!
     
  6. samurayjp

    Newcomer samurayjp Member

    Joined:
    Jul 3, 2008
    Messages:
    29
    Country:
    Brazil
    Well, I came to this conclusion after testing more than a hundred Dstwo USB adapters.
    (I have a box full of them here because I had to replace them with others before sending to customers).
    And the problem only occurred when using the adapters mentioned.

    With other adapters, the problem does not happen using the same microSD (after format and reinstall) and the same Flashcard.
    So I think the problem is not in the DSTwo but USB adapters.
     
    Nebuleon and Issac like this.
  7. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yeah, I make it a point to tell people not to use the readers that come with flash carts, even if they appear to be working fine.
     

Share This Page