DSTT file help needed please

Discussion in 'DSTT' started by boxo, Mar 31, 2008.

Mar 31, 2008

DSTT file help needed please by boxo at 12:13 PM (2,652 Views / 0 Likes) 9 replies

  1. boxo
    OP

    Newcomer boxo Newbie

    Joined:
    Mar 31, 2008
    Messages:
    6
    Country:
    United Kingdom
    Hi, hope you can help me!

    I've looked at the faq and a few other threads but i'm struggling and would appreciate it if you could take a look at my question.

    I've just got my 2nd DSTT card, the first one works perfectly and plays the roms i've loaded on to it. I got this new one so i could try them with a higher capacity memory card and the 4gb card works perfectly.

    so I know this 2gb memory card works and I know the new DSTT card works as i've tested both. I've got a rebadged ewin 2 in 1 expansion pack and an EZ3in1 pack as well.

    I want to do a little bit more with this new card, moonshell movies and internet browsing. I'm happy to do the work needed, i just require a bit of help finding it all.

    I've installed V1.09 of the menu as it's working fine on my other card.
    I've installed moonshell 171p1

    I've tried loading the opera browser from the menu and it tells me i need to have a ram pack installed - yet it's plugged in already and neither the ewin or the ez3in1 works when i try them, i get the same result. I obviously am missing some software - so what do i need to allow the expansion packs to work, where can i get it and where do i need to put it on the memory card?

    Thanks very much for looking, hope you can help.
     
  2. boxo
    OP

    Newcomer boxo Newbie

    Joined:
    Mar 31, 2008
    Messages:
    6
    Country:
    United Kingdom
    well i got both the cards working.

    the ezflash V needs GBA Exploader 051. when it's installed on your memory (in the games folder in the root) use the left/right shoulder buttons to navigate to the expansion menu. scroll down with the D pad to 'Expansion Ram' and press A to set the mode. it will do a soft restart, then you can select the browser rom and it will start and work perfectly.

    the TTDS GBA & Explore expansion cart (a rebadged ewin pack) needs to use GBALDR_v1_6. start it in the menu, then when it loads press both shoulder buttons at the same time. it asks if you wish to patch SDRAM for DS Browser, press A for yes. the menu restarts and you can select the browser which will work perfectly.

    You must go through this every time you turn on the DS as it doesn't appear to keep the selection in the memory of the pack. I don't know if setting it for DMA or soft reset will have any effect on this useability, I've not tried these options when using either expansion pack yet.
     
  3. Bri

    Member Bri GBAtemp Psycho!

    Joined:
    Dec 25, 2007
    Messages:
    3,413
    Country:
    United States
    The problem is that that the browser requires a memory expansion cart that is usually sold with the browser, so you have to "trick" the browser into recognizing a GBA expansion pack as memory. There are two solutions that allow you to use a GBA expansion pack as memory for the browser.

    First, there is a patch for the browser that will allow it to work with the eWin 2in1 that you can use. You can get the patch for the European version of the browser here. The patch is the most convenient solution (once you have the browser patched) because you can launch the browser directly without having to launch another program first, but I don't believe you'll be able to use the browser with your EZ 3in1 (only the eWin).

    The second solution would allow you to use the browser with both your eWin 2in1 or the EZ 3in1, but it requires you to run another program before running the browser. Simply install the latest version of GBA ExpLoader (it's a .nds file, so just put it anywhere you want on your microSD card). You will use GBA ExpLoader to "patch" the expansion pack so that it will be recognized as memory for the browser before running the browser. Get GBA ExpLoader here. The site is in Japanese, but just click on the link near the top of the page.

    BTW, you may still want to install GBA ExpLoader even if you patch your browser. GBA ExpLoader also allows you to play GBA games with either GBA expansion pack. It will show you a list of .gba files that are on your slot1 microSD cart and will load them onto the GBA expansion pack to play them.

    -Bri
     
  4. helpme

    Member helpme GBAtemp Fan

    Joined:
    Nov 23, 2005
    Messages:
    478
    Location:
    uk
    Country:
    United Kingdom
  5. boxo
    OP

    Newcomer boxo Newbie

    Joined:
    Mar 31, 2008
    Messages:
    6
    Country:
    United Kingdom
    thanks for responding fellas.

    Like i said, i got both cards working using the software i mentioned below (i've just updated exploader to 0.55 - thanks) and both expansion packs work with my sandisk 2gb card. However when i plug in the 4gb SDHC card, when trying the browser i just get white screens - it happened when i used GBALDR to do a soft reset and it happened again after patching the browser. any ideas?
     
  6. boxo
    OP

    Newcomer boxo Newbie

    Joined:
    Mar 31, 2008
    Messages:
    6
    Country:
    United Kingdom
    i tell a lie - sorry. the patch worked, it just took a little while to start up. it's fine now. thanks again x
     
  7. boxo
    OP

    Newcomer boxo Newbie

    Joined:
    Mar 31, 2008
    Messages:
    6
    Country:
    United Kingdom
    are the expansion packs needed for using download play?
    Neither DS is mine so i rarely use them - they belong to my wife and daughter, i'm just setting them up.
     
  8. Bri

    Member Bri GBAtemp Psycho!

    Joined:
    Dec 25, 2007
    Messages:
    3,413
    Country:
    United States
    No, they're not used for anything but playing GBA games and for memory expansion for the browser. Oh, the EZ 3in1 is also a rumble pack (which sounds better on paper than in reality).

    -Bri
     
  9. boxo
    OP

    Newcomer boxo Newbie

    Joined:
    Mar 31, 2008
    Messages:
    6
    Country:
    United Kingdom
    ok, thanks again for the help, that's something i wasn't sure about.
    Are there any GBA games worth having? I thought it was an obsolete format.
     
  10. flashboy

    Newcomer flashboy Newbie

    Joined:
    Feb 3, 2008
    Messages:
    1
    Country:
    Sweden
    I have had some problems to use Moonshell and GBA Exploader since I got a new 2 gb memorycard from Kingston that I use with DSTT and EZ Flash 3-1, with my old 1 gb card there is no problem at all. But when I tries to load for example GBA Exploader my Nintendo DS freezes and has to be rebooted. It seems a bit picky about what memorycard you're using.

    Now I'm using the 1 gb card for Game Boy Advance, DS Organizer, Opera and games that use rumblepack like Metroid Pinball. But can't really tell why it wouldn't work with the 2 gb card, that makes no sense at all.
     

Share This Page