DS won't charge anymore, but battery still has power.

Discussion in 'NDS - Flashcarts and Accessories' started by Kirbzy, Sep 25, 2009.

  1. Kirbzy
    OP

    Newcomer Kirbzy Newbie

    Joined:
    Jan 25, 2008
    Messages:
    3
    Country:
    Australia
    Recently when trying to recharge my DS, I noticed that it doesn't work anymore (recharge light doesn't go on). I tried both the wall socket and usb charger, which both to this stage have worked fine. This would usually mean a dead battery, but there is still some charge currently left, and I can still turn the DS on and use it for a short while before it powers itself off. Is there a problem with the internal connection between the battery and the charger? Or is it something else? Cheers.
     
  2. KamuiX

    Member KamuiX GBAtemp Regular

    Joined:
    Jan 6, 2007
    Messages:
    125
    Country:
    Greece
    Noone is God or magician to tell you the problem, do your tests and find out what's the problem

    1st Go buy another charger and try (or borrow one from someone,or try charge someones DS with your charger).
    2nd Do the above similar thing with the battery (buy new,or borrow one,or try yours to other)
    3rd Check the power connector on the DS (the thing that looks like a mini-usb port on the ds) if it's broken inside. Then you can buy a repair part http://www.dealextreme.com/details.dx/sku.15854 Hope to have some skill to solder that.
    3rd Check that your house electricity is on and also your AC walll-plugs works. Idiotic step but you never now...
    4th Bad news the easy steps are over and your DS has a serious damage i think
     
  3. Steevsee

    Newcomer Steevsee Advanced Member

    Joined:
    Jan 25, 2008
    Messages:
    79
    Location:
    Aussie Game Wreckers
    Country:
    Australia
    Most likely cause would be a blown F1 Fuse. Easy fix if you have soldering experience.
    Check here for more info.
     

Share This Page