DS touch screen stays solid white

Discussion in 'NDS - Flashcarts and Accessories' started by poopo, Sep 24, 2007.

Sep 24, 2007
  1. poopo
    OP

    Newcomer poopo Member

    Joined:
    Oct 4, 2006
    Messages:
    11
    Country:
    Canada
    Ugh ... the DS lite slid off the desk and landed on it's bottom on a plastic office roll mat over carpet and now the DS bottom touch screen stays solid white.

    It's still responsive because I can test it with PictoChat, but I cannot see a thing on it, just stays solid white and lit up. There's a few threads about the top screen doing this, is it the same problem ? that the connector came loose ?

    Please inform,
    Thanks
     


  2. Urza

    Member Urza hi

    Joined:
    Jul 18, 2007
    Messages:
    6,493
    Country:
    United States
    Is it still under warranty?
     
  3. BakuFunn

    Member BakuFunn Flameproof.

    Joined:
    Apr 6, 2007
    Messages:
    1,174
    Location:
    New York
    Country:
    United States
    you could send it back to nintendo if you dont, and pay about 50-70 bucks, not really worth it
     
  4. iwakura

    Member iwakura HHNNNNNNGGGG

    Joined:
    Jul 20, 2006
    Messages:
    1,161
    Location:
    California
    Country:
    United States
    most likely a loose connector. if you're able to, open up the DS, snap open the connector hatch, push the cable in as farrrrr as you can and close the hatch (press hard)
     
  5. DarkAura

    Member DarkAura Offline

    Joined:
    Aug 20, 2007
    Messages:
    2,388
    Location:
    Over there.
    Country:
    Canada
    Don't drop your DS.
     
  6. poopo
    OP

    Newcomer poopo Member

    Joined:
    Oct 4, 2006
    Messages:
    11
    Country:
    Canada
    Not my luck I guess... i think it's just past warranty by a few days because it was for my birthday and that was a few days ago...

    I guess I'll call them and see. It also has a PSP plan with Best Buy, but the person that bought it for me lost the receipt.. ha ha.. I still have the box though, so I might give that a try as well and then if all else fails. I might consider opening it up and try to reconnect the connector.

    Sound right?
     
  7. DarkAura

    Member DarkAura Offline

    Joined:
    Aug 20, 2007
    Messages:
    2,388
    Location:
    Over there.
    Country:
    Canada
    Try reconnecting the connector first. Then if you can't make it work, contact Nintendo or Best Buy or w/e. No point in sending something in to Nintendo that you can fix yourself.
     
  8. iwakura

    Member iwakura HHNNNNNNGGGG

    Joined:
    Jul 20, 2006
    Messages:
    1,161
    Location:
    California
    Country:
    United States
    if he doesnt have the tools to open it himself then sending it in may be a better solution...
     
  9. Urza

    Member Urza hi

    Joined:
    Jul 18, 2007
    Messages:
    6,493
    Country:
    United States
    All you need is a triwing screwdriver.
     
  10. poopo
    OP

    Newcomer poopo Member

    Joined:
    Oct 4, 2006
    Messages:
    11
    Country:
    Canada
    I might give it a try first.... I've looked at all the links posted w/ instructions on how to open the DS. Looks ok, 'cept for the parts where you have to unplug the Wifi and Microphone wires....

    Can I get a Triwing screwdriver from any hardware store ?
     
  11. Heraisu

    Newcomer Heraisu Newbie

    Joined:
    Jul 24, 2007
    Messages:
    7
    Country:
    United States
    If he does open it, and it doesn't get fixed, though.
    Wouldn't that null his warranty, if they could tell somehow I mean.
     
  12. poopo
    OP

    Newcomer poopo Member

    Joined:
    Oct 4, 2006
    Messages:
    11
    Country:
    Canada
    I think I already nullified my warranty since I flashed it....

    This had to happen the night I get my R4!?!? bad luck....
     
  13. rhyguy

    Member rhyguy GBAtemp Maniac

    Joined:
    Jul 21, 2007
    Messages:
    1,377
    Location:
    Melbourne
    Country:
    Australia
    you could uninstall flash me and send it in
     
  14. flai

    Member flai Androgynous Apparently :)

    Joined:
    Sep 30, 2006
    Messages:
    850
    Country:
    United Kingdom
    Its probably a loose connector, its very, very easy to fix. There are loads of video tutorials on how to open up your Lite. Once you do it once you can do it with your eyes closed. Save yourself the money and do that.
     
  15. poopo
    OP

    Newcomer poopo Member

    Joined:
    Oct 4, 2006
    Messages:
    11
    Country:
    Canada
    Yep. I'll give it a try .... i just need to get a Triwing screwdriver now.
     
  16. arctic_flame

    Member arctic_flame GBAtemp ATMEGA8 Fan

    Joined:
    Nov 4, 2006
    Messages:
    2,840
    Location:
    England land
    Country:
    United Kingdom
    It's almost definitely a loose connector. It probably got knocked out.

    When I was replacing the case on my DS, this happened to me; it turned out I hadn't reconnected one of the ribbon cables to the bottom screen (there are 2, one for touch and one for the actual picture)
     
  17. DarkAura

    Member DarkAura Offline

    Joined:
    Aug 20, 2007
    Messages:
    2,388
    Location:
    Over there.
    Country:
    Canada
    People in other threads say to heat the tip of a pen and stick it in the screw, let it cool and you'll have a tri wing.

    Or you could use a 2mm flat screwdriver or something like that.
     
  18. .::5pYd3r::.

    Member .::5pYd3r::. Viva La Pizza

    Joined:
    Jun 2, 2007
    Messages:
    766
    Location:
    The GREAT Southern Land :D
    Country:
    Australia
  19. BakuFunn

    Member BakuFunn Flameproof.

    Joined:
    Apr 6, 2007
    Messages:
    1,174
    Location:
    New York
    Country:
    United States
    hardware stores
     
  20. poopo
    OP

    Newcomer poopo Member

    Joined:
    Oct 4, 2006
    Messages:
    11
    Country:
    Canada
    So I finally got the Triwing screwdriver in the mail today. Opened it up, pretty easy.

    The connector for the bottom screen seemed ok... pulled it out, reseated it anyways. Turned it on .... but it's still solid white. What else could it be ? Could the cable have been damaged by a drop ? or something more severe? the whole screen?
     

Share This Page