DS not charging?

Discussion in 'NDS - Flashcarts and Accessories' started by blizeH, Apr 7, 2007.

  1. blizeH
    OP

    blizeH GBAtemp Fan

    Member
    465
    0
    Dec 21, 2005
    UK
    Hi guys,

    My cousin has a problem with his DS; when you turn it on nothing happens, and it won't charge either. If you try plugging the charger into the DS then the charging light will come on very briefly and then go out again, so it's almost like the battery has died and won't charge anymore [​IMG]

    I've tried a different charger and also tried swapping the batteries in that DS with his sister's DS and still no luck with getting the thing to turn on or charge.

    Any suggestions would be great, thanks!
     
  2. Godot0102

    Godot0102 Advanced Member

    Newcomer
    91
    0
    Feb 21, 2007
    United States
    Was this ds modded?
     
  3. pewpz

    pewpz GBAtemp Regular

    Member
    132
    0
    Dec 2, 2005
    United States
    NorCal
    Seems like you've done as much as you can do. Other than taking it apart and checking for loose nuggets, there isn't much you can do. If it's out of warranty, then just pay Nintendo and get it fixed.
     
  4. blizeH
    OP

    blizeH GBAtemp Fan

    Member
    465
    0
    Dec 21, 2005
    UK
    It's been flashed so sending it back to get fixed isn't an option unfortunately! [​IMG] Taking it apart is a good idea as a last resort though, what kind of thing/area should we be looking at?
     
  5. 4saken

    4saken Retired Ace Attorney

    Member
    3,358
    3
    Nov 28, 2006
    NoFlashMe to the rescue! It might not fully remove the traces - but it should be enough >_>. Usually if something is disconnected the DS turns off automatically. You should be looking for any loose connections around the charger port. From your description (the light flashes on for a second), I wouldn't think it is a loose connection - but check anyway
     
  6. byran

    byran Newbie

    Newcomer
    9
    0
    May 9, 2006
    United States
    hey man, mine did this, well...it played but didnt charge...the fuse right underneath the charger input on the circut came half off, so i resoldered the fuse down and that was murder she wrote....works like a charm now.....

    so really ask him if it still played before it died but didnt charge, if so its probably the same thing, there soo tiney....

    gotta be more carefull from now on
     
  7. Akoji

    Akoji +5 internets to psyfira for avatar.

    Member
    1,774
    0
    Nov 8, 2002
    Canada
    lachine qc. canada
    Mine does exactly the same thing , but the weird part is that it the brand new one i just received from nintendo back from it reparations... So i think i will have to send it back again (i just received it today and yes i charged it , but it does the same thing.) ... im starting to hate nintendo costmer service.
     
  8. blizeH
    OP

    blizeH GBAtemp Fan

    Member
    465
    0
    Dec 21, 2005
    UK
    Awesome, cheers guys, going to buy one of these for myself for when I want to mod a Wii (if I ever get one [​IMG]) and I presume it'll work just fine with both old style DS and the DS Lite?
     
  9. Sinkhead

    Sinkhead yay p1ngpong.

    Former Staff
    3,692
    0
    Nov 22, 2006
    Across the pond
    Yeah it will

    - Sam
     
  10. thegame07

    thegame07 GBAtemp Psycho!

    Member
    3,860
    103
    Oct 16, 2006
    I have the exact same problem. It started two days ago. I dont know why this is happend to me because my ds has never been droped and its been looked after really carefully. I dont take it out in my pocket or anything. [​IMG] So have we foudn another defect. IS your nds a lite?
     
  11. blizeH
    OP

    blizeH GBAtemp Fan

    Member
    465
    0
    Dec 21, 2005
    UK
    Nice, thanks Sam, will order it a bit later today!

    thegame; nope, it's an old standard DS that he's using!
     
  12. blizeH
    OP

    blizeH GBAtemp Fan

    Member
    465
    0
    Dec 21, 2005
    UK
    Took it apart, couldn't see anything particularly wrong; what should I be looking for?
     
  13. TLSpartan

    TLSpartan Kills threads

    Member
    2,053
    0
    Oct 20, 2006
    Any dislodged parts(SMD's,etc). Check near the charging slot. Take a picture of the board so we can help you.