DS Lite touch creen screwed up-

Discussion in 'NDS - Flashcarts and Accessories' started by JPH, Aug 12, 2006.

Aug 12, 2006

DS Lite touch creen screwed up- by JPH at 7:50 PM (745 Views / 0 Likes) 6 replies

  1. JPH
    OP

    Banned JPH Banned

    Joined:
    Jul 11, 2006
    Messages:
    6,892
    Country:
    United States
    atleast I think, my touch screen isn't responding to most of my touch, anyone else had this problem? Could you help me out on this problem? [​IMG]
     
  2. Xeronage

    Member Xeronage GBAtemp Advanced Fan

    Joined:
    Aug 6, 2006
    Messages:
    612
    Country:
    So the touch screen is responding to you touching it..... isn't that very normal?


    If you mean it ISNT responding, use a toothbrush to clean the edges =) works for me!
     
  3. JPH
    OP

    Banned JPH Banned

    Joined:
    Jul 11, 2006
    Messages:
    6,892
    Country:
    United States
    Um, thanks for the help but putting Crest on my DS Lite's touch creen doesn't seem like it'd work, just make it worse.
     
  4. RyuKakashi

    Member RyuKakashi GBAtemp Fan

    Joined:
    Mar 18, 2006
    Messages:
    450
    Country:
    United States
    Toothpaste is usually used to clean...rougher surfaces or seal CD scratches...i've never heard of anyone using it on a touch screen. I personally use pledge electronics or just water. But no matter how dirty a screen is, it shouldn't just not respond....
     
  5. Xeronage

    Member Xeronage GBAtemp Advanced Fan

    Joined:
    Aug 6, 2006
    Messages:
    612
    Country:
    Who said I was using toothpaste? and the official DS site recommends using a toothbrush for the edges.
     
  6. JPH
    OP

    Banned JPH Banned

    Joined:
    Jul 11, 2006
    Messages:
    6,892
    Country:
    United States
    Hey guys, thanks for your help, I cleaned it( with a wet clothe) and scrubbed it a little with a toothbrush. Works normal Thanks guys....Xeronage your right my mistake!
     
  7. GoombaPoop06

    Banned GoombaPoop06 Banned

    Joined:
    Jun 7, 2006
    Messages:
    36
    Country:
    Belgium
    I did both those things ,it is starting to act up again! Im gonna go attempt to fix it again!
     

Share This Page